Install The 1.7.10 Pack

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (The 1.7.10 Pack) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select The 1.7.10 Pack from the list on the left. The launcher will handle everything else!

The 1.7.10 Pack Version 0.10.11

created by xJon on Minecraft 1.7.10 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
when I load any world or try to create one it crashes only happened when I updated to 0.9.8c
antwo234 4 years ago
Please go to the "Help" section to get help!
Posted by xJon 4 years ago | Modpack Creator
i own a server and when i click on my server to join it loads for 5 seconds and then crashes and closes the game. everything is updated but this is still happening. whats going on with it
totfc 4 years ago
Please go to the "Help" section to get help!
Posted by xJon 4 years ago | Modpack Creator
@hi its me, its still doing the same thing. i cant join single player or my server. everything is up to date. what is going on?!
Posted by totfc 4 years ago
Can we have morphieus where we can fly with bats?
PokenKind 4 years ago
Same, got the same problem with most other people on http://solder.endermedia.com/repository/mods//wr-cbe/wr-cbe-1.4.1.11.zip
_JTYJ_ 4 years ago
We're working on this issue, and will post status updates when it gets resolved. Thank you for your patience!
Posted by xJon 4 years ago | Modpack Creator
alright thanks man, really looking forward to this pack
Posted by _JTYJ_ 4 years ago
cant download the pack keep getting http://solder.endermedia.com/repository/mods//wr-cbe/wr-cbe-1.4.1.11.zip
hellders99 4 years ago
Tried to update to version 0.9.8b. But every time i get "Failed to download http://solder.endermedia.com/repository/mods/guide-api/guide-api-1.0.1-20.zip" Any way to fix this?
Hate_of_the_Aztec 4 years ago
I can't download the mod pack, it says it failed to download wr-cbe-1.4.1.11, I've tried running other versions of the pack but none seem to work so far.
pegasus3265 4 years ago
so im having trouble downloading the 1.7.10 pack because some mod called wr-cbe is not downloading and i was wondering how to fix it
wickedland 4 years ago
I just gotta ask, is there a particular reason draconic evolution isn't in this pack? Do you just not like it or are there compatibility issues?
joalars 4 years ago
Didn't really fit the old-fashioned style of the pack, but feel free to add it in manually!
Posted by xJon 4 years ago | Modpack Creator
so i was trying to use flans mod panzer IV and pak 40 but i can seem to find the shells or ammo for it? any help
lmaoitsperry 4 years ago
whats the best texture pack to run with this
Ewanws 4 years ago
I crafted the Golemancy bell for thaumcraft while on a server and it crashed my client and I cant connect to the server anymore while other people are still able to, help?
Sexypelican 4 years ago
I am having issues downloading the mudpack 'Botania' while downloading this mod pack. I've tried downloading the launcher but there is no change. suggestions?
jack1a 4 years ago
Hi, can you try again?
Posted by xJon 4 years ago | Modpack Creator
still failed to download Botania :(
Posted by jack1a 4 years ago
Should work now.
Posted by xJon 4 years ago | Modpack Creator
I cant find the ip adress for the server so i can play with my friends. Does anyone know how to get it?
kaij0032 4 years ago
Hi I am having trouble with this modpack I will load it up but it will be stuck on a black screen (I’ve waited for hours but nothing happens) Thanks
JeanValjean24601Cat 4 years ago
Please go to the "Help" section to get help!
Posted by xJon 4 years ago | Modpack Creator
[Whitelisted] [Dedicated Server] Looking for new players to join our server!
tobyp911 4 years ago
For some reason my Iron tools arent working. I can mine faster with my hands than I can my iron pickaxe. Ive also noticed that my iron axe, and iron shovel dont do anything either. i tried a stone shovel for testing, also nothing. the only tool i have that works is one i looted, some obsidian rated pickaxe, cant remember name.
Exsilium 4 years ago
Its a Thaumium Pickaxe. Also, i can mine stone with sheers... but not iron pickaxe. go figure.
Posted by Exsilium 4 years ago
I tried to create a new world. exactly the same problem.
Posted by Exsilium 4 years ago
Hi, I'm curious as to the hardware requirements of this pack? I have a fairly sub-par laptop and was wondering if there's an alternative or if this would run somewhat smoothly? Never actually tried this many mods before :/
TheEmeraldFish 4 years ago
You can always try to run the modpack but with performance-enhancing mods added (like Optifine, version D6) and also a short render distance.
Posted by xJon 4 years ago | Modpack Creator
You need to add the ExRollercoaster mod!!! (P.S. It Does NOT require any library mods!)
alexbex822 4 years ago
Hi, i made a server for this modpack today and me and my friends have been dealing with some issues with it. When we try to log in the server we are instantly disconnect and recieve a messagem saying the following: ''A fatal error has occured, this connection is terminated.''
Kuaruki 4 years ago
Please go to the "Help" section to get help!
Posted by xJon 4 years ago | Modpack Creator

Latest Update

The 1.7.10 Pack was updated to version 0.10.11