Install Tekxit 3 LE (Official) 1.12.2

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Tekxit 3 LE (Official) 1.12.2) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Tekxit 3 LE (Official) 1.12.2 from the list on the left. The launcher will handle everything else!

Tekxit 3 LE (Official) 1.12.2 Version 0.990

created by Slayer5934 on Minecraft 1.12.2
You must be logged in to comment. Click here to register a new account or log in.
whatever this means i would like to know i have 16gb ram and i give this modpack the recommended amount and i get this plus a lag spike...not happy.. and i know its not my computer..anyways any tips that be great. [12:16:27] [Server thread/INFO]: Saving chunks for level 'something'/overworld [12:16:27] [Server thread/INFO]: Saving chunks for level 'something'/ExtraUtils2_Quarry_Dim [12:16:27] [Server thread/INFO]: Saving chunks for level 'something'/Storage Cell
Luicferdotexe 9 months ago
i also get this very often [12:15:46] [Server thread/INFO]: Saving chunks for level 'something'/overworld [12:15:46] [Server thread/INFO]: Saving chunks for level 'something'/ExtraUtils2_Quarry_Dim [12:15:46] [Server thread/INFO]: Saving chunks for level 'something'/Storage Cell
Posted by Luicferdotexe 9 months ago
If i put aluminium cabbles next to IC2 generators i get massive lag
LuckySickGuy11 9 months ago
my game have two types of marble, one from chisel and one from quark, and i cannot use them to make the same things even though they look the same.
LuckySickGuy11 9 months ago
The modpack isn't letting me install it.
wolfslayer56 9 months ago
Tried to start a server but everytime the server stops in a command line saying it's missing some galacticraft files, i already download and moved the mod manually and it still happens, any clue to fix this?
Finder1691 9 months ago
the file missing is galacticraft machine4 and i can't find any solution on web
Posted by Finder1691 9 months ago
hi the modpack is not starting https://paste.dimdev.org/pecuqitohi.mccrash
kicsibors 9 months ago
Keep getting crashes because of "IO" mods, been happening ever since 0.97 update, anyone knows how to fix this? https://paste.dimdev.org/luvacowivi.mccrash
BunnMan 9 months ago
Need some help. I made the nano saber and nano shield but the shield is really usless since i cant block bcs that activates my saber :P cant seem to find where to change this in the ic2 controls either :P
vet_1kke 9 months ago
Wondering if this is as good as tekkit and hexxit individually?
MxSyd 9 months ago
dont worry just downloaded winrar and its ok
NegativeCut___ 9 months ago
its not letting me open it and 0.972Tekxit3Server.7z and is not a server pack can someone help
NegativeCut___ 9 months ago
im trying to do the server download and everytime it just says "This file does not have an app associated with it for performing this action. Please install an app or, if one is already installed, create an association in the default apps settings page." Please help me out
sTW_Mericle 10 months ago
Reinstall Java/JDK Just google Java Install / JDK
Posted by Sheepord 9 months ago
Can someone help me please? I'm trying to make a Hamachi server and it doesn't work.
Gabi_Funoby 10 months ago
Why is it so slow and laggy?
SMCGamerOrig 10 months ago
When the game launches it Says that the mod Ender IO has problems with the rest of the mods can someone help me? or have something that i can do?
AKTPenguin 10 months ago
creative core crashing what should I do?
bobisjeebus2 10 months ago
Error Message when downloading modpack, "Error downloading a file for the following pack: Tekxit 3 (Official) 1.12.2 Failed to download https://www.tekx.it/downloads/0.972Tekxit3.zip Please consult the modpack author" Windows 10 Download other modpacks fine, deleted entire technic launcher and redownloaded and tried again. Any help appreciated
SlippitySlapJnr 10 months ago
-SOLVED- Updated Java and downloads fine
Posted by SlippitySlapJnr 10 months ago
So I tried downloading this modpack to experience it, and I used the recommended Ram and everything; But When the game launches it Says that the mod Ender IO has problems with the rest of the mods; Anyone can Help me? The report link is here: https://paste.dimdev.org/oralitaqeh.mccrash
Evaristacion 10 months ago
Generally speaking... that's an error from the pirate version of technic, but it could be another thing idk
Posted by Myttae 10 months ago
I have the 64 bit java and it seems to be running. The problem is that when I launch all I get is the sound and it says its open. I don't see ANYTHING. Its like it is invisible.
SmallToe 10 months ago
Hey, so, the modpack loads up just fine, but everytime i want to create a new world or join a server I am stuck in the dirt screen, then minecraft just freezes. the log doesn't say anything at all and i have enabled 3.5GB for the modpack, my current Java Version is 64 bits 1.8.0_241 I've already deleted the .technic file from the installation path, but it still doesn't seem to work. should i maybe downgrade Java?
_Ryz3n_ 10 months ago
im not sure if our computers are different but for me it does that but eventually it gets cleared up and it loads if it doesn't load I don't know what to say
Posted by bobisjeebus2 10 months ago

Latest Update

Tekxit 3.14 Beta is out now, just search for it in the launcher! Thank you all for playing Tekxit and to those who have donated to my patreon or gotten a bisect server using the code!