Install Tekxit 3 LE (Official) 1.12.2

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Tekxit 3 LE (Official) 1.12.2) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Tekxit 3 LE (Official) 1.12.2 from the list on the left. The launcher will handle everything else!

Tekxit 3 LE (Official) 1.12.2 Version 0.990

created by Slayer5934 on Minecraft 1.12.2
You must be logged in to comment. Click here to register a new account or log in.
so i just downloaded this mod on the tech launcher to join my friends and it doesnt seem to load any visuals, ive tried every fix-it iv found on the internet but nothing seems to be working... id really like to be able to join my friends in the fun that they are having...
Bonelyboi 6 months ago
Please could you try and add Mechanism. It would be great since it would fix only real problem I have with the pack and that is that it is incredibly annoying to try and set up electrics when there isn't a good way for devices from different packs to interact.
kingtom523 6 months ago
d
dodoro51 6 months ago
is tinker constuct in ths pack ? i thought i saw it wasnt just wanne have the full experience
BoogSiPop 6 months ago
How do I get the tekxit to use forge version 14.23.5.2854 instead of 14.23.5.2847? Deleting and reinstalling the launcher won't change the version and i need the new version to connect to a server...
Coi_Dat_Boi 6 months ago
ha thank to me the dicussion isnt on 420 anymore
Xx77ghost77xX 6 months ago
Is it possible if you can add the Mekanism mods "Mekanism, Mekanism generators, Mekanism Tools" to the modpack? That would attract a lot more players to download the modpack who like to play Mekanism.
TheMegalodon474 6 months ago
Hey have you considered addin Davinci's Vessels to the pack?
soph1703 6 months ago
What do I do if I can download the mod pack but can't get it to open correctly. Meaning that I can't get any picture, and I only get sound sometimes. Other then that it is just a blank page that doesn't work.
WizBangWow25 6 months ago
When I put the mod in fullscreen mode, It only goes in the corner of my screen and the rest is black. Is there anyway I could fix this? (Im on Mac)
padric1938 6 months ago
TechnicLauncher can't download the modpack
Sonnyy 7 months ago
should work again.. some issues with our webserver
Posted by itsWiLLERtime 7 months ago
Is there any way to add a shaders modpack with this too?
Tekashi401 7 months ago
Hi, would it be possbile to add Forestry to the modpack? Cheers
jirka7251 7 months ago
Why doesn't this pack like Itemphysics, I've seen other packs work with it?
BADVIBES999 7 months ago
Hi, was decocraft removed from the pack? I thought it used to be a part of it
kalekempton 7 months ago
The 1.990 update broke my game. I was using 0.981 before updating. When I select a world it says the game crashed and that Xaero Minimap and Lag Goggles may have caused it. I can't downgrade to 0.981 - the only option in Technic launcher is 0.990
augis122 7 months ago
I've resolved the issue by downgrading
Posted by augis122 7 months ago
I can’t log on to the server I was playing on with this new update. Can I revert it back?
BlackThunderB 7 months ago
https://www.tekx.it/help.html click the option under "Client Downgrade (Techniclauncher)" and follow the steps. The zip file to download is at https://www.tekx.it/tekxit3.html under "Client"
Posted by augis122 7 months ago
PLS add chicken chunks loader mod :)
Czeladnikov 7 months ago
Can anyone help me figure out how to transfer my world to the newest update?
1Von1 7 months ago
Why can't I launch this game? I am on MacOS. I am concerned about why whenever I launch a game, it would say; "You have chosen java version 14.0.1, which is known to have issues with Minecraft. Are you sure you want to continue?" I say; "Yes." and it wouldn't open, and I have tried everything for days. Could you help? (Sorry if I sound demanding.)
SuperCaitlin537 7 months ago
You need java 8, not 14. At least I'm assuming that's what's going on here. If you want join our discord and I can handle it better there.
Posted by ghost_924 7 months ago

Latest Update

Tekxit 3.14 is nearing it's release, go play that instead, it's better in every way at this point :P