Install Steve's Galaxy (Legacy)

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Steve's Galaxy (Legacy)) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Steve's Galaxy (Legacy) from the list on the left. The launcher will handle everything else!

Steve's Galaxy (Legacy) Version 1.4.4

created by endermedia on Minecraft Version 1.7.10 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
I really wish my sound would work... and I reopened the pack to see if it would start with sound and my world was gone.
z dog4444 4 years ago
The game just. . . committed suicide? Imploded? I don't know. In the chat, it said "OpenGL Error 128: Stack Overflow" or something a few times. Then it kicked me out of my plane (I was in a Flan's Mod fighter jet at the time) and the area below me. . . disappeared. Chunks started un-loading(?) and, when chunks tried to load, they disappeared. It was very disturbing, somehow. HALP, ANYONE? PS: I doubt it is a problem with my graphics, I have a gr8 computer
zwarren03 4 years ago
It still stops for 85% for me, i reinstalled it, still didn't work. It also makes the enchanting sound.
TimH3000 4 years ago
just waith for a wile it will continue for me it took about 10 mins
Posted by scubasausage 4 years ago
It might be an issue of RAM, dedicate more than 1gb, if you don't have that option get java 64x
Posted by Will_thebuilder 4 years ago
Whare can I download this mod pack please help!!!
hermony 4 years ago
what is IP?
fmarquez1 4 years ago
Has anyone figured out how to make red wool? I can't make this without flowers and I need it for Oxygen tanks to escape the planet and play the storyline
christopherkev 4 years ago
I figured out the red wool problem, anyone else gets stuck let me know.
Posted by christopherkev 4 years ago
havent started, but fixing?
Posted by fmarquez1 4 years ago
I dont know if this is just me but i cant open my launcher. it stops going at resources and then stops working please tell me how to fix this i love a modpack with a story
Vejas18LT 4 years ago
The launcher was under DDoS attack, it seems okay now.
Posted by christopherkev 4 years ago
It stops loading at 85% and i hear the enchantment sound. what should i do? i really love this pack but it hasn't worked in the past year
KBCreeperSlayer 4 years ago
i have this too
Posted by Novous 4 years ago
The launcher was under DDoS attack, it seems okay now.
Posted by christopherkev 4 years ago
Why is this named the force awakens pack if it's referenced as steves galaxy in everything else
The new update to take out the Christmas textures destroyed my world saves!!
Tahtinen5 4 years ago
whats the server ip?
maxmogens 4 years ago
can conect to server !!!
Rafael3110 4 years ago
when is the server up
Timtamtom 4 years ago
When I load the modpack it stops loading the game at 85%... I sat there for an HOUR. just closed it... is this fixable?
Dreviosus 4 years ago
if you do not hear a sound like a potion o' experience than delete the pack and reinstall
Posted by Tahtinen5 4 years ago
is this server down???? i was excited to play this server :(
enderkiller222 4 years ago
Not trying to sound like a spaz but i am SO excited to start playing this tomorrow! (too busy tonight) I've been searching FOREVER for a modpack like this with a server!!
Dreviosus 4 years ago
Can i request MCHeli to be added to this modpack? I think it would be absolutely fucking amazing, especially when traversing the earth in style, forming little army squads, if you dont plan on going to space, rule the wasteland with your arsenal of planes and heli's and such :P i am obsessed with the follow mods that ARE on this modpack: Flans, Galacticraft, ModularPowerSuits, Sync, and Simply Jetpacks. As well as MCHeli which is not added, again I am suggesting with my best hopes of you adding MCHeli, I think it will be a SUPERB addition to the modpack. considering that in real life you surely would find planes and helicopters around the planet to use for your own deeds. :) Thank you for your time to read this!
Dreviosus 4 years ago
I installed java 64-bit and it works
bandanrab 4 years ago
i very like Steve's Galaxy and Hexxit
alibali 4 years ago
How do I change the red sand to dirt? help please!
rayendexter 4 years ago
I am playing on v1.2.0 due to the red sand on the updates. 1.2.0 is right before they added the red sand. Hope that helps you out.
Posted by FearfulInk 4 years ago

Latest Update

Introducing our latest modpack, Mianite Reborn, everything you wish Mianite S3 would have been, including an awesome community server, learn more at http://endr.me/reborn