Install Steve's Galaxy (Legacy)

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Steve's Galaxy (Legacy)) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Steve's Galaxy (Legacy) from the list on the left. The launcher will handle everything else!

Steve's Galaxy (Legacy) Version 1.4.4

created by endermedia on Minecraft Version 1.7.10 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
Can someone help me? What is the server IP. I already tried PLAY.STEVESGALAXY.COM
Pyrosion 3 years ago
hey, i played for 2 days and it worked perfectly fine, then when i tried to open up my world it closed minecraft down and put me back into the mod launcher and keeps doing this whenever i try to launch my world, anyone who knows how to fix this?
isacwennberg 3 years ago
i had the dame problem dont know how t fix it or if you can fix it
Posted by silverwolf1313 3 years ago
That happened to me but I found out you just have to reinstall the pack
Posted by Superknight 3 years ago
This modpack does not want to work, when it goes to 85% it hangs. Forgiveness for the way of speaking is translated from GOOGLE TRANSLATION (;
aymane25 3 years ago
This is an old and abandoned modpack. But there is another modpack very similar to this: Mineout 3. Try it- http://www.technicpack.net/modpack/mineout-3-age-of-destruction.930215
@PaulNoir 3 years ago
my backpack glitched out anyway to get it back?
drewski444 3 years ago
no server?
Cantingprism83 3 years ago
i cant play it it stops at 85% when loading fix these crashes
Yeti98gamingtodeath13 3 years ago
how to add more planets
Gargani 3 years ago
I play the mod for a day then the next day it crash and NOW i cant play it anymore??? HELP
Bluepie 3 years ago
yop
NeferGame 3 years ago
First time downloading mods in general and i have no idea what to do past downloading the folder called steves-galaxy_1.4.4. help?
drewski444 3 years ago
I updated my Java and it still wont work for me. So what now?
DarkQueen2010 3 years ago
Can you help me ? I am blocked at 85% and I can't use java runtime environnement version 8 update 71 .
starlator508 4 years ago
same here, hopefully someone can fix this.
Posted by Chrisdaval 3 years ago
c'est pareil pour moi bloquer a 85 % bloquer pour le ressource pack
Posted by ArXis 3 years ago
il faut que je me mette en quel version de minecraft pour pouvoir jouer ????
Ug-Vargas 4 years ago
forge 1.7.10
Posted by starlator508 4 years ago
Is there any way to add extra planets in this?
Joeman300 4 years ago
when i try to add the extra planets mod into this it always crashes. Anyone know how to fix this?
Joeman300 4 years ago
TIp: I use some mods to make the galaxy even cooler: Starminer mod, Portalgun mod and warpdrive mod. I also used more planets for galacticcraft to go to saturn etc. but that crashed my laptop.
Crizarro 4 years ago
i can get in im stuck at 85 %
toby4 4 years ago
LOL, the website is a ........ Just look at it: play.stevesgalaxy.com
Aleksandar204 4 years ago
thx
Posted by Demonboy05 4 years ago
thehit boxes are mest up for me i cant hit any thing so i did f3 h and the hit boxes on my player were in the wa of me hitting any thing! how do i fix this
demolition36 4 years ago

Latest Update

Introducing our latest modpack, Mianite Reborn, everything you wish Mianite S3 would have been, including an awesome community server, learn more at http://endr.me/reborn