Install Steve's Galaxy (Legacy)

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Steve's Galaxy (Legacy)) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Steve's Galaxy (Legacy) from the list on the left. The launcher will handle everything else!

Steve's Galaxy (Legacy) Version 1.4.4

created by endermedia on Minecraft Version 1.7.10 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
WHY WOULD YOU DISCONTINUE STEVES GALAXY!!!!!!!!!!!!!!!!!!iiiii!!!!!!!!!!!!!WHY?!?!?!?!?!?!?!?
SuperSonic1234 4 years ago
That's fine, discontinue your support for this mod. But could you at lease leave us your last stable version of server and client???!!!! Can we have a link to previous versions?
jasonoldy69 4 years ago
The official server has been discontinued.
I cant connect to a server The game always sais: no further information
hinouzer 4 years ago
alternative servers? i love to play this on multiplayer...
Skranz 4 years ago
do you think you could add something so java 1.7.2 also could play?
nathalie3649 4 years ago
get 64bit java
Posted by rbnzdave 4 years ago
i need codechicken but i already got it and every time i launch there is an error that i need code chicken and the mod is unable to download it what can i do?
10Luke04 4 years ago
Pssssst, add Chisel!!! :DDDDDD
CsugTheThug 4 years ago
Alright, good news. I found that you can download the MrTJPCore here: http://www.curse.com/mc-mods/minecraft/229002-mrtjpcore/2242514. Sadly though, the server is not up. Have fun guys!
Challenger1_ 4 years ago
Looking into it more, I've found the server will never be back up. Here: http://stevesgalaxy.com/
Posted by Challenger1_ 4 years ago
Is this a safe download?
Posted by Jakedaddy36 4 years ago
Fix Please! I love this modpack and i cant play :(
juniorwhitworth 4 years ago
Whenever I try playing the modpack it tells me I need to install MrTJPCore-1.0.9.18-universal.jar file when i installed it I tried putting it into the folder C:\Users\%username%\AppData\Roaming\.technic\modpacks\steves-galaxy\mods\1.7.10 but it said that the folder didn't exist. Is this just a thing with mac?
AwesomeDud2 4 years ago
I got that same message: CB's DepLoader was unable to download required library MrTJPCore-1.7.10-1.0.9.18-universal.jar Check your internet connection and try restarting or download it manually from http://projectredwiki.com/maven/mrtjp/MrTJPCore/1.7.10-1.0.9.18//MrTJPCore-1.7.10-1.0.9.18-universal.jar and put it in your mods folder
Posted by Challenger1_ 4 years ago
cant download 1.4.4
K'tulu 4 years ago
I have a 5gb minecraft server sitting idle right now... I could throw this on it for the time being. If I do, what version should I put on it?
jim2029 4 years ago
If I click PLAY in Technic Launcher(TL), game starting and if reach 85% after one minute close minecraft and open TL. Sorry my bad english, but I am from Czech Republic If you help me start the game, i give you LIKE
GENS935 4 years ago
I have the same problem, It gets to 85% and then goes back to the Technic Launcher
Posted by Matteo17825 4 years ago
same problem
Posted by The_Darth_Vader 4 years ago
It looks like the Dev has ended support for this mod pack, It's a shame... but all things must come to an end. Such a shame, it was such a short run.
Deeluna 4 years ago
please fix it
TGD 4 years ago
why cant i download 1.4.4 please fix this
TH3_SKATER_KID 4 years ago
is the server down guys?
robinbodar101 4 years ago
It still says there is not a 1.4.4 version too download, its been 11 days still no fix .-.
11pikachu11 4 years ago
Also when reverting back to 1.4.1, which I can get to work, the server gives me this error [19:39:08] [Server thread/INFO]: Starting minecraft server version 1.7.10 [19:39:15] [Server thread/ERROR]: Encountered an unexpected exception cpw.mods.fml.common.MissingModsException: Missing Mods: Forge : [10.13.3.1384,11.14) at cpw.mods.fml.common.Loader.sortModList(Loader.java:244) ~[Loader.class:?] at cpw.mods.fml.common.Loader.loadMods(Loader.java:472) ~[Loader.class:?] at cpw.mods.fml.server.FMLServerHandler.beginServerLoading(FMLServerHandler.java:87) ~[FMLServerHandler.class:?] at cpw.mods.fml.common.FMLCommonHandler.onServerStart(FMLCommonHandler.java:314) ~[FMLCommonHandler.class:?] at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:117) ~[lt.class:?] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:387) [MinecraftServer.class:?] at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685) [li.class:?]
Posted by 11pikachu11 4 years ago
how i download MrTJPCore
eliispro 4 years ago
Hi eliispro, as mentioned by PSOK. Go to http://www.curse.com/mc-mods/minecraft/229002-mrtjpcore/2242514 and put the downloaded file (MrTJPCore-1.0.9.18-universal.jar) into C:\Users\%username%\AppData\Roaming\.technic\modpacks\steves-galaxy\mods\1.7.10
Posted by 9809 4 years ago

Latest Update

Introducing our latest modpack, Mianite Reborn, everything you wish Mianite S3 would have been, including an awesome community server, learn more at http://endr.me/reborn