Install Steve's Galaxy (Legacy)

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Steve's Galaxy (Legacy)) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Steve's Galaxy (Legacy) from the list on the left. The launcher will handle everything else!

Steve's Galaxy (Legacy) Version 1.4.4

created by endermedia on Minecraft 1.7.10 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
how can i download the modpack without downloading the app?
Nick_001 1 year ago
You could use MultiMC instead of Technic
Posted by EnderSalad 1 month ago
Does the More Planets addon for Galacticraft not work with this modpack? I tried installing it, and the game crashes.
N1ght5ky 1 year ago
Never mind I managed to fix it by updating the GalacticraftCore, Planets and the Micdoodlecore mod to the latest versions.
Posted by N1ght5ky 1 year ago
Does anyone know how I can get generated dirt to have grass spread
Abbinabb 1 year ago
hey um when i launch the game and try to customize it wont let me and all the what should be dirt is red sand how do i get the grass
chuckhope 1 year ago
i was having this problem downloading the pack 2 years ago and everyone else had the dirt not redsand
Posted by chuckhope 1 year ago
Go to the modpack folder, find the config folder, then find the file called "defaultworldgenerator". Open it and there will be an option that says "lockworldgenerator", set this to false and you will be able to select different world generation types when creating a new world.
Posted by Pyrisous 1 year ago
Does anyone know how to get milk earth has no cows and I can't travel to other planets to check I their I'd space cows
skeletonrockstar 1 year ago
Craft the Cow Backpack using Adventure Backpack, then grow some wheat and put it in the backpack. The backpack will consume the wheat and fill the tanks with milk.
Posted by dark14life 1 year ago
Forgot to mention that to get milk to craft the Cow Backpack you'll need to use the Fossils and Archaeology mod to grow a cow embryo from fossils. At that point, you'll have A cow, but using the Cow Backpack is quicker. Unless, that is, you somehow manage to get a bunch of cow embryos and then you can just make a herd of cows for yourself to supply milk.
Posted by dark14life 1 year ago
I have installed this mod and it works for me, in the technic launcher settings of this mod, choose specific version to 1.4.5 and reinstall the pack, close the settings window and install the pack again, this time it will install version 1.4.5.
Imperious909 1 year ago
Can confirm this works.
Posted by dark14life 1 year ago
Update log says loading is fixed, sadly this is not the case.
11thRaggedyMan 2 years ago
Under ModPack Options change it to run version 1.4.5.
Posted by dark14life 1 year ago
I've found out it's because you're using FMP (Forge Multi Part) version 345 something, whereas you should be using 344. If you can't find it, here's a dropbox link from the file that I still have:
DJ_4_3leXion 2 years ago
Download Forge ( and drop it into C:\Users\%username%\AppData\Roaming\.technic\modpacks\steves-galaxy\mods
Posted by ciaranvalari 2 years ago
Yo don't bother. This shit don't even download properly. I tried 6 different installs, looked at the logs, nothin. Just save yourself the trouble.
DatJayce 2 years ago
how do you download the vorbis java core
mcwo111 2 years ago
Buddz422 2 years ago
You can use an IndustrialCraft terraformer to create grass.
Posted by Pyrisous 2 years ago
Buddz422 2 years ago
Does anyone know how to get grass to spread on generated dirt in the world?
Buddz422 2 years ago
Is there anyway to get grass to spread again? I changed my world to dirt now none pf the dirt will spread into grass. Help please!
Buddz422 2 years ago
Error in downloading, the zombie awareness mod cannot be found, so download too because I love this modpack but have a new PC that I wanted to download this on.
Musicalogic 2 years ago
How do I stop the water source blocks that appear randomly?
Buddz422 2 years ago
Those aren't random. They're the result of meteorites crashing to the ground. Some have ice that melt into water blocks.
Posted by dark14life 1 year ago
[B#725] A detailed walkthrough of the error, its code path and all known details is as follows: [B#725] --------------------------------------------------------------------------------------- [B#725] [B#725] -- System Details -- [B#725] Details: [B#725] Minecraft Version: 1.7.10 [B#725] Operating System: Windows 8.1 (x86) version 6.3 [B#725] Java Version: 1.8.0_51, Oracle Corporation [B#725] Java VM Version: Java HotSpot(TM) Client VM (mixed mode), Oracle Corporation [B#725] Memory: 328808312 bytes (313 MB) / 1073741824 bytes (1024 MB) up to 1073741824 bytes (1024 MB) [B#725] Mod Pack: Unknown / None [B#725] LiteLoader Mods: 4 loaded mod(s) [B#725] - VoxelCam version 1.3.2 [B#725] - VoxelMap version 1.5.14 [B#725] - VoxelLib version 2.3.1 [B#725] - Mouse Tweaks version 2.4.4 [B#725] LaunchWrapper: 49 active transformer(s) [B#725] - Transformer: cpw.mods.fml.common.asm.transformers.PatchingTransformer [B#725] - Transformer: optifine.OptiFineClassTransformer [B#725] - Transformer: cpw.mods.fml.common.asm.transformers.MarkerTransformer [B#725] - Transformer: cpw.mods.fml.common.asm.transformers.SideTransformer [B#725] - Transformer: cpw.mods.fml.common.asm.transformers.EventSubscriptionTransformer [B#725] - Transformer: net.minecraftforge.classloading.FluidIdTransformer [B#725] - Transformer: appeng.transformer.asm.ASMIntegration [B#725] - Transformer: codechicken.lib.asm.ClassHeirachyManager [B#725] - Transformer: codechicken.core.asm.InterfaceDependancyTransformer [B#725] - Transformer: codechicken.core.asm.TweakTransformer [B#725] - Transformer: codechicken.core.asm.DelegatedTransformer [B#725] - Transformer: codechicken.core.asm.DefaultImplementationTransformer [B#725] - Transformer: fastcraft.asm.FastCraftTransformer [B#725] - Transformer: myrathi.infinibows.asm.BowTransformer [B#725] - Transformer: invtweaks.forge.asm.ContainerTransformer [B#725] - Transformer: [B#725] - Transformer: micdoodle8.mods.miccore.MicdoodleTransformer [B#725] - Transformer: codechicken.nei.asm.NEITransformer [B#725] - Transformer: li.cil.oc.common.asm.ClassTransformer [B#725] - Transformer: com.mumfrey.liteloader.transformers.event.EventProxyTransformer [B#725] - Transformer: com.mumfrey.liteloader.launch.LiteLoaderTransformer [B#725] - Transformer: com.mumfrey.liteloader.client.transformers.CrashReportTransformer [B#725] - Transformer: cpw.mods.fml.common.asm.transformers.DeobfuscationTransformer [B#725] - Transformer: cpw.mods.fml.common.asm.transformers.AccessTransformer [B#725] - Transformer: net.minecraftforge.transformers.ForgeAccessTransformer [B#725] - Transformer: appeng.transformer.asm.ASMTweaker [B#725] - Transformer: codechicken.core.asm.CodeChickenAccessTransformer [B#725] - Transformer: cofh.asm.CoFHAccessTransformer [B#725] - Transformer: invtweaks.forge.asm.ITAccessTransformer [B#725] - Transformer: micdoodle8.mods.miccore.MicdoodleAccessTransformer [B#725] - Transformer: cpw.mods.fml.common.asm.transformers.ModAccessTransformer [B#725] - Transformer: cpw.mods.fml.common.asm.transformers.ItemStackTransformer [B#725] - Transformer: cofh.asm.CoFHClassTransformer [B#725] - Transformer: lumien.resourceloader.asm.ClassTransformer [B#725] - Transformer: alexiil.mods.load.coremod.BetterLoadingScreenTransformer [B#725] - Transformer: cpw.mods.fml.common.asm.transformers.TerminalTransformer [B#725] - Transformer: com.mumfrey.liteloader.client.transformers.JoinGamePacketTransformer [B#725] - Transformer: com.mumfrey.liteloader.client.transformers.ServerChatPacketTransformer [B#725] - Transformer: com.thevoxelbox.common.TimeUpdateTransformer [B#725] - Transformer: com.mumfrey.liteloader.client.transformers.LiteLoaderEventInjectionTransformer [B#725] - Transformer: com.mumfrey.liteloader.client.transformers.LiteLoaderCallbackInjectionTransformer [B#725] - Transformer: com.mumfrey.liteloader.client.transformers.MinecraftOverlayTransformer [B#725] - Transformer: com.mumfrey.liteloader.client.transformers.LoginSuccessPacketTransformer [B#725] - Transformer: com.mumfrey.liteloader.client.transformers.CustomPayloadPacketTransformer [B#725] - Transformer: com.mumfrey.liteloader.client.transformers.ServerCustomPayloadPacketTransformer [B#725] - Transformer: com.thatapplefreak.voxelcam.VoxelCamTransformer [B#725] - Transformer: com.mumfrey.liteloader.client.transformers.ChatPacketTransformer [B#725] - Transformer: com.thevoxelbox.voxelmap.litemod.VoxelMapTransformer [B#725] - Transformer: cpw.mods.fml.common.asm.transformers.ModAPITransformer [B#725] JVM Flags: 9 total; -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=32M -Xms1024m -Xmx1024m -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump [B#725] AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used [B#725] IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0 [B#725] FML: MCP v9.05 FML v7.10.99.99 Minecraft Forge Optifine OptiFine_1.7.10_HD_U_C1 93 mods loaded, 93 mods active [B#725] States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored [B#725] UCHIJA mcp{9.05} [Minecraft Coder Pack] (minecraft.jar) [B#725] UCHIJA FML{} [Forge Mod Loader] (modpack.jar) [B#725] UCHIJA Forge{} [Minecraft Forge] (modpack.jar) [B#725] UCHIJA appliedenergistics2-core{rv2-stable-9} [AppliedEnergistics2 Core] (minecraft.jar) [B#725] UCHIJA CodeChickenCore{} [CodeChicken Core] (minecraft.jar) [B#725] UCHIJA InfiniBows{1.3.0 build 20} [InfiniBows] (minecraft.jar) [B#725] UCHIJA LanteaCraft-Core{1.0} [LanteaCraft Core] (minecraft.jar) [B#725] UCHIJA Micdoodlecore{} [Micdoodle8 Core] (minecraft.jar) [B#725] UCHIJA NotEnoughItems{} [Not Enough Items] (NotEnoughItems-1.7.10- [B#725] UCHIJA OpenComputers|Core{1.0.0} [OpenComputers (Core)] (minecraft.jar) [B#725] UCHIJA <CoFH ASM>{000} [CoFH ASM] (minecraft.jar) [B#725] UCHIJA betterloadingscreen{1.3.2} [Better Loading Screen] ([1.7.10] BetterLoadingScreen-1.3.2.jar) [B#725] UCHIJA bspkrsCore{6.16} [bspkrsCore] ([1.7.10]bspkrsCore-universal-6.16.jar) [B#725] UCHIJA Treecapitator{1.7.10} [Treecapitator] ([1.7.10]Treecapitator-universal-2.0.4.jar) [B#725] UCHIJA adventurebackpack{1.7.10-0.8b} [Adventure Backpack] (adventurebackpack-1.7.10-0.8b.jar) [B#725] UCHIJA appliedenergistics2{rv2-stable-9} [Applied Energistics 2] (appliedenergistics2-rv2-stable-9.jar) [B#725] UCHIJA CoFHCore{1.7.10R3.0.3B2} [CoFH Core] (CoFHCore-[1.7.10]3.0.3B2-294.jar) [B#725] UCHIJA ThermalFoundation{1.7.10R1.2.0B1} [Thermal Foundation] (ThermalFoundation-[1.7.10]1.2.0B1-95.jar) [B#725] UCHIJA ThermalExpansion{1.7.10R4.0.2B2} [Thermal Expansion] (ThermalExpansion-[1.7.10]4.0.2B2-210.jar) [B#725] UCHIJA BigReactors{0.4.3A} [Big Reactors] (BigReactors-0.4.3A.jar) [B#725] UCHIJA ChickenChunks{} [ChickenChunks] (ChickenChunks-1.7.10- [B#725] UCHIJA BuildMod{v1.0} [Build Mod] (coroutil-1.1.2.jar) [B#725] UCHIJA CoroPets{v1.0} [CoroPets] (coroutil-1.1.2.jar) [B#725] UCHIJA CoroAI{v1.0} [CoroAI] (coroutil-1.1.2.jar) [B#725] UCHIJA ExtendedRenderer{v1.0} [Extended Renderer] (coroutil-1.1.2.jar) [B#725] UCHIJA ConfigMod{v1.0} [Extended Mod Config] (coroutil-1.1.2.jar) [B#725] UCHIJA CustomMainMenu{1.5} [Custom Main Menu] (CustomMainMenu-MC1.7.10-1.5-client.jar) [B#725] UCHIJA lootablebodies{1.3.5} [DrCyano's Lootable Bodies] (CyanosLootableBodies-1.3.5-backport.jar) [B#725] UCHIJA defaultworldgenerator{0.1-b13} [Default World Generator] (DefaultWorldGenerator-1.7.10-0.1-b13-client.jar) [B#725] UCHIJA IC2{2.2.744-experimental} [IndustrialCraft 2] (industrialcraft-2-2.2.744-experimental.jar) [B#725] UCHIJA ForgeMultipart{} [Forge Multipart] (ForgeMultipart-1.7.10- [B#725] UCHIJA GalacticraftCore{3.0.11} [Galacticraft Core] (GalacticraftCore-1.7- [B#725] UCHIJA Mekanism{8.1.5} [Mekanism] (Mekanism-1.7.10- [B#725] UCHIJA EnderIO{1.7.10-} [Ender IO] (EnderIO-1.7.10- [B#725] UCHIJA FastCraft{1.21} [FastCraft] (fastcraft-1.21.jar) [B#725] UCHIJA flansmod{4.10.0} [Flan's Mod] (Flans Mod-1.7.10-4.10.0.jar) [B#725] UCHIJA FlatSigns{} [Flat Signs] (FlatSigns-1.7.10-universal- [B#725] UCHIJA fossil{1.7.10 Build 7.2.0} [Fossils and Archeology Revival] (Fossils_Archeology_Revival-1.7.10_Build-7.2.jar) [B#725] UCHIJA GalacticraftMars{3.0.11} [Galacticraft Planets] (Galacticraft-Planets-1.7- [B#725] UCHIJA iChunUtil{4.2.2} [iChunUtil] (iChunUtil-4.2.2.jar) [B#725] UCHIJA inventorytweaks{1.59-dev-156-af3bc68} [Inventory Tweaks] (InventoryTweaks-1.59-dev-156.jar) [B#725] UCHIJA IronChest{} [Iron Chest] (ironchest-1.7.10- [B#725] UCHIJA Waila{1.5.10} [Waila] (Waila-1.5.10_1.7.10.jar) [B#725] UCHIJA JABBA{1.2.1} [JABBA] (Jabba-1.2.1a_1.7.10.jar) [B#725] UCHIJA MrTJPCoreMod{} [MrTJPCore] (MrTJPCore-1.7.10- [B#725] UCHIJA ProjRed|Core{} [ProjectRed] (ProjectRed-1.7.10- [B#725] UCHIJA ProjRed|Transmission{} [ProjectRed-Transmission] (ProjectRed-1.7.10- [B#725] UCHIJA OpenComputers{} [OpenComputers] (OpenComputers-MC1.7.10- [B#725] UCHIJA LanteaCraft{1.0.0-70} [LanteaCraft] (LanteaCraft-1.7.10-70.jar) [B#725] UCHIJA LunatriusCore{} [LunatriusCore] (LunatriusCore-1.7.10- [B#725] UCHIJA Mantle{1.7.10-0.3.2.jenkins184} [Mantle] (Mantle-1.7.10-0.3.2.jar) [B#725] UCHIJA MekanismGenerators{8.1.5} [MekanismGenerators] (MekanismGenerators-1.7.10- [B#725] UCHIJA MekanismTools{8.1.5} [MekanismTools] (MekanismTools-1.7.10- [B#725] UCHIJA meteors{2.14.3} [Falling Meteors] (meteors-1.7.10-2.14.3.jar) [B#725] UCHIJA minechem{} [Minechem] (Minechem-1.7.10- [B#725] UCHIJA MineMenu{1.2.0} [MineMenu] (MineMenu-1.7.10-1.2.0.B44-universal-client.jar) [B#725] UCHIJA numina{} [Numina] (Numina- [B#725] UCHIJA powersuits{} [MachineMuse's Modular Powersuits] (ModularPowersuits- [B#725] UCHIJA powersuitaddons{} [Modular Powersuit Addons] (ModularPowersuitsAddons- [B#725] UCHIJA MouseTweaks{2.4.4} [Mouse Tweaks] (MouseTweaks-2.4.4-mc1.7.10-client.jar) [B#725] UCHIJA NetherOres{1.7.10R2.3.0} [Nether Ores] (NetherOres-[1.7.10]2.3.0-12.jar) [B#725] UCHIJA notenoughkeys{@MOD_VERSION@} [NotEnoughKEys] (NotEnoughKeys-1.7.10-1.0.0b29-client.jar) [B#725] UCHIJA ObsidiPlates{} [ObsidiPlates] (ObsidiPlates-1.7.10-universal- [B#725] UCHIJA openmodularturrets{2.0.1-137} [Open Modular Turrets] (OpenModularTurrets-1.7.10-2.0.1-137.jar) [B#725] UCHIJA fodc{1.6.1} [Ore Dictionary Converter] (OreDictionaryConverter-1.6.1.jar) [B#725] UCHIJA Ping{%MOD_VERSION} [Ping] (Ping-1.7.X-1.0.2.B6-universal.jar) [B#725] UCHIJA ProjRed|Transportation{} [ProjectRed-Transportation] (ProjectRed-1.7.10- [B#725] UCHIJA ProjRed|Exploration{} [ProjectRed-Exploration] (ProjectRed-1.7.10- [B#725] UCHIJA TConstruct{1.7.10-1.8.5.build957} [Tinkers' Construct] (TConstruct-1.7.10-1.8.5.jar) [B#725] UCHIJA ProjRed|Compatibility{} [ProjectRed-Compatibility] (ProjectRed-1.7.10- [B#725] UCHIJA ProjRed|Integration{} [ProjectRed-Integration] (ProjectRed-1.7.10- [B#725] UCHIJA ProjRed|Illumination{} [ProjectRed-Illumination] (ProjectRed-1.7.10- [B#725] UCHIJA ProjRed|Expansion{} [ProjectRed-Expansion] (ProjectRed-1.7.10- [B#725] UCHIJA RedstoneArsenal{1.7.10R1.1.1B1} [Redstone Arsenal] (RedstoneArsenal-[1.7.10]1.1.1B1-85.jar) [B#725] UCHIJA ResourceLoader{1.2} [Resource Loader] (ResourceLoader-1.2-client.jar) [B#725] UCHIJA Schematica{} [Schematica] (Schematica-1.7.10- [B#725] UCHIJA Shatter{4.0.0} [Shatter] (Shatter-4.0.0-client.jar) [B#725] UCHIJA simplyjetpacks{1.5.1} [Simply Jetpacks] (SimplyJetpacks-MC1.7.10-1.5.1.jar) [B#725] UCHIJA Stackie{} [Stackie] (Stackie-1.7.10- [B#725] UCHIJA Sync{4.0.0} [Sync] (Sync-4.0.0.jar) [B#725] UCHIJA tabbychat{} [TabbyChat] (TabbyChat-1.7.10- [B#725] UCHIJA ThermalDynamics{1.7.10R1.1.0B2} [Thermal Dynamics] (ThermalDynamics-[1.7.10]1.1.0B2-149.jar) [B#725] UCHIJA TiCTooltips{1.2.4} [TiC Tooltips] (TiCTooltips-mc1.7.10-1.2.4-client.jar) [B#725] UCHIJA tradeboothmod{} [Trade Booth Mod] (tradebooth. [B#725] UCHIJA WLM{1.4.3} [The Wasteland Mod] (Wasteland mod-1.4.4.jar) [B#725] UCHIJA weather2{v2.3.6} [weather2] (Weather-2.3.7.jar) [B#725] UCHIJA WR-CBE|Core{} [WR-CBE Core] (WR-CBE-1.7.10- [B#725] UCHIJA WR-CBE|Addons{} [WR-CBE Addons] (WR-CBE-1.7.10- [B#725] UCHIJA WR-CBE|Logic{} [WR-CBE Logic] (WR-CBE-1.7.10- [B#725] UCHIJA ZAMod{v1.9.5} [Zombie Awareness] (ZombieAwareness-1.9.6.jar) [B#725] UCHIJA McMultipart{} [Minecraft Multipart Plugin] (ForgeMultipart-1.7.10- [B#725] UCHIJA aobd{2.6.3} [Another One Bites The Dust] (AOBD-2.6.3.jar) [B#725] UCHIJA ForgeMicroblock{} [Forge Microblocks] (ForgeMultipart-1.7.10- [B#725] AE2 Version: stable rv2-stable-9 for Forge [B#725] CoFHCore: -[1.7.10]3.0.3B2-294 [B#725] ThermalFoundation: -[1.7.10]1.2.0B1-95 [B#725] ThermalExpansion: -[1.7.10]4.0.2B2-210 [B#725] Mantle Environment: DO NOT REPORT THIS CRASH! Unsupported mods in environment: optifine [B#725] NetherOres: -[1.7.10]2.3.0-12 [B#725] TConstruct Environment: Environment healthy. [B#725] RedstoneArsenal: -[1.7.10]1.1.1B1-85 [B#725] ThermalDynamics: -[1.7.10]1.1.0B2-149 [B#725] AE2 Integration: IC2:ON, RotaryCraft:OFF, RC:OFF, BC:OFF, RF:ON, RFItem:ON, MFR:OFF, DSU:ON, FZ:OFF, FMP:ON, RB:OFF, CLApi:OFF, Waila:ON, InvTweaks:ON, NEI:ON, CraftGuide:OFF, Mekanism:ON, ImmibisMicroblocks:OFF, BetterStorage:OFF [B#725] Launched Version: 1.7.10-Forge10.13.4.1448-1.7.10 [B#725] LWJGL: 2.9.1 [B#725] OpenGL: AMD 15D8:C9 GL version 4.6.14761 Compatibility Profile Context 30.0.13023.4001, ATI Technologies Inc. [B#725] GL Caps: Using GL 1.3 multitexturing. [B#725] Using framebuffer objects because OpenGL 3.0 is supported and separate blending is supported. [B#725] Anisotropic filtering is supported and maximum anisotropy is 16. [B#725] Shaders are available because OpenGL 2.1 is supported. [B#725] [B#725] Is Modded: Definitely; Client brand changed to 'fml,forge' [B#725] Type: Client (map_client.txt) [B#725] Resource Packs: [] [B#725] Current Language: English (US) [B#725] Profiler Position: N/A (disabled) [B#725] Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used [B#725] Anisotropic Filtering: Off (1) [B#725] [16:52:11] [Client thread/INFO]: [net.minecraft.client.Minecraft:func_71377_b:359]: #@!@# Game crashed! Crash report saved to: #@!@# C:\Users\SoleyAce\AppData\Roaming\.technic\modpacks\steves-galaxy\crash-reports\crash-2022-04-18_16.52.10-client.txt [B#725] Process exited with error code -1
SoleyAce 2 years ago
can anyone help me understand why my games not running?
Posted by SoleyAce 2 years ago
Under ModPack Options change it to run version 1.4.5.
Posted by dark14life 1 year ago
I downloaded forge multipart but it keeps giving me the error Forge mod loader has found a problem with your minecraft installation the mods and versions listed below could not be found ForgeMultipart : any The file 'logs/fml-client-latest.log' contains more information What am I doing wrong?
lillymunster 2 years ago
i have got the same issue have you found a way to resoled it yet?
Posted by SoleyAce 2 years ago
Force the modpack to run in 1.4.5 instead of 1.4.7 and it will work.
Posted by dark14life 1 year ago
anyone wanna play this together??
Tekkitor2015 2 years ago
How do I download this modpack using android
chandra27 2 years ago
Technic modpacks require Java edition, which is not available on Android
Posted by Pyrisous 2 years ago

Latest Update

The issues with Steves Galaxy launching correctly have been fixed. The pack should work as normal now. -LabMonkey