Install Steve's Galaxy (Legacy)

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Steve's Galaxy (Legacy)) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Steve's Galaxy (Legacy) from the list on the left. The launcher will handle everything else!

Steve's Galaxy (Legacy) Version 1.4.4

created by endermedia on Minecraft Version 1.7.10 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
I used to be able to play offline, but now i press play and it waits like 8 sec. and goes back to technic. why does this do this? my ram has not changed.
Nyx_Ender 6 days ago
For some reason, now when i try to play offline the launcher closes as normal, but then the game doesn't open. there is no crash report either. The game worked before, why does it not anymore? i have tried reinstalling it to see if that would work, but still nothing. PLEASE HELP!!!
Nyx_Ender 1 week ago
keeps on crashing at 85% can someone help me
phdq18 1 month ago
same
Posted by PythonProgrammer 2 weeks ago
was anyone able to fix this? i downloaded it today and am having the same issue
Posted by edregeski 2 weeks ago
i even gave it 4 gb of ram lol
Posted by edregeski 2 weeks ago
can u add build craft plss?
DeagleTheKing 1 month ago
can u add build craft plss?
DeagleTheKing 1 month ago
can u add build craft plss?
DeagleTheKing 1 month ago
when i go and try to launch steves galaxy it just closes and it doesent say any error it just crashes anybody know how to fix?? help fastt
duskoapostolki 2 months ago
The same thing happens to me! What's going on? Someone help us fix this problem please
Posted by Emasnab2 2 months ago
How do I get leaves/saplings so I can collect oxygen on other planets?
MasterBeef_ 2 months ago
how do i get colored wool?
risnar 2 months ago
In all honesty, its a shame that this got discontinued. Nevertheless, me and my friends play it because its a gem of a pack, even if there isnt even a proper wiki for it and its outdated. Based on the recent 1.12.2 pack, I have a feeling you aint dead yet. If you can, at least try to smoothen out some edges or maybe even recontinue the pack. There are still players commenting years after the discontinuation date, and for good reason. Then again, I doubt you shut it down without any reason. If the interest wasn't there, it makes total sense. However, it would be a godsend if you can at least push out one last update to update some mods in here that have addressed vital issues in the same time period. ( One major one being the intense lag spikes with OpenModularTurrets ). I hope you could consider this. Even if it changes one feature or fixes a pack like OpenModularTurrets, I'd bet that the dedicated players to this modpack would be eternally greatful (hope you read this lmao)
GamerDude976 4 months ago
how do you download the server
AwesomeTeddy09 9 months ago
i love this modpack but i dont know how to use it
polyton 10 months ago
dose any one now a sever ip for this modpack
Hdmjcnnfk 11 months ago
Yes i Do.. Its my own Ip AKA my own private Server
Posted by PlayerOnYT 4 months ago
Yes i Do.. Its my own Ip AKA my own private Server
Posted by PlayerOnYT 4 months ago
when it reaches 85% hangs and does not get bloody !!! what am I doing wrong can somebody help me????
nikosxxx 11 months ago
I get that to, unfortunately I don't know how to fix.
Posted by Reecey_pie29 10 months ago
make sure you have windows and java 64 bit and you give it more than one gb of ram
Posted by TheNukeLore 5 months ago
I got a bug with adventure backpacks where i accidentally filled a tank with MineChem hydrogen, and now it instantly crashes the game when I open the backpack. Anyone know a fix?
Blaze2658 11 months ago
can you change to a normal world?
rowpoke 11 months ago
How do i change the red sand to dirt i have tried to customize the wastland when i was creating a world but it wouldnt do anything when i clicked the customize button is there any way i could fix this or any other way to change the redsand to dirt
Colton2006712 1 year ago
If i start the modpack and it initializes and finishes my minecraft doesn`t start and when i start it on my own i cant join the Server
NyanCat0202 1 year ago
Same, I don't know why that happens
Posted by HeroTee 1 year ago
anybody wanna hop on to my server just msg ya boi
rosted_the_gamer 1 year ago
aye m8 im down
Posted by Sypher16 1 year ago
can i join
Posted by Hdmjcnnfk 11 months ago
o server funciona ?
Awrau1314 1 year ago

Latest Update

Introducing our latest modpack, Mianite Reborn, everything you wish Mianite S3 would have been, including an awesome community server, learn more at http://endr.me/reborn