Install Steve's Galaxy (Legacy)

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Steve's Galaxy (Legacy)) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Steve's Galaxy (Legacy) from the list on the left. The launcher will handle everything else!

Steve's Galaxy (Legacy) Version 1.4.4

created by endermedia on Minecraft 1.7.10 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
Pls add support for mac!
yatwins 9 years ago
This is a really cool modpack! Nice job with it! But can you please add the Aliens Vs Predators mod? It would be great if you can.
rhino4279 9 years ago
the same thing is happing to me with the black screen and then to the main menu i really like this modpack can u fix this plz
DANTASTIC 9 years ago
Why cant I play this pack every time I try to play it it loads then the screen goes black then it sends me back to the main menu. help me please
Flight N150XT 9 years ago
Why does it say Offline?
TheCrafter343+ 9 years ago
Why does it say Offline?
TheCrafter343+ 9 years ago
Help, I cant load the pack up :( !
Inadequate_Cash 9 years ago
This is my favourite modpack.
0Beechlgz 9 years ago
Hey anyone, i need help... what verson of java does this run, make it as accurite as possable plz, it would be a HUGE help, thank you
Killer_Octipus 9 years ago
Please, please add thermal dynamics to this pack!
datdenkikniet 9 years ago
Done :)
Posted by Amaxter 9 years ago
whenever i click install it downloads for about 5 minutes then stops how do i fix this
hharper55 9 years ago
Same problem here
Posted by Tristan2020 9 years ago
How do I go about adding plugins to a private server for me and some friends?
imperiledthree 9 years ago
it would be cool if the modern weapons addon for flans were added
BadgerBib 9 years ago
I can't play the modpack!
Pirate88r 9 years ago
How the hell do you charge the modular power suits on this mod pack ?
zibafu 9 years ago
never mind, I installed it. But I can't play it! what can I do?
Taken_Username 9 years ago
I can't install it on my launcher! nothing happens when I click that search-bar-type-thing that says "install new pack or search"! PLZ HELP!
Taken_Username 9 years ago
This probably sounds dumb but I can't seem to find or craft any diamonds. Does anyone know how I could get any?
CrisisCreations 9 years ago
You can mine for them but they're rare. In theory you could smelt coal ore in a SAG mill if you can get it with silk touch or something and in rare instances.
Posted by 0Beechlgz 9 years ago
(sorry hit reply early) In rare instances diamond will be produced.
Posted by 0Beechlgz 9 years ago
thanks I wasn't sure if they just quit spawning.
Posted by CrisisCreations 9 years ago
You can use Minechem to craft them. Look at one under a microscope, make sure you have your lab journal loaded into them scope. Then move your journal to the chemical synthesis machine, and see that the diamonds are made out of nanotubes. You can then use R to find the recipe for nanotubes.
Posted by Akapavious 9 years ago
ATTENTION***** I had the issue of my game just going back to the launcher every time i tried to load. Then I downloaded java 64 bit and it fixed the issue!!!
RedSky_Eagle 9 years ago
I have the same problem, and I tried this and it didn't work.
Posted by masterlyJudgement 9 years ago
Loved this pack, have had to recreate worlds due to update. Fine by me, this packs's worth it. But now I can't even download the install, download keeps freezing as I'm trying to download the projectred zip file. Anyone have a solution for this?
Akapavious 9 years ago
And no, Jojo, I'm not using a mac.
Posted by Akapavious 9 years ago

Latest Update

The issues with Steves Galaxy launching correctly have been fixed. The pack should work as normal now. -LabMonkey