Install Steve's Galaxy (Legacy)

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Steve's Galaxy (Legacy)) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Steve's Galaxy (Legacy) from the list on the left. The launcher will handle everything else!

Steve's Galaxy (Legacy) Version 1.4.4

created by endermedia on Minecraft 1.7.10 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
@Psok Thank you for your help the pack now works :D
hinouzer 8 years ago
Hey, you guys should add Chisel to the modpack. :)
CsugTheThug 8 years ago
I have got a different problem involving the pack itself. This seems a good place to comment it. Anyway, I normally go to the start button and search "technic" and the pack comes up I double click and it runs. But today I go to search and it DOESN'T come up. I go to search documents and everything else but it doesn't show up. When I go to Roaming (%appdata%) all of the modpacks and their respecting saves are there. It was working yesterday is the weirdest part. I have no idea what to do and would appreciate some ideas or help.
Widespread_Pandemic 8 years ago
the background looks like mcheli, though that mod isnt in the pack.
meme8383 8 years ago
Mine says it couldnt download the which gives me a 404 error.
meme8383 8 years ago
I cant Play Steves Galaxie The game always sais: CB's DepLoader was unable to download required library MrTJPCore-1.7.10- Check your internet connection and try restarting. It is the same on my friends PC so pleease fix it so i can Play this delicious Modpack ;)
hinouzer 8 years ago
Its still stuck at "reloading resource packs" at 85%
spartaelos 8 years ago
Its still stuck at "reloading resource packs" at 85%
jackrusel83 8 years ago
I would delete the modpack by using the Delete Pack option, while having Steves galaxy selected, within the technic launcher. Navigate to the C:\Users\%username%\AppData\Roaming\.technic\modpacks directory to ensure the folder was actually deleted. Then, search for Steves Galaxy in the Add Pack or Search bar and re-download Steves Galaxy. One this has been completed and if the modpack doesn't launch, try what I previously recommended in a post below. This is what fixed the issue for me, so I apologize if this does't fix the issue for you.
Posted by psok 8 years ago
Hi there PSOK, did try your method and still having the same problem stuck loading at 85% Reloading resources pack. Will have to wait for the solution from the mod developer. Appreciate your help though. Thanks
Posted by 9809 8 years ago
If you are getting the below error: CB's DepLoader was unable to download required library MrTJPCore-1.7.10- Check your internet connection and try restarting or download it manually from and put it in your mods folder Go to and put the downloaded file (MrTJPCore- into C:\Users\%username%\AppData\Roaming\.technic\modpacks\steves-galaxy\mods\1.7.10 and the modpack should launch. You can copy and paste the directory I posted so you don't have to navigate manually. This fixed my modpack launching issue.
psok 8 years ago
I did what you say. Got stuck loading at 85% Reloading resources pack.. it just close and back to Technic Launcher :(
Posted by 9809 8 years ago
Adding it manually does not appear to work. I think that some coding somewhere in the Technic system resets all mods in the "mods" folder--so far I've not gotten it to successfully incorporate a re-added MrTJPCore. It just deletes it before fully loading.
Posted by Madman198237 8 years ago
That's odd. Mine worked fine. Although, I did delete the pack and then re-install it via the Technic Launcher before I received the error I previously mentioned. Have you tried that?
Posted by psok 8 years ago
Posted by meme8383 8 years ago
Now i am getting the 85% error. I was getting hopeful that this computer can run packs
Posted by meme8383 8 years ago
Does anyone know why we cant download 1.4.4?
anorimos27 8 years ago
i cant download D: as in when i play it it says fail
xxjb12345 8 years ago
playing the game with my hubby and he got kicked out of my game. now every time it loads and he joins, he has lost everything. is there anything that can be done about this. Please
B10hazard 8 years ago
i cant even get it working when i revert to 1.4.1 to bad this was one of my favorite modpacks
chtyla 8 years ago
He probably downed the server to update it. 9809, I don't think anybody knows why nobody can access this update. Also, we're all having the MrTJPCore issue-the download link doesn't function anymore, so CB's Deploader can't download it. Somebody move/removed the download that was at the internet location the Deploader was searching.
Madman198237 8 years ago
Thanks for the info. Appreciate it.
Posted by 9809 8 years ago
How come Technic Launcher not showing version 1.4.4 ? I'm having error of running version 1.4.3 some MrTJPCore file from projectwiki not found. Please advise. Thank you
9809 8 years ago
Why would you remove the server and are you going to have another one?
flynnlives1146 8 years ago
It's a sticky resin block with a glitched/nonexistent texture, if I'm thinking of the same thing you are. As far as I know, it's supposed to be there as a source for rubber other than rubber trees. Maybe. I don't know how to fix that--maybe just wait and see what happens with the next update or two. Or talk to the IC2 people.
Madman198237 8 years ago
I was wondering why the blocks named "ic2.blockHarz" from industrialcraft 2 appear everywhere in ruins. I found an abandoned city and these blocks are EVERYWHERE: they replaced most of the walls, floor etc. I looke d in the mod options but found no solution. When I first started playing I also experienced chunk loading errors. As I was walking a strip of chunks would not generate but the ones after that would. some paths in between. It stopped but I want to know what causes it.
Widespread_Pandemic 8 years ago
Please advise where to download the update. 1.4.4. is not on the list for Technic launcher i just updated my server to 1.4.4. and I do not see the update for the Technic launcher client side Please advise thank you
akametalbeast 8 years ago
When I press play on the technic launcher the loading gets to forge micro-blocks at 28% then crashes. I have waited several updates and there is no change. Any suggestions from fellow players and if not could the developers please try to fix this. I really want to play this and this is extremely annoying!
techno shark 8 years ago

Latest Update

The issues with Steves Galaxy launching correctly have been fixed. The pack should work as normal now. -LabMonkey