Install Steve's Galaxy (Legacy)

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Steve's Galaxy (Legacy)) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Steve's Galaxy (Legacy) from the list on the left. The launcher will handle everything else!

Steve's Galaxy (Legacy) Version 1.4.4

created by endermedia on Minecraft 1.7.10 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
Please, why my steve's galaxy don't open??? Anyone know?
arthurstransky 8 years ago
I have 64 bit java but can't go above 1 GB ram and i have 6 GB ram installed, further the loading screen gets stuck on 85% when reloading resource packs
KevinKefje 8 years ago
Download Java Runtime Environment (JRE), not the JDK, then install and reboot your computer and you will be able to choose your RAM in the Technic Launcher options.
Posted by 1Diablo25 8 years ago
clico em jogar e carrega mas nao abre o minecraft e volta para a tela do technic launcher. Sabe por que?
Danifzn 8 years ago
clico em jogar e carrega mas nao abre o minecraft e volta para a tela do technic launcher. Sabe por que?
Danifzn 8 years ago
Also, I was trying to play on 1.4.4, so you know if you can fix it.
OrangeCreeper217 8 years ago
When I got on, the title screen wouldn't work, the screen is white except for the panorama, (which is downscaled to the bottom left), and I can click on stuff, but I don't know what I'm clicking. Basically, my title screen is bugged.
OrangeCreeper217 8 years ago
K. stuff we've found, Several parts of flans mods are bugged and will crash java when clicked on. Some parts of advanced powersuits are uncraftable, the carbon fibres, tubes and muscle. The fossil analyser has a hideous bug on it best use only one stack of fossils at a time, and place them carefully. Chemcraft is fantastic, make radioactive chests to store stuff in tho as opening a regular chest with broken down radioactives is instadeath. zombies can fall down shafts with power cables running down them.
rbnzdave 8 years ago
Also the server download 1.4.4 and a clean download (which takes bloody ages through the tragicly slow launcher (like 4 seperate slow assed parts)) work fine, provided you are running 64 bit java. You can get that from > other downloads.
Posted by rbnzdave 8 years ago
When i try to run the game nothing happens.. the java loding bar appears but then goes back to launcher... damm i want to play this mod =/
tiagix 8 years ago
remove the 32bit java you are running and install 64bit from
Posted by rbnzdave 8 years ago
still not working =/ Im only using java 8 u60 (64bit)
Posted by tiagix 8 years ago
Try using the java 7 U can download from this website:
Posted by arthurstransky 8 years ago
Still not working... i guess everyone who installs for the first time cant get the modpack running...
Posted by tiagix 8 years ago
Shutting down internal server THeres a error
Espinhoso 8 years ago
Does any one remember the original creator/manager of this mod pack because i would like to see his/her newer works
Devilsgamer666 8 years ago
endermedia is the maker of this mod
Posted by FearfulInk 8 years ago
why do i get stuck on relaoding resauses
crazycow830 8 years ago
the same thing happens to me have you found out how to fix it?
Posted by Unanimous 8 years ago
Maybe if you wait it works, but get Shuting DOwn Internal Server when creating a world.
Posted by Espinhoso 8 years ago
Anyone know why i cant install the map? i tried to use the URL but it didnt work, so i tried to search it and it pops up but all i saw was all blank and like making a new modpack exept when i checked the downloads and runs, it was "??" and so i thought if anyone got it too! if u do and know how to fix it PLZ REPLY!!!
poopeppoo 8 years ago
i need help ASAP. once again this is the best place i thought of to post this. i downloaded a city map and started building etc. so the owner says "use with mods at your own risk/mods may cause unintended results etc. so there is weird blocks and things everywhere that are mod items. so i accidentally pick block one, and then IT CRASHES THE GAME and brings me back to the launcher. i try to go into the world again but it crashes everytime. I have done everything i know to do to try to fix it, to no success. i appreciate any ideas or help.
Widespread_Pandemic 8 years ago
Anyone know if Diamonds are on a different level then unmodded Minecraft?
LadyGrelka 8 years ago
they are between about 5 and up to about 14
Posted by rbnzdave 8 years ago
ok so i waited like an hour for it to load and then it loads and then it closes right after it loads
nolan24712 8 years ago
get 64bit java. we had the same issue on a mates machine. the java installed with windows by default is 32 for some reason.
Posted by rbnzdave 8 years ago
hinouzer 8 years ago
can Steve's Galaxy runs on Window 10?
datlazzy0607 8 years ago
runs fine. get java 64 bit tho.
Posted by rbnzdave 8 years ago
I cant even join a lan server because of the same error :,( Is there a way to fix this by myself??
hinouzer 8 years ago
WHY WOULD YOU DISCONTINUE STEVES GALAXY!!!!!!!!!!!!!!!!!!iiiii!!!!!!!!!!!!!WHY?!?!?!?!?!?!?!?
SuperSonic1234 8 years ago
That's fine, discontinue your support for this mod. But could you at lease leave us your last stable version of server and client???!!!! Can we have a link to previous versions?
jasonoldy69 8 years ago

Latest Update

The issues with Steves Galaxy launching correctly have been fixed. The pack should work as normal now. -LabMonkey