Install Steve's Galaxy (Legacy)

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Steve's Galaxy (Legacy)) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Steve's Galaxy (Legacy) from the list on the left. The launcher will handle everything else!

Steve's Galaxy (Legacy) Version 1.4.4

created by endermedia on Minecraft 1.7.10 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
bad intermittent lag. I play a hosted server with only one other person and he has no lag. The server has 2.5 gig of ram. I have 8 gig and im running 64 bit java with 3 gig to run the launcher. My ping is 20 on avg. my Verizon connection is 50mg avg. All the video settings are at the lowest but i still have to wait 4-6 seconds every other time i click on a chest or machine. Can someone offer a clue to why this is. thanks
timmetalgod 5 years ago
when i try to play, it says "CB's DepLoader was unable to download required library vorbis-java-core-0.8-20150201.161816-1.jar Check your internet connection and try restarting or download it manually from http://files.qmxtech.com/libs/vorbis-java-core-0.8-20150201.161816-1.jar and put it in your mods folder" The website is down tho. kinda a waste of time...
MetalMushroom04 5 years ago
SERVER KEEPS CRASHING! PLZ FIX!
danclay 5 years ago
Can't install the pack, Technic launcher gives "Broken API-Link"
romancandle 5 years ago
The modpack gives me an error when trying to play, it says it didn't manage to download vorbis-java-core-0.8-20150201.161816-1.jar and tells me to download it manually from http://files.qmxtech.com/libs/vorbis-java-core-0.8-20150201.161816-1.jar , but that site is down for me
Ackerfe 5 years ago
I crash whenever the world tries to generate a specific object. No idea what this object is, but the text "Generating..." appears on screen, then I crash. I believe it is the large city from wasteland, but I got it to generate on an earlier version.
whizkid9797 5 years ago
Is the server offline?
TheFutureBowtie 5 years ago
The server has bin offline / online in a crash reboot loop for about 20 hours. theres no mods or admins actively maintaining this server to might take days for it to be fixed
Posted by MrChavoda 5 years ago
Ok
Posted by TheFutureBowtie 5 years ago
when me and my friend log in the server shuts down??? we live together in a city
puppy63376 5 years ago
Can you close the server less often?
TheFutureBowtie 5 years ago
i try to download the mod pack but there A Broken API please fix
MEPHISTOPHELES20 5 years ago
Hey, I have a problem with the mod pack server. I could play the server before, but now, I can't. I loved the mod pack and server and I just got to the moon. But now, I can't play it anymore because it says "Failed to login: Invalid session (Try restarting your game). I've restarted and reset the mod pack thousands of times but it doesn't work. I even refresh. Do you have tips on playing on the server again?
TheFutureBowtie 5 years ago
It works again :D
Posted by TheFutureBowtie 5 years ago
Great Modpack, bu it seems to crash a lot. Any ideas on what is causing it?
TheEpicGamer14 5 years ago
With the new update it stops loading at %85
Silver_Serpant 5 years ago
fix the server man really annoying
ImBreaking 5 years ago
love the pack, might want to figure out what's causing all the crashes and 1 minute restarts however.
DanteStigma 5 years ago
Do meteorites spawn grass and is there some way for me to get sheep, cows, pigs, etc...
Silver_Serpant 5 years ago
I have a Problem with the salinationplants They are in my base and crash my client everytime i log on.Is there a way to fix this?
stonehead123 5 years ago
smelly cats
WhatAHorribleCallum 5 years ago
For some reason i have this OpenGL error 1281 which makes my items turn into white squares. With this problem it is very hard to play. Please tell me how to fix this
Mika_Mess 5 years ago
i just finished helping my friend with the same problem all you have to do is go to your windows updater and update everything ya need to then look up on your pc java updater after all of that is updated and installed may need a restart try it out again should work. if not feel free to message me again and ill find another way to help or at least try lmao
Posted by dylberry 5 years ago
crashes as soon as i try to load a world
Rupert100 5 years ago
Hey there, I had the same problems with 1.4.1, and again with 1.4.2. Loading an existing world just crashed the game. In my case (reading some generated error logs), I found the new version of the Mekanism mod to be responsible. Do you use logistical sorters in your world? If so, then this might be the reason for the crash. My solution was to just delete the Mekanism, MekanismGenerators and MekanismTools jar files in your mods folder for 1.4.1 or .2, and download/copy an older version of these files into the mods folder. Version 1.4.0 of SG was working perfect, so I went ahead and got Mekanism version 8.1.0.216 (straight google search will get you to the jars) and copied them into the mods folder for SG 1.4.2. Worked afterwards again, and I could get back to my world. Seems like Mekanism is not downward compatible in a way, and causes loads of exceptions which crash the game. This happened with other mods before after SG updates, but never that bad. Usually, things are just missing (which is bad if one has complicated machinery setups). One time, I lost all itemducts connecting the machines ... a pain to repair LOL. Anyway, this last mod-update-disaster was much easier to resolve! Hope it helps and you get back to your world! :D
Posted by Starbuck_BSG 5 years ago

Latest Update

Introducing our latest modpack, Mianite Reborn, everything you wish Mianite S3 would have been, including an awesome community server, learn more at http://endr.me/reborn