Install Steve's Galaxy (Legacy)

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Steve's Galaxy (Legacy)) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Steve's Galaxy (Legacy) from the list on the left. The launcher will handle everything else!

Steve's Galaxy (Legacy) Version 1.4.4

created by endermedia on Minecraft Version 1.7.10 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
never mind, I installed it. But I can't play it! what can I do?
Taken_Username 5 years ago
I can't install it on my launcher! nothing happens when I click that search-bar-type-thing that says "install new pack or search"! PLZ HELP!
Taken_Username 5 years ago
This probably sounds dumb but I can't seem to find or craft any diamonds. Does anyone know how I could get any?
CrisisCreations 5 years ago
You can mine for them but they're rare. In theory you could smelt coal ore in a SAG mill if you can get it with silk touch or something and in rare instances.
Posted by 0Beechlgz 5 years ago
(sorry hit reply early) In rare instances diamond will be produced.
Posted by 0Beechlgz 5 years ago
thanks I wasn't sure if they just quit spawning.
Posted by CrisisCreations 5 years ago
You can use Minechem to craft them. Look at one under a microscope, make sure you have your lab journal loaded into them scope. Then move your journal to the chemical synthesis machine, and see that the diamonds are made out of nanotubes. You can then use R to find the recipe for nanotubes.
Posted by Akapavious 5 years ago
ATTENTION***** I had the issue of my game just going back to the launcher every time i tried to load. Then I downloaded java 64 bit and it fixed the issue!!!
RedSky_Eagle 5 years ago
I have the same problem, and I tried this and it didn't work.
Posted by masterlyJudgement 5 years ago
Loved this pack, have had to recreate worlds due to update. Fine by me, this packs's worth it. But now I can't even download the install, download keeps freezing as I'm trying to download the projectred zip file. Anyone have a solution for this?
Akapavious 5 years ago
And no, Jojo, I'm not using a mac.
Posted by Akapavious 5 years ago
Joins, Started in a wasteland with NO FOOD... NO TREES..... The players are too ignorant to tell you how to do stuff. NO RULES. NO HELP. GETS BANNED FOR SAYING THIS SERVER SUCKS. -1/10
SpaciiGh0stt 5 years ago
you're an idiot, everything is a wasteland stop relying on others to help you... its supposed to be very difficult so go play vanilla
Posted by hharper55 5 years ago
Joins, Started in a wasteland with NO FOOD... NO TREES..... The players are too ignorant to tell you how to do stuff. NO RULES. NO HELP. GETS BANNED FOR SAYING THIS SERVER SUCKS. -1/10
SpaciiGh0stt 5 years ago
mine just crashes when I go to create my world.
RedSky_Eagle 5 years ago
plz help with this problem and no jojo i do not play on a mac
Posted by RedSky_Eagle 5 years ago
please please please fix for mac it really annoys me that I can not play this wonderful looking mod on my mac
[email protected] 5 years ago
Really good modpack for singleplayer or multiplayer. I used to use the Wasteland mod a year or so ago and it's nice to see it used so fittingly in a modpack. I need to contact somebody about the Steve's Galaxy server though, an admin or somebody as I and at least one other person knock the server offline (for everybody) when we attempt to log in and neither of us know why and are reluctant to try again. I couldn't find a help or contact on the website, is there anyone who checks here who can tell me who to contact?
0Beechlgz 5 years ago
Are there any resource packs for this modpack, or any recommended resource packs that will work well with it, played vanilla minecraft for so long with a hd resource pack that looked proper smooth, its kinda hard going back to retro graphics haha
zibafu 5 years ago
I'm thinking the weather mod needs to be axed. Can't seem to keep it turned off between logins, and two days of building just got nuked by a wind storm because I forgot to disable it when I logged in. Not cool.
Dhrekkin 5 years ago
Anyone else agree that there should be Craftable Animals mod in this pack? Any other Archeologist out there would understand.
BrotherPotato 5 years ago
Anyone else notice absolutely no diamonds in their worlds?
CrisisCreations 5 years ago
ive found diamonds in my world, found one vein in an abandoned mineshaft, and one of the skystone meteor chests had diamonds in
Posted by zibafu 5 years ago
When will this be fixed for Macs?
CODFANBOY111 5 years ago
It doesn't work for macs? Dang. I really wanted to play this.
Posted by masterlyJudgement 5 years ago
GUYS. If your steve's Galaxy crashes, and you run Jave 32 Bit, thats your problem! Steve's Galaxy is a modpack with a ton of mods that require alot of ram to play. I recommend upgrading your java to 64 Bit so you can allocate more ram to technic.
Budders_ 5 years ago
using 32 bit. no lag :)
Posted by poepkast 5 years ago
if only worlds were able to work across updates, that'd be great
Eqqsalad 5 years ago
i hit play goes right back to the launcher
WitherSlayer 5 years ago
he needs to fix so it works for macs
Posted by jojoe0007 5 years ago
What am i supposed to do when it crashes and wont close so i cant open it again.
justin5723 5 years ago
Because he needs to fix it
Posted by jojoe0007 5 years ago
Fix it so it works for Mac Omg
jojoe0007 5 years ago

Latest Update

Introducing our latest modpack, Mianite Reborn, everything you wish Mianite S3 would have been, including an awesome community server, learn more at http://endr.me/reborn