Install Tekxit 3 [Official]

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Tekxit 3 [Official]) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Tekxit 3 [Official] from the list on the left. The launcher will handle everything else!

Tekxit 3 [Official] Version 1.3

created by Slayer5934 on Minecraft 1.12.2
You must be logged in to comment. Click here to register a new account or log in.
Hey buddy! long time no see! happy to see that you manage to make a version 3! i used to play the version 2 sometime ago, good to see that you are still kicking! im thinking on playing minecraft again, and i think i will play with your modpack again! dont even know if you remember me (the guy who complained about that colossal huge mega tree avaiable for anyone to plant on the server hahaha, we got some multiple troubles with it!) just came here to say hello and congratulate for this new pack! cheers buddy!
tochjunin 5 years ago
Thanks and yes I remember :P
Posted by Slayer5934 5 years ago | Modpack Creator
I downloaded the Texxit Server File and have set it up correctly, I port warded and tested the server and the server loads up normally and other players can join it however none of the mods load up due to "JEI not Installed on the Server" but when I check the server files JEI is there and it is in the .minecraft , the .forge folder and my .technic folder in %appdata%. I thought to make a folder called coremods and put JEI in it and still same issues, I even used a newer version of JEI and added it to all of the folders in %appdata% and my server but still the same issue. When I press E to open my menu in creative all of the mods are shown to be there but if I put anything in my inventory you cannot interact with anything or place it down on the floor, When I go to place it it disappears within half a second of it being placed, when I go to right click something from Pams HarvestCraft to eat anything nothing will happen for example and when I press Q it doesn't drop the item either I have to drag it out of my inventory. I went on singleplayer and all of the mods loaded up and was working perfectly but whenever I join my server none of the mods from hexxit or tekkit show up apart from Xaeros_Minimap, NotEnoughItems and XaerosWorldMap. If someone could help me out Id appreciate it :)
FREESIXNINE 5 years ago
I have a problem with thermal expansion item ducts. whenever i click a duct near a chest with the hammer it just disappears, it wont change...
Yodamester121 5 years ago
Is anyone having a problem with animal overpopulation? I think there's probably an auto breed thing goin on, but idk how to disable it. If anyone knows how and lets me know it would be very appreciated :)
modhia 5 years ago
I noticed some the crafting recipes are missing, such as the chocobo saddle bags and all energy cells above basic, which makes all the higher level jetpacks uncraftable and leaves us to have to craft a lot of basic cells for energy storage.
gaddi21 5 years ago
revision to what I said, I did some searching and found that you upgrade cells with thermal expansion upgrade kits, however the chocobo saddle bag thing still stands
Posted by gaddi21 5 years ago
Hello! I just downloaded the pack, which by the way looks to be an absolutely amazing pack, but my problem lies more in the game itself. once in a world, I noticed that my fps was consistently shooting up and down from 0 to 60, while no other modpack has this outcome. I can't tell if maybe I'm missing something in the launcher settings, or if its just my computer. is there a way to fix this issue?
brickboyjoey 5 years ago
also forgot to mention, that along side the lagg, i tried lowering all my video settings to see if maybe it would help in the matter, but it didn't change a thing
Posted by brickboyjoey 5 years ago
Same problems happening here!
Posted by SetArk 5 years ago
The modpack requires 3.5GB-4GB >minimum< set in the launcher, and your pc needs a >minimum< 8GB of memory/ram otherwise you'll get massive stutters/slowdowns.
Posted by Slayer5934 5 years ago | Modpack Creator
Hail! I'm testing it, but one thing that is visible from the start, is that strangely Minecraft started to eat on my CPU and Disk usage. I've been playin on Attak of the B Team yeah, old modpack.) without any minecraft stuttering, with max out settings. Any idea of why this pack is raising so much the CPU and Disk usage?
SetArk 5 years ago
Hi. My friends and I have put up a little private server for us to play on, but we seem to have problems connecting from time to time. It's not the server, ports are forwarded, connection is good, etc. - we think that there's a mod causing a problem. What happens is that one of us will try to connect and it simply will not load. Sometimes it says nothing at all, sometimes it says "loading terrain" and doesn't go any further. Any advice? Thank you.
PixoPoxo 5 years ago
Im not exactly sure where to look for the issue as Im not having it, if you could get on the discord and send a log my way I can take a look.
Posted by Slayer5934 5 years ago | Modpack Creator
Hi so today i installed update to version 0.84 but my server is 0.83 and it looks like it will take a while before i can update server. Is there any way to downgrade my 0.84 to 0.83? I tried modpack settings but there is only 0.84.
Unnum 5 years ago
how much ram does it take to run a nolag server?
Rohanlord 5 years ago
Its not just about the ram, its also the cpu. But it depends on the amount of players really.
Posted by Slayer5934 5 years ago | Modpack Creator
Hey I can't install even one file when I click install on the modpack. It immediately gives me an error. This is what it looks like: I just want to play with my friends so please help me out.
Oxygenerations 5 years ago
btw the link works, you just gotta copy and paste it into the search engine thing
Posted by Oxygenerations 5 years ago
Having issues connecting to my LAN server after updating client and server. The server denies the login and says the mod versions don't match. EG. Server seems to still think it has the old 0.82 mod versions and client has 0.83. Do you know which file I need to update/edit to correct which mod version the server has? I have replaced the two .jars and the libraries folder.
axman10 5 years ago
Those were one time additional instructions, your suppose to delete the mods and configs folders and replace those too..
Posted by Slayer5934 5 years ago | Modpack Creator
I have some questions 1. Will new mods be added later? 2. Will Galacticraft be allowed to build 6 rockets to visit the other planets? 3. When are the machines that are marked as decorative blocks in Ender IO released? Thank you in advance
akazukilp 5 years ago
1. Its possible and likely mods will be added later on, but not so much that its an "all the mods" modpack or bloated like Tekxit 2... 2. You can already visit other planets with galacticraft, unless you mean a planet expansion pack which then the answer is probably. 3. Not sure what you mean by this
Posted by Slayer5934 5 years ago | Modpack Creator
Some of Enderio's items are marked with goose feet and are displayed as decoration only.
Posted by akazukilp 5 years ago
Pretty sure they are just for decoration. Like so you dont have to make the actual block if you just want it visually.
Posted by axman10 5 years ago
Thanks for the updates! any chance of adding big reactors or World Control? (successor to nuclear control)
pandg3 5 years ago
I have a problem with the download. After i start downloading i get an error. It says Failed to download scala-reflect-2.11.1.jar How do i fix this?
D3Visi0n 5 years ago
The same for me, dude.
Posted by Jokerphant98 5 years ago
Sounds like one of the minecraft libraries is down... No idea why..
Posted by Slayer5934 5 years ago | Modpack Creator
Where do you upload your Modpack files?
HSScholle 5 years ago
Posted by Slayer5934 5 years ago | Modpack Creator
The game crashed whenever I try to open the options menu in-game.
dragonbasher13 5 years ago
Should be fixed in the next update, which will be released whenever vanillafix is updated..
Posted by Slayer5934 5 years ago | Modpack Creator
Won't download through the technic launcher or direct download
EpicFoxx64 5 years ago
Should be fine now..
Posted by Slayer5934 5 years ago | Modpack Creator
raiding or nah?
fitchlyons 5 years ago
i've got 1 fps on i5 4460 and r9 380 with 6gb ram allocated, why it happens?
SeiA1997 5 years ago
If your system only has 8GB of ram total and you assign 6GB to minecraft, theres gonna be issues.. Assuming Im right about that..
Posted by Slayer5934 5 years ago | Modpack Creator

Latest Update

Tekxit 3 [Official] was updated to version 1.3