Install Tekxit 3 LE (Official) 1.12.2

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Tekxit 3 LE (Official) 1.12.2) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Tekxit 3 LE (Official) 1.12.2 from the list on the left. The launcher will handle everything else!

Tekxit 3 LE (Official) 1.12.2 Version 0.990

created by Slayer5934 on Minecraft 1.12.2
You must be logged in to comment. Click here to register a new account or log in.
cant launch server, it gives an error somewhat. i already sended you by mail but looks like you're not checking your mails. specs: i5 6600 24G Ram GTX 970 http://www.mediafire.com/file/r4ealurv4d38lur/tekxit_3_server_logs.rar/file
ecanduysak 2 years ago
Uppercase/Lowercase conversion causes crash in Turkish locale https://github.com/rwtema/extrautilities_old_issues/issues/1687 Meybe it helps
Posted by sl0ter 2 years ago
I didnt see the email till today, sorry about that..
Posted by Slayer5934 2 years ago | Modpack Creator
Sup dude, first of all: really nice modpack, appreciate your work, keep doing the great job! :) But I also got a question: I've set up a Multiplayer server for a couple of friends and me, but it somehow feels like that I did something wrong: we have been playing for a couple of hours and none of us found copper, tin, or anything besides the Minecraft vanilla ores .. there are also no battle towers, dungeons or something like that :/ but if I open the inventory, I actually can see like all the modpack items, how to craft them, and so I - just wondering if it's like totally normal or if i am doing something terribly wrong ^^ (Also got no timbermod etc, maybe not installed at all? Don't know)
-dnz 2 years ago
Battle towers are spread apart more and the modded ores have different spawn heights, if your not seeing anything modded then your running vanilla minecraft. If youd like to be sure you can install xray mod for 1.12.2 and scan for ore that way to be sure. You can reach me more easily on discord if possible, the link is on the main modpack page (Overview)
Posted by Slayer5934 2 years ago | Modpack Creator
I've found tons of battletowers and copper and tin, but my world doesn't appear to have ANY silver. Is there something messing with the ore generation? I've also noticed that you can find diamonds up on the surface (around y=63), unsure if this is just changed spawnheights, a mod, or just the biome, but whatever it is has likely made ores spawn in strangely.
Posted by pokemontrainer_s 2 years ago
nothing bad, just informing that in the server download there were 2 Micdoodle core Jars I just deleted the older version and it ran fine
huntzilla360c 2 years ago
COMPLETE CORRECTION!!! I just suck and I pasted a copy of every new mod.... so there were duplicates galore...…..
Posted by huntzilla360c 2 years ago
My friend is trying to open the mod pack, but it fails to launch. It says the Ender IO Integration Mod(s) and the Just Enough Items mod are the most likely problems. We already tried uninstalling and reinstalling the mod pack. Any ideas on a fix?
xxMrxTarzanxx 2 years ago
A link to the crashlog would be useful.
Posted by Slayer5934 2 years ago | Modpack Creator
I have a feeling he hasn't assigned 3.5GB of memory.
Posted by Slayer5934 2 years ago | Modpack Creator
I can't get into my aternos server because it's one update outdated but i can't change my modpack back to 0.84 for some reason. Any way i can fix this?
Zekiel 2 years ago
I really would like to know the answer to this too
Posted by andyroo2012 2 years ago
If you don't want to update then don't update, other than that there's no going back a version.
Posted by Slayer5934 2 years ago | Modpack Creator
okay, so i entered one of those portals scattered around the world yesterday and then i couldn't enter it anymore. Now there's this big black hole where the portal used to be that keeps getting bigger and bigger. Is there any way to remove this black hole?
BaconM8FTW 2 years ago
You need to use a rift remover
Posted by Slayer5934 2 years ago | Modpack Creator
What does everyone use for power generation in this pack? None of the solutions I'm familiar with (Mekanism, Atomic Science, Big / Extreme Reactors) are present, and I'm super gun-shy about IC2 nuclear since it feels like it's impossible to not have it blow up...
mcorrie 2 years ago
You can try IC2 solar
Posted by Slayer5934 2 years ago | Modpack Creator
I thought that battletowers was in this pack but I have explored for thousands and thousands of blocks and found none. Is this a glitch or are battletowers just not in this pack
Ender_Frosty 2 years ago
Actually, just cheched the ,od list and battletowers is there. I am now 90% sure that this is a glitch. Either that or I am very unlucky with terrain generation
Posted by Ender_Frosty 2 years ago
Also sorry about spelling, typing on an ipad isn’t one of my strong suites.
Posted by Ender_Frosty 2 years ago
Can't connect to the servers, keeps saying authentication servers are down
LockDudeBro 2 years ago
Mojang had some issues for a brief moment, that's not a modpack problem.
Posted by Slayer5934 2 years ago | Modpack Creator
Can i have a link for the discord please?
ADarkerDoctor 2 years ago
https://discord.gg/yN73ej7 Please read the description, it is there for a reason.
Posted by Slayer5934 2 years ago | Modpack Creator
Why are monoliths disabled in Dimensional Doors? It is easy to bypass dungeons with the monoliths there. Is there anyway to enable them?
UnchartedDeath 2 years ago
I will look into the issue.
Posted by Slayer5934 2 years ago | Modpack Creator
when is buildcraft getting added? - still no early/mid game quarry options without it...
bensdb 2 years ago
Buildcraft is up to date on but idk when they'll install it :( I really need it for my builds. http://www.9minecraft.net/buildcraft-mod/
Posted by huntzilla360c 2 years ago
Buildcraft is currently in ALPHA state, I do not add mods in that state.
Posted by Slayer5934 2 years ago | Modpack Creator
It will be added once in BETA or above.
Posted by Slayer5934 2 years ago | Modpack Creator
Is this pack still popular?
Ender_Frosty 2 years ago
the servers arent normally full but are well populated
Posted by n0bleteamleader 2 years ago
It's not out of BETA yet, but yeah I consider the user base to be larger than 90% of the modpacks. The main server is usually full actually, but a second one is going to be added to the server list soon :)
Posted by Slayer5934 2 years ago | Modpack Creator
ok so since this pack doesnt have tool leveing for tinkers construct and id like to have good weapons id like to add creative modifiers to the infernal mobs drop list. ive been trying for hours to try and figure it out but i can not even get the /give command to give me the modifier... if someone could help me figure this out it'd be a real treat. im just so command illiterate and ive been out of the programming this for a few years now im just lost.
n0bleteamleader 2 years ago
Hey there, I have quite a big problem with a modpack... So basicly it can load up till the main menu but when world loading is finished it just crashes. Crash log says something in the lines of Caused by: java.lang.NullPointerException Anyone have the same problem?
ivan5956 2 years ago
What version of java are you using(try 64bit if you're not) and in the Technic launcher have you set your RAM to a higher amount than the base 1Gb?
Posted by huntzilla360c 2 years ago
The modpack requires 8GB total RAM and 3.5GB set in the launcher.
Posted by Slayer5934 2 years ago | Modpack Creator
is in modpack questbook ? if is how can i open it ? :D
lolkingsvk 2 years ago
https://docs.google.com/spreadsheets/d/e/2PACX-1vTkZG-t1afcKNyPPTd79sOlgnGVQOXTaO1UWjjIIoDbKO0bV9cuLQ1wmEhuDokIxWMJPJbpd8msj6y4/pubhtml
Posted by huntzilla360c 2 years ago
Hey modder! Have you thought about adding project-e to the pack? I remember it being in the second edition of the modpack and it's really missed by me and the people I play with.
Spop22 2 years ago
It makes the game too easy and too short imo, so I did not add it..
Posted by Slayer5934 2 years ago | Modpack Creator
Hey buddy! long time no see! happy to see that you manage to make a version 3! i used to play the version 2 sometime ago, good to see that you are still kicking! im thinking on playing minecraft again, and i think i will play with your modpack again! dont even know if you remember me (the guy who complained about that colossal huge mega tree avaiable for anyone to plant on the server hahaha, we got some multiple troubles with it!) just came here to say hello and congratulate for this new pack! cheers buddy!
tochjunin 2 years ago
Thanks and yes I remember :P
Posted by Slayer5934 2 years ago | Modpack Creator
I downloaded the Texxit Server File and have set it up correctly, I port warded and tested the server and the server loads up normally and other players can join it however none of the mods load up due to "JEI not Installed on the Server" but when I check the server files JEI is there and it is in the .minecraft , the .forge folder and my .technic folder in %appdata%. I thought to make a folder called coremods and put JEI in it and still same issues, I even used a newer version of JEI and added it to all of the folders in %appdata% and my server but still the same issue. When I press E to open my menu in creative all of the mods are shown to be there but if I put anything in my inventory you cannot interact with anything or place it down on the floor, When I go to place it it disappears within half a second of it being placed, when I go to right click something from Pams HarvestCraft to eat anything nothing will happen for example and when I press Q it doesn't drop the item either I have to drag it out of my inventory. I went on singleplayer and all of the mods loaded up and was working perfectly but whenever I join my server none of the mods from hexxit or tekkit show up apart from Xaeros_Minimap, NotEnoughItems and XaerosWorldMap. If someone could help me out Id appreciate it :)
FREESIXNINE 2 years ago
I have a problem with thermal expansion item ducts. whenever i click a duct near a chest with the hammer it just disappears, it wont change...
Yodamester121 2 years ago

Latest Update

Tekxit 3.14 Beta is out now, just search for it in the launcher! Thank you all for playing Tekxit and to those who have donated to my patreon or gotten a bisect server using the code!