Install Tekkit

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Tekkit) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Tekkit from the list on the left. The launcher will handle everything else!

Tekkit Version 1.2.9h

created by sct on Minecraft Version 1.6.4 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
Hey guys ı need some help.When ı am trying to download the tekkit ı always get an error which says (Failed to download .......................(the packs name)...... Please consult the author. What should ı do.
PartyPatrick 2 weeks ago
watch out for flails (might also be an issue with LAN games), making one crashed the game and deleted the save. Needed to recover the world in the saves folder, copy it, reinstall the mod pack, paste the save in the saves folder and make a new world with the same name to access the save again.
Hawk6241 2 weeks ago
what is the name of the texture pack youtubers use with this called
iklaw 2 weeks ago
I am on Linux Ubuntu, and when I tried to move the mod file folder into the Minecraft/mods folder, it didn't let me move it there. What am I missing?
massacrin 3 weeks ago
I just redownloaded the latest version, and I can't get the sound to work. Do I need to find the sound files and replace them? I had to do the same thing for Hexxit as well.
Doodleb34567 4 weeks ago
i keep crashing and the game tells me ive ran out of memory
ZADOX29 2 months ago
how do i stop this
Posted by ZADOX29 2 months ago
you have to download java x64 and then in the launcher you can give minecraft more ram
Posted by karlemil 1 month ago
how to get a more recent version of minecraft on tekkit, ex. 1.13 or 1.14
andrewtanyinkit 2 months ago
I have the same question. I have 1.14.3 for minecraft. I did find sort of an answer but it stated that you can't change the version that is used unless you made the modpack. So it appears that the maker of this modpack would have to change it to the newest version of MC.
Posted by ethermyn 19 hours ago
does this have a server taht i could join with a friend or do i need to make one?
rremik 2 months ago
Does anyone know how I can get multiworld support for a server? I have tried working with Multiverse but that didn't work out too well. I am looking to mainly create a second world for resource gathering
neelin21 2 months ago
Version 1.2.9h ''Program Java(TM) Platform SE binary not responding" please help me
KokyCZE 2 months ago
For some reason with this exact version of tekkit I can't launch it. I can launch older versions, other mod packs and everything. It is just this version and I can't figure out why.
prolittle 5 months ago
Same - shuts on load almost instantly. Doesn't appear to actually be adding the Lumy Skin Patch to the files either, at least I can't see it anywhere
Posted by BurntValentine2 5 months ago
Issue fixed after the change from 1.2.10 to 1.2.9h
Posted by BurntValentine2 5 months ago
is there a version with the energy condenser (or whatever equivalent exchange mod it is)?
SlimySniper 5 months ago
Hi i'm creating a Tekkit server with beastnode and i've tried the supported plugins and manually adding plugins from Bukkit.org neither have worked I really only want setspawn, ranks, and a way to protect areas like factions. Any Help would be appreciated
Hambruiser 6 months ago
WHY. DO. YOU. ADAMANTLY. REFUSE. TO. UPDATE. EVEN. ONE. OF. THE. DAMNED. MODS? There are versions of nearly every mod in this pack that are fixed and much less buggy AND compatible with this version of MC and Forge, that have been out for YEARS. You can't be bothered to do even one measly little update to fix things like Extra Utilities recipes simply not working at all, MFR machines losing their settings on logout, TE machines that don't take the correct input, Wireless Redstone that doesn't send the signal even though both ends are set to the right channel, and MFR machines that ignore said redstone signal even when it does get there? THIS. PACK. COULD. BE. FANTASTIC. BUT. IS. A. TOTAL. DISGRACE. You should all be ashamed that you can't lift a finger in years to fix any of this BS.
mcorrie 6 months ago
Can you replace AE with AE2
DJOS420 7 months ago
Do I use this for single player or somehing else. I am new
DJOS420 7 months ago
It can be either singleplayer or multiplayer. There is a server download on this page.
Posted by LasaBir 6 months ago
Hi i tink i have played this before. I realy need tekkit
Zondyz 8 months ago
Pack is so buggy it's literally unplayable now. I just spent 40 minutes breaking and re-placing a wireless redstone receiver thatt absolutely refuses to emit signal no matter what the transmitter on the same frequency says, where I place them, or how many times I break, reset, and re-tune them. Unbelievable there's absolutely no response to anything, including the age old "why no updates" from the flagship pack of this site and launcher. Unreal.
mcorrie 9 months ago
Sorry that that doesn't work! Sorry to say, but quite a few things in this modpack don't work. Some mods weren't finished, others are just buggy. Since the version of Minecraft for this modpack is so old, all of the mods are going to be out of date with no one maintaining them. It would be nice if some of these things were fixed, but lets be real: they aren't going to be fixed. Sad to say, but if you are trying to do something and it doesn't work because a mod is broken, you are going to have to find some other way to do it.
Posted by LasaBir 6 months ago
Caribbean tides server is awesome omg .
bonsssss 10 months ago
Hello. Nem birom elinditani szerver inditott enek mi lehet a problémája?
FoggyMercury944 11 months ago

Latest Update

A mod was added (Lumy Skin Patch), which brings back your super nice Minecraft skins (and if you play with other people, theirs as well!).