Install Tekkit

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Tekkit) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Tekkit from the list on the left. The launcher will handle everything else!

Tekkit Version 1.2.9i

created by sct on Minecraft Version 1.6.4 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
I can't play the game because of an unknown reason. I hit install and waited and hit play, but then it acted like it was about to go on the game but it kicked me off with no reason why. Any one got help?
brickhead75 2 years ago
this mod pack is not included with my launcher :/
Xelbac 2 years ago
Is there a reason enderio is not in this modpack? I like it a lot and it is quite useful for automation with AE.
patytseng 2 years ago
You do realize this modpack is over years old?
Posted by TheUnknown54 1 year ago
So I just downloaded this and my skin is not showing at all. Even in singleplayer, the skin is still Steve. Anyone have a fix for this?
aquamancer12 2 years ago
It's because Minecraft doesn't do 1.6.4 servers anymore, since they're old. It'll be Steve for everyone everywhere.
Posted by TheUnknown54 1 year ago
i don´t know why but, on my win 10 won´t started what i must do, i really don´t know :/
KRAUSTV242 2 years ago
How can i find or make electrum ingot?
Hyp 2 years ago
gold + silver i believe
Posted by patytseng 2 years ago
Use NEI to check crafting recipes. :)
Posted by TheUnknown54 1 year ago
Could not reserve enough space for 3145728KB object heap HELP!!!
riposton 2 years ago
You need to assign less ram for your Java, rightklick on your launch.bat file and change the NUMBERS in -> "java -Xmx3G -Xms2G -jar Tekkit.jar nogui"... Xmx3G means maximum 3Gb ram, Xms2G means 2 Gb minimum. Set those numbers to fx. 2G or 2000M... or 1500M...
Posted by eXeNewter 2 years ago
How do I add and remove mods in this?
Starr_Destroyer 2 years ago
Hold "windows key" and "R" simultaneously to bring up "Run" and then type %appdata% and press OK. Find '.technic' then go to 'modpacks' then 'tekkitmain' then you just need to go into the 'mods' folder. Each .jar/.zip file is a mod. You can then search for the mod you want to remove/update or you can drag and drop the mod you want into the folder. If you need to change configs, find the 'config' folder in the 'tekkitmain' folder. You can also access these folders by pressing "open resourcepack folder" on your resourcepack menu and then go up a folder to reach 'tekkitmain'
Posted by TheModdedSyrociate 2 years ago
I made a modpack but none of the mods will load, help?
JECinTOR 2 years ago
Do you have a mod-loader within the pack? If not, I recommend installing the forge universal jarfile and placing it in the bin folder in your modpack. Make sure you rename it to modpack.jar. If you have a modloader, make sure you have all of the prerequisites for you mods. Tinker's Construct needs mantle ECT...
Posted by TheModdedSyrociate 2 years ago
Equivalent exchange is missing ash infused stone so now I can't make transmutation tablet. It is probably missing a lot more stuff too.
TheCure935 2 years ago
Reinstall Tekkit Main
Posted by TheModdedSyrociate 2 years ago
I run a tekkit main server on 1.2.9g open to the public. http://apocgaming.org / 164.apocgaming.org I am also listed in the tekkit main forums on technic.
Zilacon 2 years ago
Am I the only one who didn't have this in the Technic launcher?
Ians_Insane 2 years ago
Search for it or insert the api key into the search box.
Posted by TheModdedSyrociate 2 years ago
is there anyone but me that is having trouble getting the pack to start?
zander3421 2 years ago
yes
Posted by BobFromSateFarm 2 years ago
is there a server and if so what is the IP
Allycatergaming 2 years ago
There are many servers. Search for one on google. Soon, I will be hosting my on tekkitatx.mc-srv.com
Posted by TheModdedSyrociate 2 years ago
im doing everything correctly, made a minecraft acount and technic launcher acount, downloaded technic launcher and tried put the minecraft username and password in 50 times and it still did not work. What do I do
spooperson 2 years ago
You may need to use the account email address.
Posted by TheModdedSyrociate 2 years ago
Does anyone have a newer galiticcraft modpack that works with the older 64 bit java
HJHBK6742 2 years ago
Only the Vanilla Minecraft sounds are working for me - none of the machines from Thermal Dynamics mod make any noise at all. Is there a way to enable these sounds?
MrN0ah 2 years ago
how do i download the technic launcher?
Successful_Fails 2 years ago
you download it through the technic launcher
Posted by ryano365_ 2 years ago
RYANO365_ 1 that was very helpfull! downloading the launcher thru the lancher
Posted by CraftyMinersYT 2 years ago
Go onto the download page found here: https://www.technicpack.net/download
Posted by TheModdedSyrociate 2 years ago
how do i get an older version
kioken 2 years ago
of tekkit? if so click modpack options and then select version
Posted by ryano365_ 2 years ago
Downloaded the launcher tried logging into the launcher and doesnt let me log in..
codster920 2 years ago
you have to login with your mc login
Posted by ryano365_ 2 years ago

Latest Update

Version 1.2.9i disables version update checks for all the mods, which were causing some people to crash.