Install Tekkit

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Tekkit) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Tekkit from the list on the left. The launcher will handle everything else!

Tekkit Version 1.2.9i

created by sct on Minecraft Version 1.6.4 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
needs an update..
UnimeiyOusuih 3 years ago
I have made an alloy furnace in two different worlds and each time I place it and then try to use it, it gives me a blank blue screen that fills the page. I can exit just fine, but I can not use alloy furnaces. Anyone else have this problem? How can I stop this or fix this?
destinyx99 3 years ago
error unzipping a file for the following pack: Tekkit Attempting to extract file tekkitmain-1.0.zip, but it did not exist In addition, i get this problem in every technic modpack! How can i fix this problem
Kelix 3 years ago
I keep getting invalid credentials anyone know how to fix, I literally just reset everything from mojang to tekkit passwords and emails....please help i dont know whats going on
TurtleYT365 3 years ago
I don't know the why of it but a clean restart usually takes care of it for me. It's some kind of bug with the Launcher. No valid Minecraft password will work until you kill it completely, and "closing" the launcher often doesn't suffice. I believe you can find the processes in Task Manager and kill them for the same effect, but restarting is easier.
Posted by mcorrie 3 years ago
It is absolutely ridiculous and shameful that the pack for which this launcher and community is named has gone YEARS with no updates. My computer can just BARELY play the 1.7.10 pack, so poorly it's painful. This is the only other pack on EARTH with at least most of the big tech and convenience mods... and they're all hopelessly out of date. Suffering from bugs and missed features that have been fixed by the mod authors for multiple calendar years. SHAME! There are no other packs of modest size with Thermal Expansion, Minefactory Reloaded, Modular Powersuits, Galacticraft, Big Reactors, Atomic Science, and Extra Utilities... in a Minecraft version newer than 1.6.4. This pack needs to be updated to 1.7.1, BADLY. Every mod on its list has a version that supports that version. You should add EnderIO, some form of Equivalent Exchange (or ProjectE), and OpenBlocks. Maybe Bibliocraft while you're at it. I just can't play any bigger packs... and I can't stand playing this one knowing the bugs (broken recipes, etc.) don't have to be there, and that all these mods have new content we can't use. SHAME I SAY! UPDATE FREAKING NOW!
mcorrie 3 years ago
I partially retract my request. I recently got hold of a version of Bevo's Tech Pack and saw what they did to Minefactory Reloaded (hint - they nerfed EVERYTHING to be so hard you can't make a damned thing), so I'm far less enthused about updating that. What's the point of mods if you can't make anything useful whatsoever without farming PILES of freaking Nether Stars before you can actually get into the mods? If I wanted to play regular Minecraft for hundreds of hours and kill thousands of mobs the hard way, with regular tools and armor, I wouldn't bother with mods, now would I?
Posted by mcorrie 3 years ago
think of it this way, since it hasnt been updated it doesnt need a certain version of java
Posted by broman21 3 years ago
I too would love to see an update to the tekkit server it's due!
XtCrAvE 3 years ago
I downloaded the "Server Download", when i went to start the server it tells me the Galactic Craft update has failed
kweihl000 3 years ago
How long until tekkit 1.7?
adamjly 3 years ago
few years
Posted by SpaceGandalf 3 years ago
I keep getting invalid credentials anyone know how to fix, I literally just reset everything from mojang to tekkit passwords and emails....
Netheract 3 years ago
I keep getting the same thing aswell but ik I'm doing everything right
Posted by liamf1 3 years ago
I keep getting invalid credentials anyone know how to fix, I literally just reset everything from mojang to tekkit passwords and emails....
Netheract 3 years ago
I keep getting invalid credentials anyone know how to fix, I literally just reset everything from mojang to tekkit passwords and emails....
Netheract 3 years ago
I keep getting invalid credentials anyone know how to fix, I literally just reset everything from mojang to tekkit passwords and emails....
Netheract 3 years ago
I keep getting invalid credentials anyone know how to fix, I literally just reset everything from mojang to tekkit passwords and emails....
Netheract 3 years ago
I keep getting invalid credentials anyone know how to fix, I literally just reset everything from mojang to tekkit passwords and emails....
Netheract 3 years ago
Would it be at all possible to update this mod pack at least by one version?
LeoVeracruse 3 years ago
I use Tekkit, and am using lots of Buildcraft pipes and engines to create a machine that manufactures fireworks stars. I have attempted the same machine over 5 times and every time I get to a certain point and Tekkit crashes and Technic Launcher comes back into view. I try to reload my map and Tekkit crashes again, and again, and again. And ideas on what I can do to figure out what is going on, and how to fix it? Thanks in advance for any help.
nickademus420 3 years ago
i dont have tekkit in my lacher help me
emilwallin 3 years ago
In the top left corner of Technic Launcher there is a text box that you have to click in, then type Tekkit and hit enter on your keyboard. Then the left list will refresh with all versions of Tekkit available. Click on the one you want, then in the right hand window there will be an Install button. Click that, install, then Tekkit will appear on the left hand column every time you launch Technic Launcher.
Posted by nickademus420 3 years ago
why it always fails when I install it?
GamingPlusit 3 years ago
can you update all the mods to latest version
Bwebb02 3 years ago
Can you add Equivalent Excahnge?
Bwebb02 3 years ago
Exchange*
Posted by Bwebb02 3 years ago

Latest Update

Version 1.2.9i disables version update checks for all the mods, which were causing some people to crash.