Install RLCraft

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (RLCraft) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select RLCraft from the list on the left. The launcher will handle everything else!

RLCraft Version 2.9.1c

created by Shivaxi on Minecraft 1.12.2
You must be logged in to comment. Click here to register a new account or log in.
could someone please help me? :/ My minecraft always crashes when starting this! Its been like this since the new update. And I have no idea what to do! I already tried reinstalling the modpack
Katchupcato3o 3 years ago
Did you use a Javaversion 1.8.0_191 with 64-Bit and set the Memory to at least 3GB (maybe try if 3GB works and if the game crashes after some hours of playing you can raise it to 5GB)
Posted by Oompf 3 years ago
could someone please help me? :/ My minecraft always crashes when starting this! Its been like this since the new update. And I have no idea what to do! I already tried reinstalling the modpack
Katchupcato3o 3 years ago
Can't start server https://pastebin.com/hSVnard8gm
koneney 3 years ago
How do I install optifine to the modpack?
wongsw66 3 years ago
just put the optifine .jar into the mods folder.
Posted by xBlackD 3 years ago
the Jar File is a installer - it doesn't change anything to my version if i copy it to the mod folder (check "MODS" in Minecraft if optifine is loaded)
Posted by Oompf 3 years ago
You have to run the optifine jar file, hit "extract, and put THAT jar into the mod file
Posted by MrKyuubi 3 years ago
Not sure why but once I start up RLCraft Its loads all the mods etc and then once it gets to a certain point is freezes and crashes.
JustheretoplayRLCRAFT 3 years ago
don't have a server?
Itz_Chaos 3 years ago
so it loads up and it runs but by the time it finishes installing all the mods, the game closes and I don't really know what to do (I have it set to 5GB of ram)
PokeGirlPG21 3 years ago
I had to install Optifine 1.12 to get rid of this problem.
Posted by Zebro-Chromeo 3 years ago
My minecraft repeatedly crashes when i try to open it. Are there certain requirements for the pc to run rlCraft?
douglas065 3 years ago
5gb of ram allocated to java which requires a 64bit operating system
Posted by MajicReno 3 years ago
I really miss Soul Sword...
ratchetnoobie 3 years ago
we keep clicking install and nothing happens. Do we need to install on chrome
sheapreaper77 3 years ago
Hi, so, this modpack is pretty unplayable for me. For starters, no, I do not have a bad set up. I literally built this tower about two weeks ago. It has a Ryzen 1600, GTX 1050ti, 16 gb of RAM. The issue started when I tried to make a server for me and my friends to play on. I run a vanilla server fairly regularly and so far have had no problems with performance, with the CPU usage usually sitting at 6-15% usage. Yet, when I play RLCraft on singleplayer, not hosting any servers, the CPU usage is at 60-90 percent and the game stutters like crazy. So, you can imagine how laggy running a server on RLCraft was. Is there a way to fix this lag or is the mod just insanely unoptimized?
Teoras 3 years ago
i can only change my gb to 3.5 how do i get it to 5?
Simpa69 3 years ago
By the sounds of it you probably only have 4gb total and some of the 4gb cant be used because your computer needs it so it can do its background stuff to check right click your windows icon in the bottom left and click system it will tell you how many gb of ram you have.
Posted by MajicReno 3 years ago
Guys my game keeps crashing while starting minecraft plz help
mickky64 3 years ago
same
Posted by douglas065 3 years ago
same
Posted by douglas065 3 years ago
i have encountered a glitch where i cant use any of the nunchucks it says i need level 69420 im not even joking i need help tryin to fix it
fergus7068 3 years ago
Anyone want to start a survival server??
PurpleLemons2626 3 years ago
After installing the pack and clicking "Play", technic starts to 'grab' a lot of things. When it opens the game, it crashes immediately (I don't even get to see the game window), and the launcher reappears. I use 64-bit java with tons of ram (though I set it to 5gb in launcher options).
EternalWarmth 3 years ago
when it loads the main menu screen when using the technic launcher its automatically loaded into full screen with it zommed in like 400% on the top left corner and cannot seam to fix it. It only happens with this modpack
MrTrollZz 3 years ago
Try pressing F11 it toggles fullscreen.
Posted by MajicReno 3 years ago
Same problem! Have you got any way to fix it? It's SOOO annoying! I've heard F11 works but this is my laptop that was ORIGINALLY a working laptop, so its a different setting for me, (my computer broke so that's why I have to use this laptop) All i'm asking is to tell me if F11 works or if there is another way.. Thanks!
Posted by GamingToothless 3 years ago
Ok so I just fixed it! Basically I pressed Fn then F11, or the other way round, it'll zoom out and if you go into full screen it is fixed! Yippee!
Posted by GamingToothless 3 years ago
Since i updated to this version of the mod, my minecraft just crashes when loading my current world. I tried new worlds but they crashed too. I also tried reinstalling the mod several times with no luck. It would be nice to get some tips from someone that may know how to solve my problem. ^^
Katchupcato3o 3 years ago
is there should be only 116 mods or more ? I have that tin ore electrum etc. is missing
Kruk13 3 years ago
i have the requirements needed to run the mod but it still refuses to let me play
MONSTERJVR 3 years ago

Latest Update

RLCraft was updated to version 2.9.1c