Install Tyrants and Plebeians: PenULT

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Tyrants and Plebeians: PenULT) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Tyrants and Plebeians: PenULT from the list on the left. The launcher will handle everything else!

Tyrants and Plebeians: PenULT Version PU 3.7.1

created by LabJac on Minecraft Version 1.7.10
You must be logged in to comment. Click here to register a new account or log in.
Yeah. The error message in technic has to do something with copy.com
WeAllZLoVeCAKE 3 years ago
My name is not copy.com, I cannot solve this problem.
Posted by LabJac 3 years ago | Modpack Creator
i cant install the modpack
loporlp 3 years ago
HEY your bandwidth is somehow ran out for something. please fix this so i can download
Gaming_Zer0 3 years ago
That's copy.com's fault for being lazy with small bandwidth limits
Posted by LabJac 3 years ago | Modpack Creator
Well the download isn't working for me, got an error as well and must consult the author, and on the windows download my session is always invalid or my connection is throttled.
Nordbritkt 3 years ago
I blame copy.com for having a bandwidth limit. Try alternate installation methods: http://monorisu.enjin.com/forum/m/21720506/viewthread/22945124-tdm-modpack-alternate-installations/post/last#last
Posted by LabJac 3 years ago | Modpack Creator
I have a problem. While trying to download the modpack it gives me the error that I failed to download https://copy.com/3cVX4JUbKp6Ai46M Hope this helps! Thanks.
cooldudeJB6 3 years ago
CANT DOWNLOAD THE MODPACK ?????
Gaming_Zer0 3 years ago
i cant update the modpack :c
ethoman 3 years ago
The server is up again. So come forth, ye lifeless puppets!
LabJac 3 years ago
Am I the only one, wo cant open his inventory?
_IceBubble_ 3 years ago
When is the TDM return?
Gaming_Zer0 3 years ago
now
Posted by LabJac 3 years ago | Modpack Creator
why you don't add MCHeli
Carjan04 3 years ago
Labjac, when I try to install the mudpack, it give me an error and says to consult the modpack author. Is it just my computer being weird or is it the modpack being undownloadable.
ninjaboy8080 3 years ago
why always the monorisu servers and packs dont work ??????????
jeroen8 3 years ago
rip in kille cheeky prince server :(
TheMCJarhead 3 years ago
Due to issues with the server host, TDM server will be dead for at least one week while I go and setup the survival server.
LabJac 3 years ago
Many icons require fixing, Flansmod+ needs to be added in, resource pack crashes, resource pack inventory is so damn bright that i cant see shit and many models require retexturing
Comrade_Kevin 3 years ago
doesnt download
[email protected] 3 years ago
ooo! This sounds very chaotic and "shoot first ask questions never" type of thing. I love it :D
DukeNuke 3 years ago
aww, everytime i try to load it up it crashes at the part when the mojang screen comes up, the mojang screen is black. I have java 64bit so idk why it happend
Posted by DukeNuke 3 years ago
Please HELP ME!!!!When i try to use the binoculars i put it in my hand but dosen't work.Tryed to right click,left click but nothing.What i need to do for this to fix???
Japalpeno__ 3 years ago
Oh, binoculars have been broken for a while. That's why I didn't include them with any of the teams. Try the rangefinder instead!
Posted by LabJac 3 years ago | Modpack Creator
The Error Failed to download https://copy.com/3cVX4JUbKp6Ai46M occures, when i go to this Addres with the Browser there is written: Bandwidth Exceeded Sorry, this content has run out of bandwidth.
SirGorgeJones 3 years ago
That means copy.com is being lazy since it can't handle too many downloads at once. Try downloading again later.
Posted by LabJac 3 years ago | Modpack Creator

Latest Update

Tyrants and Plebeians: PenULT was updated to version PU 3.7.1