Install Monorisu: AoW 3

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Monorisu: AoW 3) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Monorisu: AoW 3 from the list on the left. The launcher will handle everything else!

Monorisu: AoW 3 Version AoW 3.7

created by LabJac on Minecraft Version 1.7.10
You must be logged in to comment. Click here to register a new account or log in.
Server Works now! :D Thanks for fixing lab
PrivateOmega 4 years ago
the server does not work !
Benll1000 4 years ago
check the overview and follow the steps to fix the server problem
Posted by PrivateOmega 4 years ago
Dropbox works if you copy the link to the place you're posting the download on and change the last number at the very end of the link to 1 instead of zero
SoulTrapper1630 [YT] 4 years ago
I already suggested that and he said that the bandwith is terrible which is 100% true.
Posted by jamesbail 4 years ago
maanalcho is speed hacking big time on the servers, please ban him. I'll try to get some footage.
jamesbail 4 years ago
https://youtu.be/Igjnn9707K0
Posted by jamesbail 4 years ago
Tried to play USA survival, died 400 thousand times, eventually got to the room with the guy you were supposed to capture, saw an NPC and was so tense I immediately shot him up, now the commander murders me on spawn.... plz help!
viper_247 4 years ago
that is supposed to happen
Posted by 27_Stop_it_TJ 4 years ago
It wont work because the uploader he was using shut down a few days ago (not allowing anyone to download). Can you just switch to dropbox or another uploaded until u can figure this out??!!!
jamesbail 4 years ago
Dropbox bandwidth limit is terrible. Anyways, I posted a bad solution. See modpack description for details
Posted by LabJac 4 years ago | Modpack Creator
cant down load an idk how to use alternative help!!!!!!!!!
Taffy_Da_Boss 4 years ago
what means couldnt download modpack failed to install /http copy or so ??? I cant get the pack;(
enesmelda 4 years ago
It's because copy.com is down :/ There's a quote from their site: "Service is no longer available as of May 1, 2016. Thank you for your support." We have to wait for another host... :|
Posted by R0ckwe11 4 years ago
I cant join the server every time i try to join the server i always get the connection time out is the server open?
WurstAndMemes 4 years ago
same problem
Posted by jeroen8 4 years ago
I used to be able to get on the server, but now I think my account or something has glitched. After the NSA and the hint, all text disappears, then the flamethrower sound effect plays before the modpack crashes. I have no clue what happened or why it is doing this, and yes I did delete it and I re-downloaded it. If anyone has any idea as to what to do please inform me!
E1ectr015 4 years ago
Edit: I found out the problem, turns out I am glitched at the edge of the world and it kicks me because of it. However, I have no clue how to fix it...
Posted by E1ectr015 4 years ago
anyone else not able to join tdm? every time i try it says "Disconnected"
xXLavaHawkXx 4 years ago
Sometimes the server does that for no reason. Try again later
Posted by LabJac 4 years ago | Modpack Creator
You should add the GrayWolf content pack! it's so cool! also, may i help manage the server? i can build maps and stuff.
Enderzio 4 years ago
I have played this pack before, but for some reason, when i join the server, it says "connection timed out" any suggestions?
Enderzio 4 years ago
Woo Hoo i managed to install it, by screwing up all my other mod packs XD
chaserocks2003 4 years ago
So, I think it says it's missing some pixel format or something...
EndyEnderman2 4 years ago
I CANNOT INSTALL IT!!! THE SEARCH BAR WONT LETS ME COPY AND PASTE TRANSLATION: YOUR MODPACK IS BROKEN
lazy/dude/man/kid5 4 years ago
When I press play, it loads Technic, disappears then opens Technic again.
EndyEnderman2 4 years ago
when I try to log in I get internal server error
Turret_Bud 4 years ago
Every time I try to join the server it always says FMLModRejection[Examplemod: 1.0]
Captainprice187 4 years ago
Is the tdm server down? I've been trying to join for two days and my connection is continually timed out; I've restarted and reinstalled multiple times and still nothing.
Nordbritkt 4 years ago

Latest Update

Monorisu: AoW 3 was updated to version AoW 3.7