Install Tekkit

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Tekkit) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Tekkit from the list on the left. The launcher will handle everything else!

Tekkit Version 1.2.9i

created by sct on Minecraft Version 1.6.4 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
Server Tutorial At https://www.youtube.com/watch?v=oUEoiBaJwkk For Mac Strictly!!!!
BrutalEater 5 years ago
Donwload server. Unpack. Launch. C:\Users\GoliafRS\AppData\Roaming\.tekkit>java -Xmx3G -Xms2G -jar Tekkit.jar nog ui ьр  22, 2015 12:43:12 PM net.minecraft.launchwrapper.LogWrapper log INFO: Loading tweak class name cpw.mods.fml.common.launcher.FMLServerTweaker ьр  22, 2015 12:43:12 PM net.minecraft.launchwrapper.LogWrapper log INFO: Using primary tweak class name cpw.mods.fml.common.launcher.FMLServerTweak er ьр  22, 2015 12:43:12 PM net.minecraft.launchwrapper.LogWrapper log INFO: Calling tweak class cpw.mods.fml.common.launcher.FMLServerTweaker 2015-05-22 12:43:12 [INFO] [ForgeModLoader] Forge Mod Loader version 6.4.49.965 for Minecraft 1.6.4 loading 2015-05-22 12:43:12 [INFO] [ForgeModLoader] Java is Java HotSpot(TM) 64-Bit Serv er VM, version 1.8.0_45, running on Windows 8.1:amd64:6.3, installed at C:\Progr am Files\Java\jre1.8.0_45 2015-05-22 12:43:12 [WARNING] [ForgeModLoader] The coremod codechicken.core.laun ch.DepLoader does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2015-05-22 12:43:12 [WARNING] [ForgeModLoader] The coremod appeng.transformer.Ap pEngCore does not have a MCVersion annotation, it may cause issues with this ver sion of Minecraft 2015-05-22 12:43:12 [INFO] [ForgeModLoader] [AppEng] Core Init 2015-05-22 12:43:12 [WARNING] [ForgeModLoader] The coremod calclavia.lib.Calclav iaPluginLoader does not have a MCVersion annotation, it may cause issues with th is version of Minecraft 2015-05-22 12:43:12 [WARNING] [ForgeModLoader] The coremod codechicken.core.laun ch.CodeChickenCorePlugin does not have a MCVersion annotation, it may cause issu es with this version of Minecraft 2015-05-22 12:43:13 [INFO] [STDERR] Warning: version of ForgeMultipart-universal -1.6.4-, 1.0.0.250 is newer than request 1.0.0.244 2015-05-22 12:43:13 [WARNING] [ForgeModLoader] The coremod cofh.asm.LoadingPlugi n does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2015-05-22 12:43:13 [WARNING] [ForgeModLoader] The coremod mods.immibis.microblo cks.coremod.MicroblocksCoreMod does not have a MCVersion annotation, it may caus e issues with this version of Minecraft 2015-05-22 12:43:13 [WARNING] [ForgeModLoader] The coremod invtweaks.forge.asm.F MLPlugin does not have a MCVersion annotation, it may cause issues with this ver sion of Minecraft 2015-05-22 12:43:13 [WARNING] [ForgeModLoader] The coremod logisticspipes.asm.Lo gisticsPipesCoreLoader does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2015-05-22 12:43:13 [WARNING] [ForgeModLoader] The coremod micdoodle8.mods.micco re.MicdoodlePlugin does not have a MCVersion annotation, it may cause issues wit h this version of Minecraft 2015-05-22 12:43:13 [WARNING] [ForgeModLoader] The coremod codechicken.nei.asm.N EICorePlugin does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2015-05-22 12:43:13 [WARNING] [ForgeModLoader] The coremod openmods.OpenModsCore Plugin does not have a MCVersion annotation, it may cause issues with this versi on of Minecraft 2015-05-22 12:43:13 [WARNING] [ForgeModLoader] The coremod codechicken.core.laun ch.DepLoader does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2015-05-22 12:43:13 [WARNING] [ForgeModLoader] The coremod mrtjp.projectred.comp atibility.CompatibilityCorePlugin does not have a MCVersion annotation, it may c ause issues with this version of Minecraft 2015-05-22 12:43:13 [WARNING] [ForgeModLoader] The coremod universalelectricity. core.UELoader does not have a MCVersion annotation, it may cause issues with thi s version of Minecraft 2015-05-22 12:43:13 [WARNING] [ForgeModLoader] The coremod codechicken.core.laun ch.DepLoader does not have a MCVersion annotation, it may cause issues with this version of Minecraft 2015-05-22 12:43:13 [INFO] [ForgeModLoader] Loading tweak class name cpw.mods.fm l.common.launcher.FMLInjectionAndSortingTweaker 2015-05-22 12:43:13 [INFO] [ForgeModLoader] Loading tweak class name cpw.mods.fm l.common.launcher.FMLDeobfTweaker 2015-05-22 12:43:13 [INFO] [ForgeModLoader] Calling tweak class cpw.mods.fml.com mon.launcher.FMLInjectionAndSortingTweaker 2015-05-22 12:43:13 [SEVERE] [ForgeModLoader] Unable to launch java.util.ConcurrentModificationException at java.util.ArrayList$Itr.checkForComodification(Unknown Source) at java.util.ArrayList$Itr.remove(Unknown Source) at net.minecraft.launchwrapper.Launch.launch(Launch.java:114) at net.minecraft.launchwrapper.Launch.main(Launch.java:27) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at cpw.mods.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.j ava:48) at cpw.mods.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper. java:17) What did I do wrong?
GoliafRS 5 years ago
I get the exact same error message. Did you manage to fix this?
Posted by FiscalBasilisk 5 years ago
I get the exact same error message. Did you manage to fix this?
Posted by FiscalBasilisk 5 years ago
Turns out this is a problem with Java 8 for the server. Once I uninstalled 8 and installed 7 it ran fine. I thought the latest update says it works fine on 8 though?
Posted by FiscalBasilisk 5 years ago
Does anyone know when this modpack will update to the latest release of ComputerCraft?
ericmacfa 5 years ago
!!!Bug!!! If you press F11 or try to get minecraft full screen it will crash
hockeyninja 5 years ago
Not for me.
Posted by The Average Pro 5 years ago
i don't understand why i always get id mismatches on my server, yes i'm running the correct server/client version, i have tried to delete / re-install everything but nothing seems to work. ID 102 is mismatched, ID 335 is mismatched and ID 79 is mismatched. Please help
liamdean123 5 years ago
This is fucking retarded it wont let me login because its invalid I changed my fucking password and copied and pasted it and it still doensn't work WTF
thelunarnova 5 years ago
It isn't letting me open my world I've been working on it needs to be updated!?!
Jordstar020401 5 years ago
Yeah sadly that world has become incompatible probably. There are guides to fix it I think.
Posted by The Average Pro 5 years ago
so when are you going to upgrade it to minecraft 1.7.1? I'm not going to assume you're going to do 1.8.3 any time soon
aaronbray91 5 years ago
I have a problem where I can only open the official modpacks but not the modpacks that are not offical
minecrazyguy 5 years ago
The unofficial mod packs have to download.
Posted by The Average Pro 5 years ago
I have tried hosting a tekkit server using Hamachi, it works fine and my friend can join however there the mods don't works, why is this me and my friend can see the mod items but can't build or spawn them when trying to spawn them it says the items ID doesn't excsist, please help?
[email protected] 5 years ago
i have the same problem. the mods work for me when i play single player tho. and from me please help.
Posted by redbazil 5 years ago
Run launch.bat
Posted by The Average Pro 5 years ago
I have problem
[email protected] 5 years ago
Canvox, I have an honest question for you... WHY DO YOU NEVER EVER UPDATE HEXXIT? Whilst Tekkits modpack thrives, hexxits modpack is clinging to what little life is left, I think it'd be in eveyones interest if you merged hexxit with tekkit if your technic crew doesn't want to update hexxit any more, hexxit doesn't really break any industrial immersion and in fact may even benefit it, I strongly suggest the next time you think of updating the tekkit modpack you do all tekkit players a huge honor and service by flatout merging hexxit also...
FurryletsplayerX 5 years ago
and also, the smoking blocks would be the ultimate nice touch to our tekkit factories, backpacks and daypacks which can be dyed and placed are an awesome idea, and bags that can conntain items and containers as well as the light sources could all be beneficial to the immersion and even mechanics of tekkit.
Posted by FurryletsplayerX 5 years ago
you sould add tinkers construct and botania
jake75155 5 years ago
Tinkers construct is good, I'd support that being added except that it's not exactly technology. It's more... Medieval, incidentally it IS medieval technology. Botania though, I don't think it should be added. Because Botania is all about magic. Equivalent exchange and Mystcraft already seem too magical for tekkit IMHO.
Posted by Kodasa 5 years ago
Me and my friend are trying to play together but we both have this issue with the server. When i open the start.bat it opens the cmd a bit of text pops up but the actual server doesnt run. the cmd (black box) doesnt close it stays open till i press a button. the weird thing is if i run the normal server file i can play it but obviously no mods work. PLZ help
darkor1243 5 years ago
The CMD actually explains the whole problem if you read it. "Could not reserve enough space for 314728KB object heap". What the CMD does is it mods the server. The normal minecraft_server.1.6.4 isn't modded until the CMD has downloaded the object heap. The object heap is 3.1GB. I seem to have some glitch where I have enough space yet it still thinks I don't.
Posted by The Average Pro 5 years ago
My friend has a server using this modpack, and I've never had issues playing on it before. Now it says that the server was updated to 1.7.10, but I can't find a way to play it on anything other than 1.6.4. How can I fix this so I can play on his server?
goofdude 5 years ago
He might be using an experimental build.
Posted by The Average Pro 5 years ago
Also make sure its the right modpack.
Posted by The Average Pro 5 years ago
no mod packs work at all the minecraft says java ae bineriy is not responding why does this happen i get the app finally and i cant use it why Technic please fix this for me plz
demoniccinnimon9 5 years ago
no mod packs work at all the minecraft says java ae bineriy is not responding why does this happen i get the app finally and i cant use it why Technic please fix this for me plz
demoniccinnimon9 5 years ago
no mod packs work at all the minecraft says java ae bineriy is not responding why does this happen i get the app finally and i cant use it why Technic please fix this for me plz
demoniccinnimon9 5 years ago
no mod packs work at all the minecraft says java ae bineriy is not responding why does this happen i get the app finally and i cant use it why Technic please fix this for me plz
demoniccinnimon9 5 years ago
no mod packs work at all the minecraft says java ae bineriy is not responding why does this happen i get the app finally and i cant use it why Technic please fix this for me plz
demoniccinnimon9 5 years ago

Latest Update

An update to the server files (named Tekkit_Server_v1.2.9g-2.zip) has been pushed, which fixes a crash at start due to bspkrsCore failing an update check