Install The Classic Pack

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (The Classic Pack) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select The Classic Pack from the list on the left. The launcher will handle everything else!

The Classic Pack Version 3.3.5

created by Pulz on Minecraft 1.12.2 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
Is there some kind of Sphax patch for this?
nettrow 5 years ago
Sphax patches are available for almost every mod in the pack, which due to their Terms of Service- cannot be redistributed (even modified versions). Speak to me or PikaArc on the Discord server and we can point you straight to the right links!
Posted by Pulz 5 years ago | Modpack Creator
Hello! I wanted to ask the developer if he could add more security mods? It would be cool seeing security mods so i can make my base more secure on a public server of mine! Please do so if you want! Securitycraft would be great!!
Flashyyxd 5 years ago
Hi, feel free to add this to #requests on my Discord.
Posted by Pulz 5 years ago | Modpack Creator
Hi All I started a new server with a friend, I have noticed I cannot craft TNT, lava buckets etc. I have tweaked the essentials plugin and even removed it from the server. i tried single player and still the same issue. is this a bug or has TNT etc been disabled completely in this modpack?
EQUALEXPERT 5 years ago
This has been fixed in the latest release, not sure what caused the issue- but MineTweaker has allowed me to make a work around.
Posted by Pulz 5 years ago | Modpack Creator
Excellent thank you. dont suppose the same work around would do for world anchors as part of RailCraft? they just arent there.
Posted by EQUALEXPERT 5 years ago
Anchors were fixed as part of the 2.5.3 update
Posted by Pulz 5 years ago | Modpack Creator
After updating to version 2.5.1, trying to connect to my own server it says connection lost: Fatally missing blocks and items.
Plumps68 5 years ago
Hey! Make sure you download a fresh copy of the server pack files, and replace the config folder with a fresh copy! This has solved the issue for other people.
Posted by Pulz 5 years ago | Modpack Creator
i cant use my axe it says first position set to...
Jttigas4422 5 years ago
Hye Jttigas, that would be the wooden axe from WorldEdit. Just use a stone or better axe :) If this is happening with non axe items, contact me on the Discord!
Posted by Pulz 5 years ago | Modpack Creator
hi,im having a problem where I am unable to break blocks because it says in chat...first position marked then it shows coordinates. Is their a way to disable this?
addison01642 5 years ago
Hye addison, that would be the wooden axe from WorldEdit. Just use a stone or better axe :) If this is happening with non axe items, contact me on the Discord!
Posted by Pulz 5 years ago | Modpack Creator
Hey guys, another question regarding the energy link. There is no energy link and i cannot convert bc power to ic. I have the geothermal generator working and supplied with lava from the Nether, and i cannot use the power for my Quarry. Please help. Engines are not an option since I am producing way more power than those engines ever could.
Geralt86 6 years ago
Hi Heisenburg86, I included the mod "Power Converter" for this very reason. That said, the recipe for one of the required components (Module TE) is broken, as it depends on a mod we can't use. So if you are on a server/single player, you will need to find a way of having them spawned in!
Posted by Pulz 5 years ago | Modpack Creator
Hey guys. I'm having a problem crafting a Geothermal Generator. The universal cells are not working in the recipe and neither is making cells using the extractor. I'm stuck and I really need the generators for my projects. How can I make the geothermal generator on this pack?Help. Been stuck for a whole day now.
Geralt86 6 years ago
Hi Heisenberg86, you may be getting mixed up with the different cells! Using Empty UNIVERSAL fluid cells will give you the UNIVERSAL fluid cell. Using just an Empty cell, will give you the coolant cell. Feel free to ask on the Discord if this doesn't help!
Posted by Pulz 6 years ago | Modpack Creator
Hey heisenberg86, pulz said universal cells wont work and dont make normal cells in the extractor, you need a metal former which is on extruding and then you need to put a tin plate inside you will get 3 normal cells then =)
Posted by PikaArc 6 years ago
Hey guys. Thanks for your help. The tin in the metal former on extruding did the trick. What a relief. Thank you very much.
Posted by Geralt86 6 years ago
Is there any resource packs for this modpack? I just hate the default look, but i really want to play the modpack :(
LokeThorsteinsson 6 years ago
I recommend Sphax- you can download the individual patches for each TNTC mod. Due to their ToS, I can't distribute a pre-compiled Sphax texturepack. Sorry.
Posted by Pulz 6 years ago | Modpack Creator
There is a problem with the mod "Power Utilities". The crafting recipe for the power converter item is uncraftable. It requires two key items that are apart of the 'Power Utilities' mod, the 'IC Module' and the 'TE Module'. You are able to craft the 'IC Module' but there is no recipe for the 'TE Module' Now I did some research and testing and found out that the "Power Converter" does work as its intended to link IC and BC power when I spawned it into a single player mode. The issue is that you cannot craft it because the 'TE Module' does not have a recipe. So, my suggestion would be to either create a recipe for the 'TE Module' somehow in the files of the game.... or..... remove the mod entirely and replace it with a similar but in my opinion better and updated mod called "Power Converters 3" (Link: The one to use is the most recent 'PowerConverters 2.11' (located under the files tab), compatable with 1.7.10. I think this would be a huge upgrade to the current "Power Utilities" Mod.
IamSnips 6 years ago
Apologies for the somewhat late reply. We have already remedied this issue by adding the TE module to a free /kit on the official server. I suggest other servers do the same until I implement either a recipe or fix!
Posted by Pulz 6 years ago | Modpack Creator
Awesome modpack bro, I was trying to create something like this but then I found yours and thought "It's perfect!"
xcastzcast 6 years ago
Hello xcast, I'm glad to hear you are finding the pack fun! Make sure you pop over to our Discord if you haven't already, so you can be part of the community that drives the direction of the pack :)
Posted by Pulz 6 years ago | Modpack Creator
Can you add "Power Utilites 1.0.4" it only adds the old Energy Link from tekkit classic, works the same way it used to. It let's you convert RF to EU and RF to EU, which was a big thing back in Tekkit classic. Here is a picture of it in use: Link to the mod:
ZoroarkEX 6 years ago
Hi Zoroark, just posting to confirm that your request was received loud and clear! It is something I have been considering recently, and is more than likely to appear in an upcoming version ;) Thank you for your continued support!
Posted by Pulz 6 years ago | Modpack Creator
Hi, Pulz. Thanks for adding the mod! But I see I forgot to mention I had to change the recipe with minetweaker and MineTweaker RecipeMaker to make the energy link craftable on my client and my own server. It is a quick fix. Download "minetweaker" and "MineTweaker RecipeMaker", add it to the client and server. Use the new command "/mtrm" to get the recipe maker GUI and make the recipe you want. It will make a file in the new "scripts" folder in the modpacks main folder. Then just make sure both the server and client have the same files in the "scripts" folder. I think if you add the scripts folder to and the server download, everyone should be able to have the same recipe when they download the modpack. I changed it to require two "module IC", instead of one "module IC" and one "module TE" (since module TE seems to be uncraftable), but it is possible to make it use the same recipe as the old tekkit classic as well.
Posted by ZoroarkEX 6 years ago
It seems like's comment sections doesn't like new lines so that comment became a wall of text, but I hope it is still readable.
Posted by ZoroarkEX 6 years ago
Sorry for the late response ZoroarkEX- I'm aware of this and have already fixed this. It will be present in the next update!
Posted by Pulz 5 years ago | Modpack Creator
Hi Pulz! I gotta say this modpack is really awesome. I've had tons of fun so far and I'm always coming back for more! However, the new update has created some problems on my save back from the version and it seems there is no possibility to downgrade modpack version from the Technic Launcher level. Is it temporary, will there be any way to install older modpack versions to continue playing on old saves?
BloXx321 6 years ago
Hey BloX, thank you for the positive feedback! Unfortunately, unless you have a copy of the version you won't be able to *easily* downgrade! I took over the pack after this version, and have no copy of the old files- as there was no intention to have any backwards support. Sorry!
Posted by Pulz 6 years ago | Modpack Creator
why can't I change the direction my buildcraft redstone engines are facing?
MexBlickbarn 6 years ago
Hey Mex, you can join our Discord for much, much quicker support! The engines should orient themselves correctly based on the pipe you are using- and you can easily pick them up to try again with a pickaxe. You could also try using the Wrench- if you haven't already.
Posted by Pulz 6 years ago | Modpack Creator
Looks like the server isn't working.
JotaBastos 6 years ago
Feel free to drop by the Discord support channel and I'll help you out!
Posted by Pulz 6 years ago | Modpack Creator
seems like the server pack link isnt active anymore. is this gona be fix soon. would like to make a server for me and my friends
justin2664 6 years ago
Hi Justin, I've taken over the pack ownership and have updated a bunch of the mods. It is possible the link was unavailable during that upload time! I apologise for the inconvenience.
Posted by Pulz 6 years ago | Modpack Creator
I like this modpack but everytime i die or log out of my world my skin is a steve skin you need to fix that.
Gabriel_Xeon 6 years ago
Hi Gabriel, That is indeed an annoying issue. A fix I have found (for servers, at least) is to run the plugin ChangeSkin. This appears to fix the issue most of the time.
Posted by Pulz 6 years ago | Modpack Creator
In old tekkit you could convert IC2 power to BC power with a "Power link", it looks like that mod isn't in this modpack. Is there another way to convert power or could that mod be added?
zxpmc 6 years ago
Hey. I really like the modpack. I like all the changes and the differences from the old tekkit classic. But i was wondering how the UU-matter works now? Why is it Fluid? How to i make it to iridium ore? Please explain. Thank you
s0ulberg 6 years ago
What mods do I remove to make this work as a server?
LTWalri 6 years ago

Latest Update

Removes Planar Artifice, preventing unfixed bugs ranging from server/client crashes. Resolves Botania coal duplication and inconsistent Thaumcraft Aspects on items. Adds Joys of Painting, a way to paint artwork