Install The Classic Pack

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (The Classic Pack) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select The Classic Pack from the list on the left. The launcher will handle everything else!

The Classic Pack Version 3.1.6

created by Pulz on Minecraft Version 1.12.2 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
the mod pack wont load i have everything downloaded and it keeps crashing i have tried to uninstall and reinstal but nothing works i wwould like some help if anybody could help me
DarnByte2 1 year ago
Feel free to join the Discord and we can troubleshoot your issue. The most common issues people report are due to them not allocating a minimum of 2GB RAM and/or having the wrong java version (x32 instead of x64)
Posted by Pulz 1 year ago | Modpack Creator
https://paste.dimdev.org/ogozudesil.mccrash Crashes everytime i try to load it any tips?
sestyan 1 year ago
The Discord server is the quickest place to get support. Your log states that you are only using 1GB of RAM, when 2GB is the minimum required the launch the pack.
Posted by Pulz 1 year ago | Modpack Creator
Can we expect an update to 1.13?
InDirectVariant 1 year ago
This isn't a question I can answer sadly. Yes, I'd be interested in updating to 1.13- but we have to wait for Forge/Rift to finish updating, and then wait for the mods to update too.
Posted by Pulz 1 year ago | Modpack Creator
Hi, could you explain what the main purpose of modpack is?
Davi sartori 1 year ago
As per the modpack description: The Classic Pack is inspired by Tekkit- bringing updates to the Classic mods that started the modded scene on Minecraft. There's a mix of magic and technology mods- so you are encouraged to start the pack any way you want. Questbooks are in development currently to bring even more things to do.
Posted by Pulz 1 year ago | Modpack Creator
It would be really nice if you could fix the problem mentioned earlier about the EMC values in the 3.0.8 patch or something. the joy of playing tekkit is the lack of work you need to put down to play modded minecraft. would be very much appreciated.
swezero398 1 year ago
In the most recent update as I am playing singleplayer many objects which I know in the past had emc values under the equivalent exchange system (such as netherrack, low medium and high covalence dust, and the energy collecter mark 1) no longer have emc values, is this a glitch in the pack, on my computer specifically, or is it an intentional removal of these values?
likeablock2113 1 year ago
That isn't a cause of the latest update- it's been like that for a very long time. You can re-add these on a server by deleting the ProjectE folder that comes with the download and letting a fresh one generate. For singleplayer, you'd need to install the modpack on the vanilla launcher and delete the ProjectE folder as above. There is a written guide: https://www.theclassicpack.com/forums/m/50366894/viewthread/32333685-classic-pack-forge-tutorial
Posted by Pulz 1 year ago | Modpack Creator
HELP me pls! when I click install it then when it installs there is no PLAY option
Kapeu 1 year ago
Hi, please join our Discord server and make a ticket- where you can provide your logs and get a solution!
Posted by Pulz 1 year ago | Modpack Creator
Problems with Mantle and Tinker's
FanySilva 1 year ago
https://paste.dimdev.org/julanutovo.mccrash
Posted by FanySilva 1 year ago
Hi, you only have 1GB allocated- you need at least 2GB to load the pack. I recommend around 4GB for the best performance. You may need to install Java x64 if you haven't got it already- feel free to hop on the Discord for faster support if you need it!
Posted by Pulz 1 year ago | Modpack Creator
Absolutely loving playing this pack with my friends! It would be awesome if you could add Chisel :) keep it up!
Raddari 1 year ago
Hi, I'm glad to hear you're enjoying the pack! Chisel has been requested a few times, but may not be entering the pack for a while due to its history of server issues :(
Posted by Pulz 1 year ago | Modpack Creator
im having trouble finding a texture pack for this modpack. you know of any?
ModWingz 1 year ago
There are a few fan made sphax patch packs available on the Discord if you hop on and ask. An official Sphax patch will be available shortly after the next update, which is due to drop reasonably soon.
Posted by Pulz 1 year ago | Modpack Creator
Hi, Railcraft released a beta version. Would it be able to use this in the modpack? https://minecraft.curseforge.com/projects/railcraft/files?filter-game-version=1738749986%3a628
Fichtme 1 year ago
Yep, I am aware of this and watching it carefully. I'm just waiting to see if any critical bugs are found- as I can't risk putting something like that into the pack. I will likely start doing my own testing with the TCP community to help speed things along.
Posted by Pulz 1 year ago | Modpack Creator
Sounds good man, dont know how to reply to your comment xD!
Posted by Fichtme 1 year ago
hello its me again . the modpack started crasing (it just didint open) i treid a lot of diferent things and none of them worked. then i took the mod folder of this modpack (appdata/Roaming/technic/modpacks) and uplaudet it to appdata/Roaming/minecraft/versions ant tried to open it and it sayd that thaumcraft didint respond so i deleted thaumicperiphery-0-3-0-jar tc6aspects4jei-0-0-2a-jar thaumcraft-1-12-2-6-1-beta25-jar thaumicinventoryscanning-1-12-2-2-0-10-jar thaumicinventoryscanning-1-12-2-2-0-10-jar treid to open it and it fully worked , but my base is a treehuose in a greatwood so then i downlaudet it from the web ( the mods mentioned above) i opened it agau everyting from thaumcraft was back ( i had a copy of my map) so am if yuo have similar problems yuo can try this also love this modpack and stevescart is waud be great ( sorry for bad english )
Ponas_LT 1 year ago
Hi Ponas, I'm glad you're enjoying the pack. I am considering adding Steve's cart in the next update :) If you have crashing issues, hop on the discord and open a ticket. There's no reason for you to not be able to enjoy the full experience the modpack has to offer!
Posted by Pulz 1 year ago | Modpack Creator
i downloaded tekkit and got the classic pack mod pack and then when i press play it crashes and just shuts down the tekkit launcher, can anyone help me
bean_1_2 1 year ago
Please join the Discord server and open a support ticket, where you can provide your logs for help. The most common issue is having x32 java instead of x64, and not having at LEAST 2GB of RAM.
Posted by Pulz 1 year ago | Modpack Creator
hello i love your modpack . but i have done everything (even collected all of the tree saplings) explored a lot and faund 8 viliges 3 ocean monuments and i will love to conect them by a railway but vanila rails are "bad" so can yuo make a vesion of your pack wint railcraft? (i tried and failed) please (sorry for bad english)
Ponas_LT 1 year ago
Unfortunately, railcraft is not available for 1.12.2. I am considering adding Steve's Carts as a replacement.
Posted by Pulz 1 year ago | Modpack Creator
Oh, and thank you for the kind words :) I'm glad to hear you are enjoying the pack.
Posted by Pulz 1 year ago | Modpack Creator
Hi there. Do you plan to add another mods? This modpack is very good and I'm enjoying it, but if this modpack could have mods like mystcraft (for traveling and creating worlds) and maybe twilight foerest or other (for that 1 or 2 extra dimensions), this modpack would be the best I had ever played.
DennyB 1 year ago
Hello DennyB, of course. I'm glad to hear you're enjoying the modpack. You can make mod requests on the Discord server in #requests. I can't guarantee every mod requested will get added- but the mods in the pack were all user requested.
Posted by Pulz 1 year ago | Modpack Creator
emc values of the item in ProjectE and coal anyway to fix just want that to be back to the same at least cause then the mod is near useless if it takes a year to make the tools...
GenLickswell 1 year ago
By default, EMC is heavily nerfed to make you less dependent on ProjectE. As previously, you'd just find some diamonds- make a collector, and afk for all of your items. That said, if you really want to reset EMC to default- you'll need to set up the modpack on the vanilla launcher (https://www.theclassicpack.com/d/20-tntc-forge-tutorial) and delete the ProjectE config folder. Servers can delete this config too- as the server config is what is used.
Posted by Pulz 1 year ago | Modpack Creator
Can you fix the Emc values? a lot of item don't have Emc values and im fine with a lot of mods not having values but I feel all the default Minecraft items should.
Fluffymanhero 1 year ago
By default, EMC is heavily nerfed to make you less dependent on ProjectE. As previously, you'd just find some diamonds- make a collector, and afk for all of your items. That said, if you really want to reset EMC to default- you'll need to set up the modpack on the vanilla launcher (https://www.theclassicpack.com/d/20-tntc-forge-tutorial) and delete the ProjectE config folder. Servers can delete this config too- as the server config is what is used.
Posted by Pulz 1 year ago | Modpack Creator
How much ram would be the minimum for a small 5 player server?
creeperboy_12 1 year ago
I'd say 3GB as a very minimum- for 5 people, as long as you aren't constantly exploring and generating new land. Obviously more is better, though you shouldn't need more than 5GB tops for such a small server.
Posted by Pulz 1 year ago | Modpack Creator
How long did it take you to create this modpack?
MinerCrafterWes 1 year ago
Quite a long time. It's been out for years, and has been improved and updated quite frequently.
Posted by Pulz 1 year ago | Modpack Creator
Hi there, awesome modpack and thanks for the update. Is it possible somehow to migrate old worlds to version 3.0?
d3936701 1 year ago
1.7.10 modded worlds are not compatible with 1.12.2, sorry.
Posted by Pulz 1 year ago | Modpack Creator

Latest Update

The Classic Pack was updated to version 3.1.6