Install The 1.7.10 Pack

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (The 1.7.10 Pack) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select The 1.7.10 Pack from the list on the left. The launcher will handle everything else!

The 1.7.10 Pack Version 0.9.8b

created by Hi it's me on Minecraft Version 1.7.10 using Technic Solder
We added the required libary files as another mod so it'll download from out host. Should fix the problems with new installs. Enjoy!
Hi it's me posted a status update for The 1.7.10 Pack 3 years ago

Comments

You must be logged in to comment. Click here to register a new account or log in.
I have been trying to add the Metallurgy mod to this pack all night long. I love the mod because it adds so many great blocks and recipes. I have the latest version but it just doesn't seem to want to play nice. Is that why you chose not to add it? Do you have any idea how I might be able to get it to work?
Posted by Eliannawhm 3 years ago
This is not relevant to here, go to the "HELP" section to get general support :)
Posted by Hi it's me 3 years ago
every time i try to play it doesn't load Mine craft all it does is closes out of the tech launcher then re-opens it. Please help.
Posted by vhgdy 3 years ago
Go to the "HELP" section to get help.
Posted by Hi it's me 3 years ago
THANK YOU! I've been trying to install for a week with the same error. Adding those files fixed it.
Posted by unfazeable 3 years ago
Thanks for verifying :)
Posted by Hi it's me 3 years ago
THANK YOU! I've been trying to install for a week with the same error. Adding those files fixed it.
Posted by unfazeable 3 years ago
the problem was fixed when I updated the pack to 7.8, but It came back when I enter in the servers
Posted by IceWizzard 3 years ago
Go to the "HELP" section to get help!
Posted by Hi it's me 3 years ago
the problem was fixed when I updated the pack to 7.8, but It came back when I enter in the servers
Posted by IceWizzard 3 years ago
ive just downloaded this pack today, got this error when launching: A download error has occured CB's DepLoader was unable to downlaod required library MrTJPCore-1.7.10-1.0.6.13-universal.jar Check your internet connection and try restarting or downloading it manually from: (link doesnt work) and put it in your mods folder. ive been researching this error for half an hour now, found a week old thread on github, your manual fix there didnt work, ive reinstalled the pack twice now and still get this error every time. I know this should probably be in help section but it seems that this update you posted here didnt work for me.
Posted by juliang790 3 years ago
NVM this comment found the fix i needed just took a little more digging :P
Posted by juliang790 3 years ago
could you tell me what to do?
Posted by Psykomanteum 3 years ago
https://github.com/The-1-7-10-Pack/The-1.7.10-Pack/issues/723
Posted by Hi it's me 3 years ago
i tried re-downloading, but I continue to get the same error.
Posted by Psykomanteum 3 years ago
Look at the GitHub page of the modpack for more information.
Posted by Hi it's me 3 years ago
Great pack keep up the good work :)
Posted by Taylor_1996 3 years ago
Modpack does not work, even when developer says it should, cannot like until this is fixed. It fails to install something once chickencore comes up.
Posted by thomas61157 3 years ago
Also note, I did go install the file manually it was complaining about and it did not fix anything.
Posted by thomas61157 3 years ago
It has been fixed.
Posted by Hi it's me 3 years ago

Latest Update

Thank you to all who have donated and supported the modpack's development. Recently we found that there is an issue with the donor capes on our end. It should be fixed within a couple of days so you could all show them off again!