Install The 1.7.10 Pack

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (The 1.7.10 Pack) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select The 1.7.10 Pack from the list on the left. The launcher will handle everything else!

The 1.7.10 Pack Version 0.9.8c

created by Hi it's me on Minecraft Version 1.7.10 using Technic Solder
If you suffered from crashing after updating to v0.9.8c, please reinstall the modpack now as this will revert the LumySkinPatch mod to its older version. That should fix your issue!
The 1.7.10 Pack was updated to version 0.9.8c 2 weeks ago
✔ The issue has been fixed & there shouldn't be any more issues downloading the pack. Happy playing!
Hi it's me 2 weeks ago
⚠ We are currently experiencing technical difficulties on our end with Solder, for anyone who wants to download the modpack. We're working on this issue, and will post status updates when it gets resolved. Thank you for your patience!
Hi it's me 2 weeks ago
Hello everyone! The modpack didn't receive a planned update recently because of personal stuff, but we're planning to release it in the next month or so. Also, there are other big (updated) surprises cooking. Stay tuned!
Hi it's me 3 weeks ago
Thank you to all who have donated and supported the modpack's development. Recently we found that there is an issue with the donor capes on our end. It should be fixed within a couple of days so you could all show them off again!
Hi it's me 6 months ago
The 1.7.10 Pack was updated to version 0.9.8 1 year ago
After almost 3 years, this "little" project of mine really surprised. I want to thanks all donors that supported my dev of the pack and bought a donor cape through bit.ly/The-1-7-10-Pack-Donate; you helped making it what it is.. full message in Discord.
The 1.7.10 Pack was updated to version 0.9.7 2 years ago
Hi everyone! The modpack didn't receive many updates lately because we've been very busy with personal stuff, but we're planning to release at least one-two last updates that we'll work on throughout June and forward. Expect mod updates and new surprises!
The 1.7.10 Pack was updated to version 0.9.6 2 years ago
After more than 2 years we're almost reaching the 500K downloads milestone and I personally wanted to throw out a big thanks again to whoever donated and supported this modpack's development; it's not obvious (..Character limit, full message in Discord)
Hi it's me 2 years ago
There were a lot of questions recently about switching Mystrcraft with RFTools and we just want to say that it's not planned. Currently we do not intend to play too much with the mod list but mainly just keep things working and updated. Thank you!
Hi it's me 2 years ago
450000 downloads; almost 3000000 runs, and over 2000 likes: Due to Technic's character limit, you can find the full status in the modpack's Discord announcements channel, but still I want to say here too: Thank you!
Hi it's me 2 years ago
The 1.7.10 Pack was updated to version 0.9.4 2 years ago
For anyone that wonders, *donors will get their cape automatically*, and no modpack update is required; maybe just a simple client re-launch to pull the refreshed API :)
Hi it's me 2 years ago
The 1.7.10 Pack was updated to version 0.9.3 2 years ago
Would you want us to update to Magical Crops 4 in the next modpack update although the consequences? This means all blocks/items in old worlds from Magical Crops 3 disappear. Vote your opinion here: http://www.strawpoll.me/11059760
Hi it's me 2 years ago
The 1.7.10 Pack was updated to version 0.9.2 3 years ago
Thanks to Novamange the modpack's Sphax patch has been updated to match all the mods of v0.9.1! Grab it while it's hot here: bit.ly/The-1-7-10-Pack-Sphax
Hi it's me 3 years ago

Latest Update

If you suffered from crashing after updating to v0.9.8c, please reinstall the modpack now as this will revert the LumySkinPatch mod to its older version. That should fix your issue!