Install The 1.7.10 Pack

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (The 1.7.10 Pack) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select The 1.7.10 Pack from the list on the left. The launcher will handle everything else!

The 1.7.10 Pack Version 0.9.8c

created by Hi it's me on Minecraft Version 1.7.10 using Technic Solder

The 1.7.10 Pack updated to version 0.9.4

A new small update! Yes, these still happen! And as for today's quote of the day: "'If you're going through hell, keep going.' -- Winston Churchill", by Lord Ptolemy; How great!

- Added the Compacter mod, per request, very useful for making compressed items and such.
- Updated 13 mods to their latest versions, all of the mods in the modpack are up to date. Also note that a new version of Jon's Exclusives is also in servers now, so players can get their in-game messages there too.
- Some minor configuration changes.
Currently set to the "Recommended" branch.

And, as always, if you're interested the fully detailed changelog of this version, it can be found in this link: http://bit.ly/v0-9-4
Enjoy!
Hi it's me posted a changelog update for The 1.7.10 Pack 3 years ago

Comments

You must be logged in to comment. Click here to register a new account or log in.
Please add Draconic Evolution. Would be great.
Posted by xJonasx_ 3 years ago

Latest Update

If you suffered from crashing after updating to v0.9.8c, please reinstall the modpack now as this will revert the LumySkinPatch mod to its older version. That should fix your issue!