Install Tekkit

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Tekkit) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Tekkit from the list on the left. The launcher will handle everything else!

Tekkit Version 1.2.9i

created by sct on Minecraft 1.6.4 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
how can i download this fucking pack you fucking sohn of a bitch
Lolmaster110 8 years ago
Get your free Steam Gift Card at http://getsteamgifts.com/ I got my Steam Gift Card there!
minecraftwizard 8 years ago
Get your free Steam Gift Card at http://getsteamgifts.com/ You can choose any game you want!
shadowdragon239 8 years ago
add tinkers pls
crayfishcraig 8 years ago
Overall excellent; I keep coming back. Unfortunately, plagued by so many annoyances: * Badly needs to be updated into the 1.7-ish range. So many little things, like not being able to find any Witches, EVER, even with Mystcraft, etc. * Badly needs Ender IO. So tired of debugging TE ducts over and over again. * Some mods woefully and inexcusably out of date: specifically, Galacticraft (no asteroids) and Extra Utilities (inversion sigil doesn't even work at all until next update... which is over a year old as of today). * Maybe consider substituting Project E for EE3, or at least find an OLDER (you heard me) version of EE3 that doesn't have damned near every useful minium stone trasnmutation recipe (seeds, grass block, etc.) nerfed out. Those are my suggestions. Thanks for listening.
mcorrie 8 years ago
Update it yourself. They got all their own modpacks and a website to run. Plus, you would have to rewrite the configs for id conflict. Ender IO is easy to put in. Like, just put it in the mods folder. Differentversions of mods don't work together.
Posted by Pixel Creations 7 years ago
Can SOMEONE PLZ add the hardcore questing mode mod
Pikaboss21 8 years ago
Like..... Yourself?
Posted by Pixel Creations 7 years ago
can someone tell me how to view my screen shots
hoteldog101 8 years ago
%appdata& on windows.. go to .minecraft and look around
Posted by Pixel Creations 7 years ago
lol
Edwardsfamilyholiday 8 years ago
Ive searched for Tekkit but all that comes up is tekkit legends, how do i get tekkit?
NinjaFurySkills 8 years ago
I can´t download the mod logisticpipes from buildcraft, so i can´t update the file and also the modpack could someone help me or the developer ? would be nice
Lasses2001 8 years ago
Pls guys it says l have 1 gb ram and cant play i have 4 gb ram? Can you help?
darkgoblinko 8 years ago
You have to allocate more RAM power to you Java Script. To do so go into control panel>Programs>Java. This will open a new window. From here click on the Java tab and then the View button for "Runtime Versions" . Again a new window will open. Click on the Runtime Parameters box and type in one of the following. (these tell java how much RAM it is allowed to use). -Xmx2048M -Xms2048M [This is required, the numbers are replaced according to ram power] 1GB = 1024 2GB = 2048 3GB = 3072 4GB = 4096 5GB = 5120 6GB = 6144 7GB = 7168 8GB =8192 9GB = 9216 10GB = 10240 *Note: Allocating too much RAM can also slow or crash you game, make sure to leave at least 1Gb extra for Background processes.*
Posted by Arkarin 8 years ago
What ARKARIN didn't mention is that if you have a 32 bit operating system, you cant run it. 32 bit operating systems can only give 1gb of ram. Plus its just Java not Java Script. Also, giving too much ram can lead to worse problems
Posted by Pixel Creations 7 years ago
i cant get on to technic launcher
Dockmartain11 8 years ago
Get your free Steam Gift Card at http://getsteamgifts.com/ I recommend this!
Fuckyoubiatch 8 years ago
you guys should really include a tutorial on how to sreate a friggin server from start to finish for all the things you need to run the server and even start it.
SerpantKiller1998 8 years ago
Its expected that you would have knowledge to start a modded server....
Posted by Pixel Creations 7 years ago
Yes 192.99.222.59 (no port needed)
bruceweed 8 years ago
anyone have a good pve server on this modpack i could play?? preferably with grief prevention????
redEO14 8 years ago
All I ask for is a decrafting table.
TurtleKing9001 8 years ago
Could you add tinkers construct please
MrFinsGayming 8 years ago
plz add a magic mod like rs magica 2 or thaumcraft
stevieschoder 8 years ago
Can´t download Tekkit on Windows
Palsternacka 8 years ago

Latest Update

Lumy Skin Patch has been updated to 1.0.13 so skins should be working again. Existing modpack builds were updated to the fixed version.