Install Tekkit Classic

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Tekkit Classic) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Tekkit Classic from the list on the left. The launcher will handle everything else!

Tekkit Classic Version 3.1.2

created by sct on Minecraft Version 1.2.5 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
help my tekkit not open anymore already tried everything and nothing worked someone says what I can do to fix?
ZeCalin 4 months ago
Hi, I have the problem with creating new world. When I want create new world, game crashes and only 3 mods loaded... :(
JaFee 7 months ago
does someone know how to launch it on Aternos. Im trying but i doesnt allows me, it says connection lost end of stream.
Keirl 7 months ago
Try using the dynamic server IP it worked for me
Posted by XP999 4 months ago
How to make it run in 2019?
Solsolis 8 months ago
Does anyone have the Sphax "Texture pack"?
bubbsMcgee 8 months ago
Posted by Solsolis 8 months ago
how do i actaully start the server i downloaded??
originalstyxx 10 months ago
run launch.bat file, you may want to edit the amount of ram. The file gives the server 3gb on default
Posted by Illumina10 7 months ago
I think there's an error on my modpack. When I open it it jist load 3 mods, the forge mods. When I try to create a world it crashes.
Watered_Pikachu 1 year ago
I'm having some problems with the standard sound of the game, how do I solve this?
EsqueletoMafioso 1 year ago
im trying to log in in my server and this 41 mods loaded Optifine OptiFine_1.2.5_HD_S_C6 Minecraft Forge FML v2.2.106.176 Forge Mod Loader version for Minecraft 1.2.5 mod_CodeChickenCore : Available (modpack.jar) mod_MinecraftForge : Available (modpack.jar) mod_NotEnoughItems : Available (modpack.jar) mod_ReiMinimap : Available ([1.2.5] mod_IC2 : Available (industrialcraft-2-client_1.97.jar) mod_IC2AdvancedMachines : Available ( mod_BuildCraftCore : Available ( mod_BuildCraftBuilders : Available ( mod_BuildCraftEnergy : Available ( mod_BuildCraftFactory : Available ( mod_BuildCraftTransport : Available ( mod_AdditionalPipes : Available ( mod_ComputerCraft : Available (ComputerCraft) mod_RedPowerMachine : Available ( mod_ccSensors : Available ( mod_CCTurtle : Available (ComputerCraft) mod_EE : Available (EE2ClientV1.4.6.5.jar) mod_EnderStorage : Available (EnderStorage-Client mod_IC2NuclearControl : Available ( mod_ImmibisCore : Available (immibis-core_49.1.1_for_1.2.5-client.jar) mod_InvTweaks : Available ( mod_MAtmos_forModLoader : Available ( mod_ModularForceFieldSystem : Available ( mod_IC2_ChargingBench : Available ( mod_CompactSolars : Available ( mod_IronChest : Available ( mod_RedPowerCore : Available ( mod_NetherOres : Available ( mod_PowerConverters : Available ( mod_Railcraft : Available ( mod_RedPowerControl : Available ( mod_RedPowerLighting : Available ( mod_RedPowerLogic : Available ( mod_RedPowerWiring : Available ( mod_RedPowerWorld : Available ( mod_TubeStuff : Available (tubestuff_49.1.2_for_1.2.5-client.jar) Balkon's WeaponMod : Available ( mod_WirelessRedstoneCore : Available (WR-CBE Core-Client mod_WirelessRedstoneAddons : Available (WR-CBE Addons-Client mod_WirelessRedstoneRedPower : Available (WR-CBE RedPower-Client mod_ImmiChunkLoaders : Available (zdimensional-anchor_rev3.2_for_1.2.5-client.jar) Minecraft has crashed! ---------------------- Minecraft has stopped running because it encountered a problem. --- BEGIN ERROR REPORT 5dd86d60 -------- Generated 1/30/19 12:04 PM Minecraft: Minecraft 1.2.5 OS: Windows 10 (amd64) version 10.0 Java: 1.8.0_201, Oracle Corporation VM: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation LWJGL: 2.9.0 OpenGL: Intel(R) HD Graphics 510 version 4.5.0 - Build, Intel java.lang.IllegalArgumentException: URI is not hierarchical at Source) at codechicken.core.CommonUtils.getJarFile( at codechicken.core.CommonUtils.findClasses( at codechicken.nei.NEIConfig.loadConfig( at codechicken.nei.NEIConfig.loadWorld( at mod_NotEnoughItems.reset( at codechicken.nei.NEIPacketHandler.handleSMPCheck( at codechicken.nei.NEIPacketHandler.handlePacket( at codechicken.core.CoreUtils.handlePacket( at codechicken.core.PacketCustom.recieve( at mod_CodeChickenCore.receiveCustomPacket( at BaseMod.onPacket250Packet( at cpw.mods.fml.client.FMLClientHandler.handlePacket250( at adl.a( at ee.a(SourceFile:46) at lg.b( at adl.b( at ajy.a(SourceFile:45) at net.minecraft.client.Minecraft.k( at net.minecraft.client.Minecraft.x( at at Source) --- END ERROR REPORT 388e6687 ----------
Lumine 1 year ago
I am trying to create a private server for my friends and I, but every time I run the launcher.bat, it gives me this [SEVERE] Unable to process our input to locate the minecraft code How can I fix this? I ran it as administrator and it says that it fails to access Tekkit.jar
trjr101 1 year ago
I figured it out, you're supposed to change the launch.bat so it uses Java 8 instead of Java 10/11. You do that by replacing java with "C:\Program Files\Java\(java version)\java.exe"
Posted by trjr101 1 year ago
I'm having issues where I only hear the mods custom sounds and none from the base game, it seems like everyone else too. Is this issue even being looked into?
keanu443 1 year ago
does anyone got trbls , i cant run this modpack
MasterMoriarti 1 year ago
Anyone having any Sound Issues? I can only hear mod pack sounds, i cant hear vanilla sounds.
Tomahawk03 1 year ago
why is this not getting updated? i love this pack. and the way all the mods are in this version. but its unoptimized.
ivar418 1 year ago
I made a multiplayer server, but skins aren't visible to anyone. Not even I can see mine. Does anyone know how to fix it?
MagmaCourtney 1 year ago
This was caused by two separate issues, first, Mojang changed the skin update system in 2015 and 1.2.5 could not longer receive skin updates, and then in February 2018 they discontinued the legacy APIs. You can, however, download a fix for it here: - This fix is installed by adding the files to modpack.jar, client-side only.
Posted by Nosiphus 1 year ago
can you add tinkers construct mod if you add it be awesome
mantas0 1 year ago
This was released 4 or 5 years ago. I don't think they will do that. This is on Minecraft 1.2.5
Posted by TopicHats 1 year ago
waht is it?!?!
Scotty1 1 year ago
whats the ip?!?!?
Scotty1 1 year ago
it seems that after mojang was bought by microsoft they removed legacy files from their server... UGH... the only way to have sound back right now seems to be to get them from other source and add them manually....
markoatonc 1 year ago
Tekkit Classic Is My Favorite Modpack this is why i uninstalled twitch launcher!