Install Tekkit Classic

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Tekkit Classic) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Tekkit Classic from the list on the left. The launcher will handle everything else!

Tekkit Classic Version 3.1.2

created by sct on Minecraft 1.2.5 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
I'm also having a problem with the launcher login, if I put it in correctly it says invalid credentials
Ferrarimonster 7 hours ago
it says to use mojang account to open the launcher but you can no longer use mojang for minecraft, you can only use microsoft.
jouzil2000 1 month ago
whenever I go into water it does a funny screen thing and it is no bueno
BigGuy 1 month ago
The Lumy Skin Patch, which was added to other legacy Technic packs, has been released for 1.2.5 in the time since those packs received it. Would it be possible for it to be added to Tekkit Classic as well?
windowsxprules1 1 month ago
it says to use mojang account to open the launcher but you can no longer use mojang for minecraft, you can only use microsoft.
cololiam9 1 month ago
why cant i download the server download? the button does nothing.
Pato01 3 months ago
I was having the issue but opening in new tab fixed it, by that I mean something actually downloaded
Posted by MechanicGopher 3 months ago
as in middle click the download button?
Posted by Pato01 2 months ago
help
Posted by Pato01 2 months ago
right click the link and select open in new tab worked for me
Posted by savjack 1 month ago
i have an issue when i open technic pack and want to instal tekkit classic i put the url and nothing happens its saying that wrong url link
LeechBlade 7 months ago
Do world anchors work between dimensions? They dont seem to be in my world
Sam_Leo- 9 months ago
What Java version should I install to play? The current Java I have installed for 64 bit (13.0.2) is stated to have issues with Minecraft, and runs into an error before getting to the main menu if I use it. I otherwise have to use 32-bit Java w/ 1GB of RAM, which I would prefer not to do.
Mental1ty 10 months ago
help my tekkit not open anymore already tried everything and nothing worked someone says what I can do to fix?
ZeCalin 1 year ago
Hi, I have the problem with creating new world. When I want create new world, game crashes and only 3 mods loaded... :(
JaFee 1 year ago
does someone know how to launch it on Aternos. Im trying but i doesnt allows me, it says connection lost end of stream.
Keirl 1 year ago
Try using the dynamic server IP it worked for me
Posted by TimothMan 1 year ago
How to make it run in 2019?
Solsolis 1 year ago
Does anyone have the Sphax "Texture pack"?
bubbsMcgee 1 year ago
https://bdcraft.net
Posted by Solsolis 1 year ago
how do i actaully start the server i downloaded??
originalstyxx 1 year ago
run launch.bat file, you may want to edit the amount of ram. The file gives the server 3gb on default
Posted by Illumina10 1 year ago
I think there's an error on my modpack. When I open it it jist load 3 mods, the forge mods. When I try to create a world it crashes.
Watered_Pikachu 1 year ago
I'm having some problems with the standard sound of the game, how do I solve this?
EsqueletoMafioso 2 years ago
im trying to log in in my server and this 41 mods loaded Optifine OptiFine_1.2.5_HD_S_C6 Minecraft Forge 3.3.8.164 FML v2.2.106.176 Forge Mod Loader version 2.2.106.176 for Minecraft 1.2.5 mod_CodeChickenCore : Available (modpack.jar) mod_MinecraftForge : Available (modpack.jar) mod_NotEnoughItems : Available (modpack.jar) mod_ReiMinimap : Available ([1.2.5]ReiMinimap_v3.2_04.zip) mod_IC2 : Available (industrialcraft-2-client_1.97.jar) mod_IC2AdvancedMachines : Available (AdvancedMachines_4.0_client.zip) mod_BuildCraftCore : Available (buildcraft-client-A-core-2.2.14.zip) mod_BuildCraftBuilders : Available (buildcraft-client-B-builders-2.2.14.zip) mod_BuildCraftEnergy : Available (buildcraft-client-B-energy-2.2.14.zip) mod_BuildCraftFactory : Available (buildcraft-client-B-factory-2.2.14.zip) mod_BuildCraftTransport : Available (buildcraft-client-B-transport-2.2.14.zip) mod_AdditionalPipes : Available (buildcraft-client-DA-additionalpipes-2.1.3.zip) mod_ComputerCraft : Available (ComputerCraft) mod_RedPowerMachine : Available (RedPowerMachine-2.0pr5b2.zip) mod_ccSensors : Available (ccSensors-client-MC125-B017pr1.zip) mod_CCTurtle : Available (ComputerCraft) mod_EE : Available (EE2ClientV1.4.6.5.jar) mod_EnderStorage : Available (EnderStorage-Client 1.1.3.zip) mod_IC2NuclearControl : Available (IC2NuclearControl_client_v1.1.10b.zip) mod_ImmibisCore : Available (immibis-core_49.1.1_for_1.2.5-client.jar) mod_InvTweaks : Available (InvTweaks-1.41b-1.2.4.zip) mod_MAtmos_forModLoader : Available (MAtmos_packaged.zip) mod_ModularForceFieldSystem : Available (mffs_rev7_for_1.2.5-client.zip) mod_IC2_ChargingBench : Available (mod_chargingbench-client-1.95b-1.2.5-r1.zip) mod_CompactSolars : Available (mod_compactsolars-client-2.3.2.10.zip) mod_IronChest : Available (mod_ironchests-client-3.8.0.40.zip) mod_RedPowerCore : Available (RedPowerCore-2.0pr5b2.zip) mod_NetherOres : Available (NetherOres_Client_1.2.1.zip) mod_PowerConverters : Available (PowerConverters_Client_1.3.4.zip) mod_Railcraft : Available (Railcraft_Client_5.3.3.zip) mod_RedPowerControl : Available (RedPowerControl-2.0pr5b2.zip) mod_RedPowerLighting : Available (RedPowerLighting-2.0pr5b2.zip) mod_RedPowerLogic : Available (RedPowerLogic-2.0pr5b2.zip) mod_RedPowerWiring : Available (RedPowerWiring-2.0pr5b2.zip) mod_RedPowerWorld : Available (RedPowerWorld-2.0pr5b2.zip) mod_TubeStuff : Available (tubestuff_49.1.2_for_1.2.5-client.jar) Balkon's WeaponMod : Available (WeaponMod.zip) mod_WirelessRedstoneCore : Available (WR-CBE Core-Client 1.2.2.3.zip) mod_WirelessRedstoneAddons : Available (WR-CBE Addons-Client 1.2.2.3.zip) mod_WirelessRedstoneRedPower : Available (WR-CBE RedPower-Client 1.2.2.1.zip) mod_ImmiChunkLoaders : Available (zdimensional-anchor_rev3.2_for_1.2.5-client.jar) Minecraft has crashed! ---------------------- Minecraft has stopped running because it encountered a problem. --- BEGIN ERROR REPORT 5dd86d60 -------- Generated 1/30/19 12:04 PM Minecraft: Minecraft 1.2.5 OS: Windows 10 (amd64) version 10.0 Java: 1.8.0_201, Oracle Corporation VM: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation LWJGL: 2.9.0 OpenGL: Intel(R) HD Graphics 510 version 4.5.0 - Build 25.20.100.6323, Intel java.lang.IllegalArgumentException: URI is not hierarchical at java.io.File.(Unknown Source) at codechicken.core.CommonUtils.getJarFile(CommonUtils.java:147) at codechicken.core.CommonUtils.findClasses(CommonUtils.java:133) at codechicken.nei.NEIConfig.loadConfig(NEIConfig.java:632) at codechicken.nei.NEIConfig.loadWorld(NEIConfig.java:291) at mod_NotEnoughItems.reset(mod_NotEnoughItems.java:46) at codechicken.nei.NEIPacketHandler.handleSMPCheck(NEIPacketHandler.java:98) at codechicken.nei.NEIPacketHandler.handlePacket(NEIPacketHandler.java:23) at codechicken.core.CoreUtils.handlePacket(CoreUtils.java:91) at codechicken.core.PacketCustom.recieve(PacketCustom.java:440) at mod_CodeChickenCore.receiveCustomPacket(mod_CodeChickenCore.java:45) at BaseMod.onPacket250Packet(BaseMod.java:135) at cpw.mods.fml.client.FMLClientHandler.handlePacket250(FMLClientHandler.java:541) at adl.a(NetClientHandler.java:1169) at ee.a(SourceFile:46) at lg.b(NetworkManager.java:343) at adl.b(NetClientHandler.java:71) at ajy.a(SourceFile:45) at net.minecraft.client.Minecraft.k(Minecraft.java:1576) at net.minecraft.client.Minecraft.x(Minecraft.java:825) at net.minecraft.client.Minecraft.run(Minecraft.java:753) at java.lang.Thread.run(Unknown Source) --- END ERROR REPORT 388e6687 ----------
Lumine 2 years ago
I am trying to create a private server for my friends and I, but every time I run the launcher.bat, it gives me this [SEVERE] Unable to process our input to locate the minecraft code How can I fix this? I ran it as administrator and it says that it fails to access Tekkit.jar
trjr101 2 years ago
I figured it out, you're supposed to change the launch.bat so it uses Java 8 instead of Java 10/11. You do that by replacing java with "C:\Program Files\Java\(java version)\java.exe"
Posted by trjr101 2 years ago
I'm having issues where I only hear the mods custom sounds and none from the base game, it seems like everyone else too. Is this issue even being looked into?
keanu443 2 years ago