Install Tekkit Classic

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Tekkit Classic) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Tekkit Classic from the list on the left. The launcher will handle everything else!

Tekkit Classic Version 3.1.2

created by sct on Minecraft 1.2.5 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
im trying to log in in my server and this 41 mods loaded Optifine OptiFine_1.2.5_HD_S_C6 Minecraft Forge FML v2.2.106.176 Forge Mod Loader version for Minecraft 1.2.5 mod_CodeChickenCore : Available (modpack.jar) mod_MinecraftForge : Available (modpack.jar) mod_NotEnoughItems : Available (modpack.jar) mod_ReiMinimap : Available ([1.2.5] mod_IC2 : Available (industrialcraft-2-client_1.97.jar) mod_IC2AdvancedMachines : Available ( mod_BuildCraftCore : Available ( mod_BuildCraftBuilders : Available ( mod_BuildCraftEnergy : Available ( mod_BuildCraftFactory : Available ( mod_BuildCraftTransport : Available ( mod_AdditionalPipes : Available ( mod_ComputerCraft : Available (ComputerCraft) mod_RedPowerMachine : Available ( mod_ccSensors : Available ( mod_CCTurtle : Available (ComputerCraft) mod_EE : Available (EE2ClientV1.4.6.5.jar) mod_EnderStorage : Available (EnderStorage-Client mod_IC2NuclearControl : Available ( mod_ImmibisCore : Available (immibis-core_49.1.1_for_1.2.5-client.jar) mod_InvTweaks : Available ( mod_MAtmos_forModLoader : Available ( mod_ModularForceFieldSystem : Available ( mod_IC2_ChargingBench : Available ( mod_CompactSolars : Available ( mod_IronChest : Available ( mod_RedPowerCore : Available ( mod_NetherOres : Available ( mod_PowerConverters : Available ( mod_Railcraft : Available ( mod_RedPowerControl : Available ( mod_RedPowerLighting : Available ( mod_RedPowerLogic : Available ( mod_RedPowerWiring : Available ( mod_RedPowerWorld : Available ( mod_TubeStuff : Available (tubestuff_49.1.2_for_1.2.5-client.jar) Balkon's WeaponMod : Available ( mod_WirelessRedstoneCore : Available (WR-CBE Core-Client mod_WirelessRedstoneAddons : Available (WR-CBE Addons-Client mod_WirelessRedstoneRedPower : Available (WR-CBE RedPower-Client mod_ImmiChunkLoaders : Available (zdimensional-anchor_rev3.2_for_1.2.5-client.jar) Minecraft has crashed! ---------------------- Minecraft has stopped running because it encountered a problem. --- BEGIN ERROR REPORT 5dd86d60 -------- Generated 1/30/19 12:04 PM Minecraft: Minecraft 1.2.5 OS: Windows 10 (amd64) version 10.0 Java: 1.8.0_201, Oracle Corporation VM: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation LWJGL: 2.9.0 OpenGL: Intel(R) HD Graphics 510 version 4.5.0 - Build, Intel java.lang.IllegalArgumentException: URI is not hierarchical at Source) at codechicken.core.CommonUtils.getJarFile( at codechicken.core.CommonUtils.findClasses( at codechicken.nei.NEIConfig.loadConfig( at codechicken.nei.NEIConfig.loadWorld( at mod_NotEnoughItems.reset( at codechicken.nei.NEIPacketHandler.handleSMPCheck( at codechicken.nei.NEIPacketHandler.handlePacket( at codechicken.core.CoreUtils.handlePacket( at codechicken.core.PacketCustom.recieve( at mod_CodeChickenCore.receiveCustomPacket( at BaseMod.onPacket250Packet( at cpw.mods.fml.client.FMLClientHandler.handlePacket250( at adl.a( at ee.a(SourceFile:46) at lg.b( at adl.b( at ajy.a(SourceFile:45) at net.minecraft.client.Minecraft.k( at net.minecraft.client.Minecraft.x( at at Source) --- END ERROR REPORT 388e6687 ----------
Lumine 3 years ago
I am trying to create a private server for my friends and I, but every time I run the launcher.bat, it gives me this [SEVERE] Unable to process our input to locate the minecraft code How can I fix this? I ran it as administrator and it says that it fails to access Tekkit.jar
trjr101 3 years ago
I figured it out, you're supposed to change the launch.bat so it uses Java 8 instead of Java 10/11. You do that by replacing java with "C:\Program Files\Java\(java version)\java.exe"
Posted by trjr101 3 years ago
I'm having issues where I only hear the mods custom sounds and none from the base game, it seems like everyone else too. Is this issue even being looked into?
keanu443 3 years ago
does anyone got trbls , i cant run this modpack
MasterMoriarti 3 years ago
Anyone having any Sound Issues? I can only hear mod pack sounds, i cant hear vanilla sounds.
Tomahawk03 4 years ago
why is this not getting updated? i love this pack. and the way all the mods are in this version. but its unoptimized.
ivar418 4 years ago
I made a multiplayer server, but skins aren't visible to anyone. Not even I can see mine. Does anyone know how to fix it?
MagmaCourtney 4 years ago
This was caused by two separate issues, first, Mojang changed the skin update system in 2015 and 1.2.5 could not longer receive skin updates, and then in February 2018 they discontinued the legacy APIs. You can, however, download a fix for it here: - This fix is installed by adding the files to modpack.jar, client-side only.
Posted by Nosiphus 4 years ago
can you add tinkers construct mod if you add it be awesome
mantas0 4 years ago
This was released 4 or 5 years ago. I don't think they will do that. This is on Minecraft 1.2.5
Posted by TopicHats 4 years ago
waht is it?!?!
Scotty1 4 years ago
whats the ip?!?!?
Scotty1 4 years ago
it seems that after mojang was bought by microsoft they removed legacy files from their server... UGH... the only way to have sound back right now seems to be to get them from other source and add them manually....
markoatonc 4 years ago
Tekkit Classic Is My Favorite Modpack this is why i uninstalled twitch launcher!
I have 2 problems: 1. Whenever I right click to place a block it keeps placing more than 1. 2. My achievements keep resetting every now and then when I enter my world. Anyone know any fixes to these problems?
Darkshadow2570 4 years ago
Posted by ISUCKSATMYLIFE 4 years ago
1. I'm pretty sure that's your mouse, mine double-clicks a lot. 2. I'm not sure. . .
Posted by MegaLucarioEXZ 4 years ago
Why I can't install SPC and World Edit in this? and I can't chat also.
DraconicEvolution 4 years ago
DraconicEvolution you need to be in a server if you using 1.2.5 to chat.
Posted by ISUCKSATMYLIFE 4 years ago
DraconicEvolution download server to get plugins to minecraft + go to the folder where did you put your server location
Posted by ISUCKSATMYLIFE 4 years ago
I know this is probably the wrong place to ask but how do I fix my technic launcher... I have changed the password so many times and it just wont work. please help me if you can!! thank you!
KiariaMuffins 4 years ago
i did sadly I had to buy another account i don't know if you can migrate to a new account i'm not so shure
Posted by lifftedcookie37 4 years ago
Ummm, so I have no sound in my Tekkit Classic game. I recently installed the modpack again and I am already having issues. What should I do to fix it? I think I need the original resource file but I dont know.
Nivid 4 years ago
I can confirm this as well. Funny enough, some sounds actually work. For example, I was in a cave and water was nearby. I could hear some custom sound of water droplets, but that was it. Block breaks, creepers, item pickups, etc. have no sound at all.
Posted by MAX490907 4 years ago
i can't even play it i have mincrft installed in the version 1.12.2 and i stillcant play it in the technc platform HELP ME
Sorentheman123 4 years ago
when i try to join a tekkit classic server it says and wont let me join, what do i do?
Jake0705 5 years ago
it might have rejected you, maybe its a whitelist server
Posted by Shadowy 5 years ago
It's most likely offline.
Posted by COLDYY1 4 years ago
yo so. i think i must be doing something wrong or somethings wrong with my launcher i wanna play tekkit classic, so i copy the url. go to add more mod packs and paste, but it always say invalid url. what the heck. Also the only thing launcher will launch is basic minecraft. Any answers?
mattmann111 5 years ago
You used this url? Make sure you're copying the url from the "Install this Modpack" button, not your browser.
Posted by MAX490907 4 years ago
I'm using Multicraft to run a server, but I just get this: "[Server] SEVERE Unable to process our input to locate the minecraft code" (Then a bunch of other stuff) Here's the full log : Anything I'm not doing right? Is it just because it's a linux? For now I'm going to run it without Multicraft, but I would like some help as soon as anyone reads this.
YellowLemon571 5 years ago
i to run a multicraft server the fix is to delete all the files in your server folder then start the server and it will remake all files and fix the problem
Posted by deadpyrofilmsfx 4 years ago
download tekkit classic server from this website.
Posted by ISUCKSATMYLIFE 4 years ago