Install Dangerous Depths

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Dangerous Depths) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Dangerous Depths from the list on the left. The launcher will handle everything else!

Dangerous Depths Version 2.2.1

created by Grim_Ascensions on Minecraft 1.7.10
You must be logged in to comment. Click here to register a new account or log in.
For those unaware, I rebuilt a more stable version of Dangerous Depths using MC 1.10. The link can be found here: https://www.technicpack.net/modpack/dangerous-depths-2.966203
Grim_Ascensions 6 years ago
Enviromine is awesome. I love finding sand dunes in deserts and placing a single block on top of them. The results are. . . catastrophic. xD
zwarren03 8 years ago
I Was Excited About This, And I Loaded It. But Then Right When It Loaded The Modpack Crashed, I have A Mac Computer.
UsernameIsTaken4 8 years ago
Modpack doens't seem to start... All other modpacks from the Technicpack start up just fine
Darunia 8 years ago
I checked both the filehost and ran the modpack without issues. There is 30 second hangup when the pack first loads the main menu that I can't correct. It may be that the pack is to heavy for your PC (see minimal suggested hardware); or your download of it corrupted during transfer or installation. Try deleting the pack and reinstalling. I can't offer any other solution as I can't duplicate the issue.
Posted by Grim_Ascensions 8 years ago | Modpack Creator
Technic launcher is telling me that there was a dropbox issue.....i would really like to continue to play this mod pack.
MommaGreenPants 9 years ago
I've tested the link and package, and its downloading fine. I'm guessing Dropbox did a 24-hr temporary suspension on it due to high bandwidth usage. Must have been a busy day.
Posted by Grim_Ascensions 8 years ago | Modpack Creator
Temporary? i just installed this and I have the same issue!
Posted by Nexfiles 7 years ago
Technic Launcher says i got the first download... :D please say its true.
epiclink3 9 years ago
But the website says 1k
Posted by epiclink3 9 years ago
The launcher has been screwy with the numbers for quite awhile now.
Posted by Grim_Ascensions 9 years ago | Modpack Creator
Might I suggest the Sync mod? http://ichun.us/mods/sync/
Mophise 9 years ago
Sorry for the delayed reply. I can probably make this happen. I know Sync used to have issues with HQM in their early 1.6.4 versions. I'll look around to make sure they're compatible. But if the problems are fixed I don't see a reason not to toss it in.
Posted by Grim_Ascensions 9 years ago | Modpack Creator
Sync added in update 2.2.0.
Posted by Grim_Ascensions 9 years ago | Modpack Creator

Latest Update

Dangerous Depths 1 & 2 are officially unsupported. No new updates will be coming. In the near future I will be releasing a new modpack called "Dark Domains" that features a theme very similar to Dangerous Depths.