Install Warhammer 40k: Blood & Iron

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Warhammer 40k: Blood & Iron) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Warhammer 40k: Blood & Iron from the list on the left. The launcher will handle everything else!

Warhammer 40k: Blood & Iron Version 2.42

created by mensrea on Minecraft Version 1.7.10
You must be logged in to comment. Click here to register a new account or log in.
Is this modpack dead?
Moon_Dew 4 months ago
Most likely. There's some pretty bad bugs involving BQ and crafttweaker that probably won't get fixed.
Posted by mensrea 3 months ago | Modpack Creator
just a heads up, but this seems to be a thing https://minecraft.curseforge.com/projects/better-questing/files/2694062
assasinwar9 5 months ago
I messed with it yesterday and while it looks promising it still has some issues (NPC mod faction data can't be read/written to). I reported the errors to the modpack maker but I highly doubt he will fix them given how far behind we are, version wise. It would be possible to find workarounds but scoreboard values are a mess in 1.7.10 and tend to get deleted a good deal. In the meantime I'll probably pick up the 1.12 Fallout pack I made if there's enough interest.
Posted by mensrea 5 months ago | Modpack Creator
I'm getting $20 credits spammed into my inventory, usually 3-15 at a time
s4lt 1 year ago
Nevermind, restarting my game appeared to work.
Posted by s4lt 1 year ago
...until it happens again. I mean, yay, free money, but, like, I need that inventory space! :P
Posted by BeccaKirby 1 year ago
Sadly this is an issue with Better Questing in 1.7.10. The mod is pretty much broken for that version and the only way I got it to work at all was to pay a programmer to try and fix it. He wasn't able to and no longer wants to work on it so I have to abandon the pack. I tried updating the map to 1.12 but it didn't work, so until I can find a way to do that I'm putting this project on hold.
Posted by mensrea 1 year ago | Modpack Creator
At the moment, I can't seem to be able to craft the mining laser, and cannot find the crafting recipe for it. I saw it in the NEI interface at one point. I looked up the recipe and tried to craft it, and yet it doesn't craft. I had to 'bq_admin' the quest 'Infiniminer' to keep going...anyone else having this trouble?
KatjaREDMedic 1 year ago
For the quest "The Hammer Falls" in Noblesse Oblige, one of the quests within the quest is to attempt to defuse the situation by negotiating with Nero. Being me, I don't negotiate with terrorists and did the red option of putting the gun to his head and telling him I had no time for this, instantly causing me to have to battle him. After killing him and his bodyguard, I went and defused the bomb but got no notification saying I completed the quest. I looked in my questbook to see that I had done everything within the quest except talking to Nero to defuse the situation. It still says incomplete. I attempted to wait for him to respawn, and when he did, he tried to kill me again. First, I tried killing myself. He was still aggressive and wouldn't talk to me after I got back. I tried logging off then back on. Still a no go. I tried shutting off Minecraft completely then coming back. Still nothing. I've tried going into creative to talk to him. No go. What do I do to complete the quest? ...Or am I screwed and have to start all over...? .-.
BeccaKirby 1 year ago
Is there any way to cure radiation poisoning?
kirawroth 1 year ago
as i level i am gaining negitive skill points... im level 6 right now and i have -449 skill points https://snag.gy/4EvFNq.jpg i currently have 10 intelegence, and the talented trait. also, love the new intro area
youngjames1 1 year ago
I can't find the beginning game quests. I just started a new world with the recent updates, the cogitator appears to be completely empty. I'm not sure how to bring up the starting quests. The quests in my inventory bar mention looking at several things but I'm not sure where it wants me to find them. I assumed the starting room but I couldn't find anything there.
KatjaREDMedic 1 year ago
It's a pretty common thing. Start on the character sheet and zoom out and look around. If you still can't find it set your GUI settings to small. Make sure you're not using it in a minimized window.
Posted by mensrea 1 year ago | Modpack Creator
could you update the server download? wanted to host this for some of my friends...
assasinwar9 1 year ago
Servers with 2+ people are really, really laggy right now. In fact they're nearly unplayable for many unless you just don't use the questbook. I'll release a server pack this weekend but I doubt you'll be happy with it. The fix is coming but it's going to take a long time due to having to have programmers actually make changes to the mods. Alternatively, I've been working on a server-friendly questbook with a scaled down character sheet. If I can get that working I'll post that alongside the server download.
Posted by mensrea 1 year ago | Modpack Creator
Anyone else having trouble with the Chaos Rising quest The Big Boss? I can't discover the location or hand in the heart. Despite this, it says the quest is complete but I can't complete the next quest.
TikiTikie 1 year ago
Can you send a screenshot of this? As far as I knew it's impossible to complete a quest unless you complete all the tasks, but knowing BQ I wouldn't be at all surprised if it's a new bug.
Posted by mensrea 1 year ago | Modpack Creator
How do I send the screenshots? There doesn't seem to be an option to attach them to the comments.
Posted by TikiTikie 1 year ago
Try using imgur to upload them and then send me the link. Sorry about the bother but it will help me out a lot.
Posted by mensrea 1 year ago | Modpack Creator
Actually, that's a really good idea that I never thought of. https://imgur.com/a/5bBue https://imgur.com/a/UnD8Z
Posted by TikiTikie 1 year ago
The location is automatic but you have to hit the submit button for it to take the heart.
Posted by mensrea 1 year ago | Modpack Creator
I do stand in the location, but it always says I'm 1m away. And since I can't trigger the location, I don't get the option to submit the heart.
Posted by TikiTikie 1 year ago
Try letting yourself sink into the pit. It did work during testing but a lot of times location quests can be tricky. If that doesn't work try making a new game, I improved the beginning part of the chaos line.
Posted by mensrea 1 year ago | Modpack Creator
Given the launcher now crashes whenever I try to play, I think the problem's on my end. Thanks for all the help, sorry for bugging you.
Posted by TikiTikie 1 year ago
Actually I left a legacy version of BQ in, that may be why it crashed. Can you send me a crash log? Bug reports are never a waste of time.
Posted by mensrea 1 year ago | Modpack Creator
Looks like what you did in the latest update stabilized the modpack. Thank goodness, this is my favourite modpack by far. I can still send you the crash report if you'd like.
Posted by TikiTikie 1 year ago
Just wanted to say that all the bugs reported here so far have been addressed. I wanted to thank everyone for their bug reports, they help make the pack better.
mensrea 1 year ago
LEMON ROSS TENKS
DarkWolfInsanity 1 year ago
MENNSSSSSSSSSSSSSSSSS
Bdaurs 1 year ago
KEYBISS
Posted by mensrea 1 year ago | Modpack Creator
Apparently there is a huge bug with the repeatable ability quests. While I can get let's say 12 mining and claim Mining I's ability reward once, as soon as I do that I can not only never repeat this, I also can no longer claim for example Farming I's ability reward. This essentially breaks the mod currently. This however can't be a general ability reward issue as the Heavy Weapons I ability reward for example works perfectly fine and is repeatable as much as I want to.
Harleyquincey 2 years ago
Forget the last part about Heavy Weapons, that, too doesn't seem to work, must've been misremembering and just went to test it. Nope, also not repeatable.
Posted by Harleyquincey 2 years ago
The server pack link seems to lead to a 404, is this fixable?
tomskeet18 2 years ago
'Shadows' in the Imperial outpost tells me to go talk to the Commander, but I can't seem to find him. I assume he's in that vault security building, but the code is one I don't have and the NPCs just tell me to go talk to Shadows again. I must have to do something first, right? Or am I just totally mistaken-
KatjaREDMedic 2 years ago
The commander is Francisco. The current version is kind of bad because there's no interface between HQM and the NPC's. A new version will be coming out very soon that fixes lots of these issues.
Posted by mensrea 2 years ago | Modpack Creator
Ohh, ok. That's no problem. I was sort of convinced I'd broken something. That's a relief...now let's find this guy, I am so bad at NPC names...
Posted by KatjaREDMedic 2 years ago
there is no way to produce the lead storage block for the quest "Staying Alive" in the tab, forbidden planet. the recipe currently makes a lead block.
youngjames1 2 years ago
Yeah, sorry about that, been meaning to push an update out to fix it but then I got sidetracked and now I'm remaking all the quests in better questing. I'm making very good progress and I hope to release it Soon. It will be an improvement over what there is now in every way.
Posted by mensrea 2 years ago | Modpack Creator
also i cant use alot of repeatable functions within the quest book like abilities, for example all but 2 of the energy weapons skills have no redeem function.
Posted by youngjames1 2 years ago
Do you meet the requirements for them?
Posted by mensrea 2 years ago | Modpack Creator
yes, I am certain that lv 100 skill in laser weapons meets their requirements. snarky comments aside it apears that just the repeatable buttions that change how the page in the book looks just dont apear, ill link some screenshots in another comment
Posted by youngjames1 2 years ago
I think I know what you mean. It wasn't always like that, but it might have happened with the most recent update of HQM. I'm in the process of overhauling everything at the moment, and skills will be fixed as such.
Posted by mensrea 2 years ago | Modpack Creator
So, unless this pack is dead and abandoned, there is a bit of a bug I'd like to report. The commissar's uniform is beyond broken. Despite the description claiming it doesn't protect, it is unbreakable and absorbs all damage. Wearing it essentially makes you immortal. Falling into the void doesn't even help. Might wanna look into this :)
ilikebiskits 2 years ago
That's not good. I'm actually still working on finishing up the story, albeit slowly. I'll probably have to release a patch to take care of this and some other issues.
Posted by mensrea 2 years ago | Modpack Creator
Yeah, cuz even though I love commissars I have to actively challenge myself to not use it. Feels kinda awful in a way. But whatever, so long as it's getting fixed :)
Posted by ilikebiskits 2 years ago
actualy it would be nice if non-space marine armor could still let 1 heart to 1/2 heart of damage through so short term combat with not end game gear is more realistic. for example, sitting there taking 200+ hits from a pinkie with fresh guardsman armor and not dieing until the armor breaks
Posted by youngjames1 2 years ago
it would also make constitution as a stat more valuable
Posted by youngjames1 2 years ago
Armor will probably be re-balanced in general with the next update. I like the idea of putting more emphasis on Con and +life stuff like stimpacks.
Posted by mensrea 2 years ago | Modpack Creator
Hey,Men, I rlly wanna know what will happen if i kill Burke after going through da "peacfull" dialogue with her and getting 2000 faction points and completing quests with Mikhail?What will it cost me? I will not becable to interract peacfully with Lost and Damned? Will i then complete the quest "Heart of Darkness? And about components to spacebridges: i was talking about singularity and rings. Where can i get em? Thx
zedman 2 years ago
You complete heart of darkness as soon as you approach Burke. Killing her changes nothing, after completing the quest Lost & Damned are permanently hostile toward you. The singularity is an item you get from the matter condensor, wiki is here http://ae-mod.info/Singularity/ The ring doesn't actually have to be built, you just need to turn in the parts. You can check the recipes for them in game.
Posted by mensrea 2 years ago | Modpack Creator
But the second part of it(quest) makes me to loose points with lost and damned...what should i do?
Posted by zedman 2 years ago
If you want to continue doing the Imperial questline you have to loose those points. Just keep going forward.
Posted by mensrea 2 years ago | Modpack Creator
Hello, It's me again. I saw that another person had the same problem, but wasn't sure if that was fixed within the most recent update or not. I have the problem in which the faction screen doesn't show anything, a flash and then blank. I also have a screenshot if you want. https://snag.gy/su8h5q.jpg .
EternalLifeMe 2 years ago
I'm pretty sure that's from me using way more factions than the author intended to have used. I don't think there's a fix for it, and I may have to wait to port to 1.10+ before it's addressed.
Posted by mensrea 2 years ago | Modpack Creator

Latest Update

The development of this pack is being suspended. It's too buggy to play in multiplayer and single player has issues with players losing their quest progress/broken quests. These are Better Questing issues that will not be addressed.