Install NeverMine: Advent of Ascension

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (NeverMine: Advent of Ascension) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select NeverMine: Advent of Ascension from the list on the left. The launcher will handle everything else!

NeverMine: Advent of Ascension Version 1.2.2

created by SkullHunter on Minecraft 1.7.10
This modpack is hidden and will not show up in the modpack index.
You must be logged in to comment. Click here to register a new account or log in.
Can't install ModPack ( does not exist) - Please fix
Sprax2013 8 years ago
Just saw the Comment wit hthe Link to the new ModPack - You should remove the ModPack or Mark that there is a new one!
Posted by Sprax2013 8 years ago
I cnat instalallaal
Silverdealer 8 years ago
I cant install this modpack too
Davencr 8 years ago
that modpack cant be installed
Gnikel_HD 8 years ago
that modpack cant be installed
Gnikel_HD 8 years ago
Code_Gear 8 years ago
Code_Gear 8 years ago
I have to say, when i tried the Eternal Dimensions mod, my fav. thing about it was Advent of Ascension. If this mudpack works form my computer, I can guarantee a like for your modpack
Code_Gear 8 years ago
SERVERS If you guys have any servers made I'd love to join one! I don't have good enough of hardware to run one myself. Please reply if you have one.
Andrew0223 9 years ago
People pls stop asking me useless questions first of all there is a information bar on the about page and second if you dont know it there is a help page and if its not there THEN you can ask it in here!
SkullHunter 9 years ago
Okay, so this modpack is awesome, and I played it last night. Once it updated to 1.2, I can't break blocks and now It says the download cannot be found? Anyone one else had the not being able to break blocks problem (No I am not in adventure mode)
KatieKate 9 years ago
Make an new world i tried to make the modpack update compatible with the older update but its not working than you'll need to make an new world then it will work agian because i started a new world to yesterday o and if it cant download just look at the help page ;)
Posted by SkullHunter 9 years ago | Modpack Creator
Does anybody know what the bars (HUD) in the top right corner mean? I've looked at every tutorial/spotlight video, the wiki, and every other website that mentions the Eternal Isles/Nevermine and have seen nothing about the HUD additions.
ChillyTiger9807 9 years ago
check the wiki -_-
Posted by SkullHunter 9 years ago | Modpack Creator
Hey, Any solution to the modpack not downloading? tried within 2 days :L doesn't seem to wanna work. quite sad, i've been so eager to check this out. Looks extremely exciting!
zhenya4090 9 years ago
And when i go to The download isnt working. says the page doesn't exist.
Posted by zhenya4090 9 years ago
I dont know keep checking every day because it wasnt working yesterday and it worked today agian so ye
Posted by SkullHunter 9 years ago | Modpack Creator
Yea it works now. Thank you. Can't wait to try it :)
Posted by zhenya4090 9 years ago
hi I don't know if you are already working on it but when I first load it up the loading bar under mojang pops up and after fully loading closes is this the glich you were talking about a little while ago?
yellowtoad64 9 years ago
Nha thats a problem with your java you need the latest java 7 to make the game work there is a mod called java7checker to make the game work to the max and if that doesnt work i really dont know what i can be els check your log file for that then!
Posted by SkullHunter 9 years ago | Modpack Creator
could you PLZ add custom NPCs? me and my friend wanna make a RPG world but we need custom NPCs
ZodiacRatt 9 years ago
i wont add it because its not good for the pack but you can always add it yourself
Posted by SkullHunter 9 years ago | Modpack Creator
i cant wait for the server!!
djcgicy 9 years ago
Im still waiting for the nevermine mod to update
Posted by SkullHunter 9 years ago | Modpack Creator
this isn't working I have downloaded and redownloaded the modpack and everytime i click play it opens a new java window and then after about 5-10 seconds it just quits. Is this a bug or is this just my computer?
zzLucky13 9 years ago
Your computer that doesnt happen to nobody els then you
Posted by SkullHunter 9 years ago | Modpack Creator
This is a really cool modpack, are you planning on adding more mods. I'm sure this modpack will pick up soon
hikaritokage 9 years ago ao cool.
Posted by Fluctus 9 years ago
My game crash when it is reloding the textures. Can someone help me?
Fluctus 9 years ago
Try reinstalling it>? or got to your .technic and delete the hole folder
Posted by SkullHunter 9 years ago | Modpack Creator
Its something with and Technicpack that i dont know how to fix yet! but this glitch gets fixed in a few dayes so if the pack doesnt download just wait a few days and it will work agian!!!
SkullHunter 9 years ago
Downloads are working but if they dont read above!
Posted by SkullHunter 9 years ago | Modpack Creator

Latest Update

NeverMine: Advent of Ascension was updated to version 1.2.2