Install Dungeon Delvers

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Dungeon Delvers) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Dungeon Delvers from the list on the left. The launcher will handle everything else!

Dungeon Delvers Version 1.3.2b

created by TRMiles on Minecraft 1.7.10
You must be logged in to comment. Click here to register a new account or log in.
is there a server? if so could i get the ip adress?
kururu298 8 years ago
We are trying to get one up, it may be awhile. Thanks for playing the pack!
Posted by TRMiles 8 years ago | Modpack Creator
I was playing on my single player world and now it crashes every time I try to use a crafting table.
cmax33 8 years ago
Tried Crafting Station or Crafting Slab ??
Posted by yanik557 7 years ago
I can't join the server?
DimaondJewels1968 8 years ago
the server is moving to a new host
Posted by reshadow500 8 years ago
for how long haven't been able to join in A long time.
Posted by DimaondJewels1968 8 years ago
New server ip. Its Check discord for updates bro. Ill see u on :) ~Saitama/Kylo
Posted by finntheguy 8 years ago
why is the ip not at the updates?
Posted by reshadow500 8 years ago
is it still the same server Ip? ???
Posted by DimaondJewels1968 8 years ago
Check discord for updates diamondjewels
Posted by finntheguy 8 years ago
For whatever reason, I can't update from 2.1.1 to the latest version. I have 3 gb allocated to the launcher, and am using the latest version of Java. Is there some way to fix this?
Xavendeir 8 years ago
ill try repairing the link
Posted by Noku269 8 years ago
Crashes as soon as i open it
twiskt 8 years ago
do you have the newest java version and set your techniclauncher to more than 1 gb ram?
Posted by reshadow500 8 years ago
When you wear Dragon backpack, all weapons are yousles, exept bows.... Enchanted sword with 29 meele dmg deals 5 dmg or you cant even hit a monster, only swords can deal dmg with fire aspect... so if you need somthing from endermans or other end monsters its just not posibble
Spx 8 years ago
So I've definitely updated Java to the latest version and I've allocated enough space for Minecraft to run and I still occasionally (not always) run in to the CTD when using a Crafting Table. Is anyone else still having this problem?
SerPickle56 8 years ago
Bring back Erbeus! That mod was the best!
ScorpioZero1 8 years ago
The mod was never removed.. =/
Posted by Dragir 8 years ago
how to get whitelisted?
jamesteezyy 8 years ago
How do i use the server download? I downloaded it i just don't know how use it.
Azure_Volt 8 years ago
Just curious, is there a place we could suggest potential mods to be added or is the list final for what's in the pack?
SerPickle56 8 years ago
If you play it on server, this that i am saying is useless. You can just download the mod apart, then open the Technic folder>modpacks>dungeon delvers>mods , and place the mod there
Posted by etrotta 8 years ago
Ah, that's alright. Was mostly just curious of suggestions for future development. If the list is set then that's fine, it is a rather good list and I've certainly enjoyed it.
Posted by SerPickle56 8 years ago
I've been playing on SP but my memory usage continuously rises as I explore and build, I have over 8gb allocated to the pack itself but it will start at around 4% usage and get up to 50% memory usage after about 2 hours of playing, is this normal or is there any way around it? I don't want my world to end up crashing
R3D_T4105 8 years ago
Hey, I died at spawn and I can't right click on my grave it says I need Admins Permission to build here.
yesermen111 8 years ago
Okay, will also fix dying in spawn.
Posted by TRMiles 8 years ago | Modpack Creator
Running into a weird glitch. When I try to use a crafting table, the game freezes for a couple of seconds and then crashes. No error message or anything.
Drake187 8 years ago
Logs would be appreciated.
Posted by TRMiles 8 years ago | Modpack Creator
Actually this glitch has been acknowledged in the past few updates and should be nonexistent if you have the latest version of Java and have allocate more than 1gb of ram.
Posted by TRMiles 8 years ago | Modpack Creator
Im not overly savvy in this area so im going to ask for help. If anyone could tip me off with how to either join the author's server or make my own i would greatly appreciate it, im getting a little tired of SP, thanks.
lovestospudge 8 years ago
It's just on multiplayer... There is an updated guide on how to make a server on the website.
Posted by TRMiles 8 years ago | Modpack Creator
after i download java it has deletet the old java so i wasnt able to set more than 1 ram -.- if you have the same problem check jave and make what Thabae123 sayed
reshadow500 8 years ago
This worked for me and I was able to play just fine after it. (Suggestion made by dragoon)
Thebae123 8 years ago
HEY! Guys go into the install foldr for the mudpack and delete EVERYTHING in there, then reinstall the pack. THEN redownload the pack THEN launch! The mods have said ALL this on discord so check discord every once in a while.
Thebae123 8 years ago
thx for try but i dont worked :/
Posted by reshadow500 8 years ago
Is this a solution to not being able to allocate more ram to the launcher? If so, thats a problem with the launcher not the pack.
Posted by lovestospudge 8 years ago
I have now the newest Java, restar my computer reinstalate the modpack 3 times and after the last start my computer crashed and it deletet all my modpacks but it keep crashing
reshadow500 8 years ago
Do what I suggestes above.
Posted by Thebae123 8 years ago
i just downloaded the modpack, when i go start it the forge loading screen get stuck at "Reloading: LanguageManager" (7/7 112/112 1/17)
etrotta 8 years ago
You need 64 bit java.
Posted by Dragir 8 years ago
>-< and how to get it? i try to download 64-bit but the java site no show it download
Posted by etrotta 8 years ago

Latest Update

Unfortunately, this project was abandoned, but you can check out the new version of Celestial Conquest!