Technic Blog

Solder updated to 0.7.2.0

Solder v0.7.2.0 has just been pushed live!  Here's the changelogs!

New Java settings.

Note: This requires a migration! Guide: Updating Solder

Modpack developers are able to set Java versions and minimum memory on modpack builds. This will allow the launcher to display a message and check users that are not using the minimum set settings.

The Launcher currently does not support this feature but it will be implemented soon.

Note: Changing Java settings on a build thats already been published requires your modpack users to re-install the pack/build.

CSS updates and tweaks

A lot of fixes and QoL changes were pushed this update.

- Side Nav bar now floats as you scroll #143

- Tab Titles are now set for every page (Credit to aschmois#369

- Numerous tiny QoL (Quality of Life) changes

Bug fixes and tweaks

- Fixed major compatibiliy issue with the Solder Client/Technic Platform

- Private or Hidden Modpacks shown if empty string API Key/CID sent. #343

- Missing API Cache resets. #344

- Travis CI tweak #364

 As always, stop by IRC and reddit to tell us what you're playing, and thanks for reading!

Comments

You must be logged in to comment. Click here to register a new account or log in.
GO BACK TO THE OLD LAUNCHER!!!
_DeadMan 5 years ago
the new one is so complicated and doesn't work
Posted by jimary 5 years ago
its stupid what they have done i miss the old one
Posted by DarkAssassin299 5 years ago
same
Posted by 12epicmanminecraft 5 years ago
new launcher best launcher
Posted by Pikachu298 5 years ago
are you crazy PIKACHU298 the new launcher is terrible are you new here because you must not have seen the old one this new one is stupid
Posted by [email protected] 5 years ago
the new launcher isnt complicated at all..it literally has a news tab and a modpacks tab..the end. the settings for ram could never be easier, and it looks good unlike the old launcher
Posted by enterprise12 5 years ago
well ENTERPRISE that doesn't change all the other crap put in like the people who cant even answer one question or their java fix that doesn't work oh and what about the broken help button in the right corner and back on that java thing what about the people who don't ever update their packs it means we will never be able to play them again as well as how most of everything on this website is broken stop being so optimistic about a broken website no matter what they add none of it can be used because THIS WEBSITE IS BROKEN and even if it wasn't there isn't enough left that’s usable
Posted by DarkAssassin299 5 years ago
EITHER PUT A NEW DOWNLOAD OR TAKE DOWN THE "NEW" (Shit) LAUNCHER OR ELSE PEOPLE ARE GOING TO LEAVE I SPEAK FOR THE PUBLIC
_DeadMan 5 years ago
You speak for yourself. Don't try to drag people who have not said anything on your behalf down with you. You are the kind of people who destroy communities for the sake of publicity and it's really annoying. If you can't figure out a brand new, simple launcher or simply can't accept change, then we don't want you here.
Posted by nickcool9999 5 years ago
no he is pretty right on that NICKCOOL9999 i agree with him and he cant destroy a broken community and when you say we then your being a hypocrite because you are speaking for yourself and on that there is no we and if there is then there wont be for long with this place
Posted by DarkAssassin299 5 years ago
I find the new launcher working fine, so no, you don't speak for the public. But, like with everything else, most of those others that feel the way you do will most probably agree with you. I on the other hand haven't had one single problem with the new launcher so I'm all happy giggeligoo :P
Posted by sketaful 5 years ago
why the hell did u go with this stupid new setup? all my downloads that worked before DON'T WORK!!! I need to be able to work with FNAF mods, and because YOU decided ur old modlauncher set up WASN'T GOOD ENOUGH, I can't use it! Why is it that you have to mess with perfection? GO BACK TO THE OLD LAUNCHER!!!
wmax499 5 years ago
i agree the update broke all of my modpacks and no one will help me
Posted by DarkAssassin299 5 years ago
YOUVE MADE IT SO COMPLICATED THAT PEOPLE CANT UPDATE SOLDER SO THEY CAN PLAY THIS WAS A HORRIBLE IDEA
_DeadMan 5 years ago
yeah, we want to play the modpacks we have
Posted by Elofebi 5 years ago
You don't even look like the guy who can actually use solder, it's for advanced users ONLY. You can still make modpacks the old way.
Posted by Misterio7x 5 years ago
i cant even understand what gave them the idea to break every modpack forcing us to put some fix in that does not work as well as complicating the site so much that no one understands and refuse to help all the people who are having problems anyone know a better modpack site like how this one use to be i hate the new one so much I’m not even able to do anything on it
DarkAssassin299 5 years ago
I cant download any modpacks anymore. Change it back to the old launcher!!
stalker83 5 years ago
bring the old launcher back, so that we can play again
Posted by Elofebi 5 years ago
i cant sign in
Posted by 12epicmanminecraft 5 years ago
Not the launcher's problem.
Posted by batfreak12345678 5 years ago
CHANGE IT NOW THE IDEA OF CHANGING THE PERFECT LAUNCHER IS HORRIBLE THE REASON PEOPLE GET THE TECHNIC LAUNCHER IS FOR THE EASE AND SIMPLICITY INSTEAD OF JUST DOWNLOADING IT FROM THE INTERNET SO THIS IS HOW TECHNIC WILL END
_DeadMan 5 years ago
I used to use this all the time and now it is making my technic mods spas out and it deletes it from my computer
Posted by [email protected] 5 years ago
I never knew the old launcher so my modpacks work fine, try uninstalling and reinstalling
Posted by piolit06 5 years ago
JUST ADD A LINK WHERE WE CAN DOWNLOAD THE OLD VERSION OF THE LAUNCHER WITH THE NEW ONE THAT WAY THESE PEOPLE MAY LEAVE YOU ALONE AND ACTUALLY DO STUFF AND MAKE THIER MODPACKS
joshet1223 5 years ago
my modpack is no longer working i put the legacy java fixer in but it did nothing i really need help on fixing the problem
DarkAssassin299 5 years ago
i try sending a message in for help but i have been getting this message for several weeks There was an error processing your request. Please try again later
Posted by DarkAssassin299 5 years ago
it means that THE DEVS THOUGHT IT WAS A GOOD IDEA TO BREAK THE LAUNCHER AND MAKE IT SO PEOPLE DONT KNOW HOW TO UPDATE
Posted by _DeadMan 5 years ago
i really wish the would just quit on this stupid update and go back to the old launcher i would not be complaining if i could just get some help but they wont even do that
Posted by DarkAssassin299 5 years ago
it wont let me log in help me D:
Luckyy7HD 5 years ago
they wont they don't give help
Posted by DarkAssassin299 5 years ago
same it says invalid
Posted by 12epicmanminecraft 5 years ago
OMG I love the changes allowing players to be notified about minimum memory settings for each build of a mod pack! Bravo!
glixyl 5 years ago
great idea perfect because my mod pack needs a min and i have to tell the players.
CoffeeSips_ 5 years ago
Though having to tell your players to reinstall to get these settings, once they go live, isn't such a perfect idea. :/
Posted by sandalle 5 years ago
updating the site isn't such a perfect idea
Posted by DarkAssassin299 5 years ago
shut it mouthy no one else can play it
Posted by 12epicmanminecraft 5 years ago
Agreed
Posted by Hero212Hero 5 years ago
Guys who are spamming caps and that are confused. #1 my modpack works, and its one of the populer ones, and im the only maintainer. yours dont work because you dont know how to make them. spamming caps solves nothing. the new launcher works fine, if anything its that ur javas so outdated nothing works. ur modpacks arent working probably because you didnt assign any RAM. instead of whining, go look at a 5 minute tutorial on these things, or go elsewhere. your not spending a dime here for their hardwork, so please stop.
enterprise12 5 years ago
well good for you but it doesn't work for anyone else and just so you know my modpacks use to work but after the update it stopped i did everything i was supposed to do and it did nothing i tired for 4 months for help but no one would answer and when i tried sending a message through the help button for the last 3 months i have not been able to send it because it says my message could not be sent so you shut up because you have no idea whats going on and everything has been crashing so much im not able to do anything and i cant even add a tag to my modpack either or any kind of update for some reason im not sure why
Posted by DarkAssassin299 5 years ago
I really wish they would unfuck the new launcher/go back to the old one. Nobody likes this version. If they listened to the community they would know that.
coxiesarmy 5 years ago
so are you guys actually complaining about the new solder update or the new launcher (which by the way is different but easyer to use over all ) cause i need to know if the new solder build is good not that you hate the new launcher or the fact that you still don't use solder this comment section is supposed to be about the solder update go complain about the launcher somewhere else
tiarnia 5 years ago
the new launcher is different but not hard to figure out you go to a pack and hit the add button if your launcher is open at the time it will add it and you can then play if you cant use the simple search window atht eh top of the launcher to find a pack then i can't help you if your pack isn't working try actually reading how to set up the new pages it took me like 5 mins to fix my pack and that was before solder now we don't have to worry about that at all solder is only for advanced users but once its up its wonder full now is this version update for SOLDER easy to apply and are there any issues with it ? NOT THE LAUNCHER
Posted by tiarnia 5 years ago
you make it sound like it works i did everything i was suppose to and mine still doesn't work and none of the modpacks it comes with at the beginning work either and i cant get any help on anything the help button in the right corner is broken i have tried to use it for 3 months and no one will answer my questions about all the problems i have when I try to post them elsewhere everything is broken on this site the default modpacks the public modpacks the help button and everything keeps crashing for me now and trying to use this website is terrible because it crashes a lot now and I can barley use it for more than five seconds
Posted by DarkAssassin299 5 years ago
realy i havn't had 1 issue with the site ... that i can think of at all... are you allocating ram before launching a pack ? most need at least 4gigs to launch
Posted by tiarnia 5 years ago
yes i have looked over everything several times but i may have missed a few things and what about the entire site being broken there isn't a single thing working except for this site which rarely works it may be fine for you but it isn't for me im only frustrated with the lack of help because i can't figure it out and neither can i get help there may be problems with my modpacks but what about the launchers modpacks for some reason they crash before they load which is new since the update so it isn’t necessarily my computer since it’s a pretty good computer and i have played them before
Posted by DarkAssassin299 5 years ago
Since they updated Solder from 0.6 to 0.7x it have ruined everything for my modpacks. Not because the new 0.7x version is bad, it's quicker, looks better and have a lot of improvements. But.. It requires Composer and my host doesn't support Composer so I can't use it anymore, sadly. So no matter how much better it gets it really doesn't matter to me since I can't use it well anymore.
Posted by sketaful 5 years ago
FALL BACK ON A VERSION!!! THIS UPDATE REMOVED ALL MY MODPACKS!!! I can't install modpacks either!!!
Meepologist 5 years ago
hi
DanBoy008 5 years ago
in cant find tekkit lite in the technicpack
regulinecolt009 5 years ago
Wondering if there's talks of an "update all" option. The launcher could then verify if there's updates like it normally does and download the appropriate updates for all packs at once. Just curious.
Gryph0nnn 5 years ago
Another nice thing would be notifications on this site when someone comments/replys to something we post. That would definitely help with mod management as well for creators. Just an idea.
Gryph0nnn 5 years ago
this shit don't work
fantasmo619 5 years ago
Yep
Posted by Hero212Hero 5 years ago
You need to have some experience on setting up web servers and Linux server administration, solder is not shit, it's for advanced users.
Posted by Misterio7x 5 years ago
It's sad how putting in the dependency of Composer. 0.6 version of solder worked great on my cheap host, but being unable to install composer on the host make the 0.7 versions impossible to run. That broke all my mods. ;(
sketaful 5 years ago
ok this is crap, I cant install any modpacks includeing the default ones, I click install and it does nothing and I ununstalled and reinstalled it
BlueYoshi68 5 years ago
My modpacks dont work im crying cause there was my favourite server and now I cant play it but my friends can ;( please help me;(!!!
TJrocker5 5 years ago
every one like then they cant ignore
they still will i have tried
Posted by DarkAssassin299 5 years ago
I Cant Launch Tekkit!
SKULL9867 5 years ago
Anyone know a cheap host that solder works on since after the update to 0.7x I can't use this on my old host? Damn composer ruined it, ;(
sketaful 5 years ago
OVH got a 4gb ram vps for 10$ monthly.
Posted by Misterio7x 5 years ago
[][][][][][][][][][][][][][][][][][]
Mate1934 5 years ago
GG
ummm my technic dosent work it says play offline all the time :C
Posted by snowfox999 5 years ago
i need help i cant put any modpack to the launcher and it really bugs me
buntjer5 5 years ago