Install Steve's Galaxy (Legacy)

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Steve's Galaxy (Legacy)) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Steve's Galaxy (Legacy) from the list on the left. The launcher will handle everything else!

Steve's Galaxy (Legacy) Version 1.4.4

created by endermedia on Minecraft Version 1.7.10 using Technic Solder

Steve's Galaxy (Legacy) updated to version 1.4.2

# Updated Another One Bites The Dust to 2.6.2
# Updated AE2 to rv2 stable 3
# Updated CodeChicken Core to 1.0.6.44
# Updated Coro Util to 1.1.2
# Updated Custom Main Menu to 1.5
# Updated Dr. Cyano’s Lootable Bodies to 1.3.5
# Updated Ender IO to 2.2.8.381
# Updated Flan’s Mod to 4.10.0
# Updated Forge to 10.13.3.1403
# Updated Galacticraft to 3.0.11.333
# Updated IC2 to 2.2.726
# Updated Mekanism to 8.1.2.230
# Updated NEI to 1.0.4.107
# Updated Open Computers to 1.5.11.25
# Updated OptiFine to HD U B7
# Updated Project Red to 4.6.1.80
# Updated Resource Loader to 1.2
# Updated Schematica to 1.7.5.120
# Updated Simply Jetpacks to 1.5.1
# Updated Stackie to 1.6.0.35
# Updated Tinker’s Construct to 1.8.5
# Updated Voxel Map to 1.5.13
* Customized MineMenu colors
Amaxter posted a changelog update for Steve's Galaxy (Legacy) 4 years ago

Comments

You must be logged in to comment. Click here to register a new account or log in.
POSSIBLE SOLUTION TO CRASH: Sorry again for the post, but playing a bit around with console and error log, I found a possible solution to potential crashes following the loading of an already existing world: The culprit is the Mekanism mod. If you use a logistical sorter in your world, then SG 1.4.2 will likely crash due to some exception linked to Mekanism's logistical sorter. The solution in this case is, just replace the version 8.1.2.230 of the Mekanism mod coming along with 1.4.2 of SG with an earlier version. In my case the version for SG 1.4.0 worked, which is Mekanism 8.1.0.216. You have to replace all (Mekanism, MekanismGenerators, MekanismTools) by just deleting the new version of the jars in the mods folder with the older versions. Works like a charm YEAH ;-) Hope that helps a bit! For the 85% loading stop, it is still there, but seems a mere glitch in the interface (at least in my case). Again, hope that helps a bit. In any case, SG is still by far the best and most consistent modpack out there. Just love it!!! Great work on all levels!!! :D
Posted by Starbuck_BSG 4 years ago
Update: I can create a new world without problems, all works fine there. But for an already existing world, it just crashes, which is bad, as my whole YT series is based on that *sigh*. So far, I've been using 1.4.0 without problems. 1.4.1 crashed as well.
Posted by Starbuck_BSG 4 years ago
Same here, it stops loading at 85%, but I get the main menu. However, once I load my old singleplayer world, it just crashes and goes back to the TechnicLauncher screen! Any suggestions?
Posted by Starbuck_BSG 4 years ago
Once again it just stops loading at 85% which is resource packs. What can I do about it?
Posted by Silver_Serpant 4 years ago

Latest Update

Introducing our latest modpack, Mianite Reborn, everything you wish Mianite S3 would have been, including an awesome community server, learn more at http://endr.me/reborn