Install Technik 1.7.10

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Technik 1.7.10) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Technik 1.7.10 from the list on the left. The launcher will handle everything else!

Technik 1.7.10 Version 2.0

created by MCWarFamily on Minecraft Version 1.7.10
You must be logged in to comment. Click here to register a new account or log in.
although you wanted to make a version 1.7.10, the map in version 1.6.4 of tekkit passes but unfortunately literally corrupted it would be necessary to make a patch that detects the blocks and rents them on the new ids in this case ALL the basalt, the blocks etc. nothing goes at all
GunthyGeek 1 month ago
Add some tinker construct addons please.
BobiAmbreaj 4 months ago
I DO love the tinker construct added in, however, as mentioned previously, it does not seem to work. The cheapest material pickaxe heads can be made of is flint, and I CANNOT find ANY flint when I use my hands, or even when I use a bone shovel. The only way seemingly to bypass this is steal stuff from villagers. If there is a way to get flint can you please let me know, because i have went through over two 64 blocks of gravel with no flint.
polosolo257 4 months ago
mod list?
C10H15N 4 months ago
I can`t break any blocks with tools but i can my hands what is the problem???????????????????????????????????????????????!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
MRPateGG 7 months ago
PLease help?!
Posted by MRPateGG 7 months ago
You need to use the tinkers construct tools. Read the book that you get when you spawn
Posted by Animine 7 months ago
you cant break any blocks with tools but you can with your hands
Nickige 7 months ago
i had the same glitch but if i make another world it seems to fix it for me
Posted by whateveralmond 7 months ago
you need to use tinkers construct
Posted by Animine 7 months ago
the quarry crashes my game whenever i place it down, and when i try and log back in it just crashes again soon after i get in. i tried turning down my settings but that doesnt work and i cant figure out why its breaking my game
whateveralmond 7 months ago
I get a LOT of these warnings. Is this normal? [14:56:23] [Server thread/WARN] [MachineMuse]: Item IC2:itemPartCarbonPlate not found in registry for recipe. [14:56:23] [Server thread/WARN] [MachineMuse]: Item IC2:itemHarz not found in registry for recipe. [14:56:23] [Server thread/WARN] [MachineMuse]: Item IC2:itemScannerAdv not found in registry for recipe. [14:56:23] [Server thread/WARN] [MachineMuse]: Item IC2:itemPartCarbonPlate not found in registry for recipe. [14:56:23] [Server thread/WARN] [MachineMuse]: Item IC2:itemBatREDischarged not found in registry for recipe. [14:56:23] [Server thread/WARN] [MachineMuse]: Item IC2:itemBatRE not found in registry for recipe. [14:56:23] [Server thread/WARN] [MachineMuse]: Item IC2:itemBatCrystal not found in registry for recipe. [14:56:23] [Server thread/WARN] [MachineMuse]: Item IC2:itemBatLamaCrystal not found in registry for recipe.
Triblade 8 months ago
hmm...i'd ignore the warnings...it's just a warning, not an error...but if you come up to an issue, you can report that
Posted by HyperXEngineer 8 months ago
So I just downloaded this pack and it loads up until "Reloading-Language Manager (1/24)" how can I fix this? Has anyone else experienced this?
TheBlueNinja97 10 months ago
You need to install java 64 bit. https://www.java.com/en/download/manual.jsp 3e link, it says (64-bit)
Posted by Rakaan 9 months ago
could you make a 1.12 version of this modpack?
austis 10 months ago
It was planned and sort of still is to push an update for a newer version...I have a problem with the new version though...Because of big changes in the mods I used and some being unavailable, the newer version isn't going to give the same experience...And on the other hand I can't seem to find time because of the upcomming midterms...I cannot promise anything, but definitely didn't forget about it
Posted by HyperXEngineer 10 months ago
Hey, I made a 1.12.2 port of this modpack, because I liked the modpack so much I had to port it. I havent uploaded it to technic because I want you guys to upload it (since its yours). I literally used some of my other modpack files and referenced the mods folder of the technik modpack to create the new one. If you want to look at it, i can send you a dropbox link. :)
Ryurious 1 year ago
Just tested it, everything works perfectly now. (The Modpack loads)
Posted by Ryurious 1 year ago
Another Note, I can't load my 1.7.10 save unfortunately. Its not corrupt because of the new version, it just wont load because all of the mods arent exactly the same (because of ports and outdated mods)
Posted by Ryurious 1 year ago
Sorry for the amount of replies, but I looked in the logs, It won't load because of the durastic version changes. So it seems everyone will have to make a new world... (i guess for better, or worse?)
Posted by Ryurious 1 year ago
Uh ok...It's been a while since I've last messed around with Minecraft modding, but I wouldn't mind getting back into it a little bit. If you want to, you can add me on Discord: Maroonchy#3261 and we can have a chat about it.
Posted by HyperXEngineer 1 year ago
I added you, my discord username is The Mjrlun
Posted by Ryurious 1 year ago
Also, how does one keep tabs on a website when their computer doesn't handle multiple processes well? xD
Posted by Ryurious 1 year ago
I would love a link to the modpack
Posted by anwoke8204 11 months ago
can you add the mod HxCShards?
exeluter 1 year ago
I don't feel like this mod in particular would suit a tech-based modpack. If you need to spawn specific mobs you can use Minefactory's machines to breed for example cows, and use the essence you get from killing them to spawn your preferred mobs
Posted by HyperXEngineer 1 year ago
I have a server up and running we have a friendly staff and limited banned items ServerIP: Technik.anvil.pw
Lord__Mianite 1 year ago
Sounds cool, sent you a message about that...
Posted by HyperXEngineer 1 year ago
Why i can't join
Posted by Zetsy 1 year ago
hello, so I've used multiple computers and still have the same problem. i start a world and immediately am struck major fps dips. i set all my settings to low and i'm still having problems. is there a mod or a setting i can disable to fix this problem? Nvidia GTX 1050ti 18GB DDR3 ram i7 CPU 2.67GHz
JakeTV 1 year ago
Bit weird, I've downloaded and run the game, spawned in the jungle and after regular rendering lag, it was perfectly fine.
Posted by HyperXEngineer 1 year ago
Working on a newer version (to support newer Minecraft versions), I hope that will sort most of the problems out.
Posted by HyperXEngineer 1 year ago
Maybe you forgot to allocate more RAM in the launcher? I've allocated 8GB (it uses less than 4 on average).
Posted by HyperXEngineer 1 year ago
Galacticcraft in serverupdates are broken, therefore the server wont start
Ahzriel 1 year ago
I hope that didn't give you too much of a headache and you managed to get it work :| I'll make sure the new server will work properly when I start & finish the new build! :)
Posted by HyperXEngineer 1 year ago
There are a lot of crashes in this modpack, first if you equip the traveller's wings the game will always crash when loading up the world, and second for some reason my itemducts keep crashing my world and I can't play it anymore. Sad because this was a fun modpack
SoulYard 2 years ago
@soul you ever figure out and fix the what was crashing you?
Posted by SnHxFirefighter 2 years ago
I've noticed the itemduct crashes and never tried the wings. When an update was planned, I had a lot to do in life as well so I discontinued the modpack for the time. Now that I'm back, I'm planning to ditch 1.7.10 and make a newer version.
Posted by HyperXEngineer 1 year ago
I can't use the Portal to the Deep Dark, I think it's related to galacticraft. Is there a way to fix this or is there a planned fix for this?
SoulYard 2 years ago
I've been a bit away, but I'll work on a newer version fairly soon...
Posted by HyperXEngineer 1 year ago
Even after changing this I can't use normal tools. Can someone help me?
kamilowaty122 2 years ago
I meant TC config
Posted by kamilowaty122 2 years ago
you could just delete the whole tinkers construct config...it'll generate the default one, without TC tools
Posted by HyperXEngineer 2 years ago
Even after that I still can't use normal tools.
Posted by kamilowaty122 2 years ago
How do you turn tinker's tools off via the server. I hate tinker's so hard.
DoctorAwesomeMD 2 years ago
same as this message(Disable Tinker Tools [For Weaklings ;) ]: Go to installation directory, config, TinkersConstruct.cfg, find B:"Remove Vanilla Tool Effectiveness"=true and change to false) but in your server directory like (C:/server/config/TinkersConstruct.cfg confused? click here (https://youtu.be/2XFBCIesfXs)
Posted by longd900 2 years ago
we have been playing this mod pack for about a week now, but still have yet to find any villages or abandoned mine shafts. have they been removed in this modpack?
anwoke8204 2 years ago
I don't know if they are but maybe you turned off Generate Structures
Posted by longd900 2 years ago

Latest Update

Early alpha 1.12.2 available for testing: https://www.technicpack.net/modpack/modpack-underconstruction.884357 make sure to tell me all about the issues you encounter!