Install ModdedNetwork StarWars

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (ModdedNetwork StarWars ) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select ModdedNetwork StarWars from the list on the left. The launcher will handle everything else!

ModdedNetwork StarWars Version 1.9

created by runescapejon on Minecraft Version 1.7.10
This modpack is hidden and will not show up in the modpack index.
This modpack is now fully not supported.
ModdedNetwork StarWars was updated to version 1.9 3 years ago
Server is Back Online!
Server is Back Online!
ModdedNetwork StarWars was updated to version 1.8 3 years ago
ModdedNetwork StarWars was updated to version 1.7 3 years ago
ModdedNetwork StarWars was updated to version 1.6 3 years ago
ModdedNetwork StarWars was updated to version 1.5 3 years ago
Server download files is release
Updated the modpack and fixes alot of the bugs about singleplayar
ModdedNetwork StarWars was updated to version 1.4 4 years ago
o.0 sorry for the along wait but if people want i can start working on this modpack more development coming soon
HUGE UPDATE! 1.7.10 :D SERVER COMING SOON! PLEASE WAIT!! :D ENJOY
ModdedNetwork StarWars was updated to version 1.3 5 years ago
New DreamCraft Rename to ModdedNetwork StarWars
Public server release now! just click Multiplayer and select the server to join have fun! :) and a few bugfixes on the key binds
ModdedNetwork StarWars was updated to version 1.2 5 years ago
well you ask and you rated good on the modpack ill keep my end of the promise and make a server, coming soon, if any of you have problem with the modpack please put in the comments the crash report in a Pastebin
ModdedNetwork StarWars was updated to version 1.1 5 years ago
If this modpack get good rating then ill make a modpack server for it :)

Latest Update

This modpack is now fully not supported.