Install Aether 2 HQM

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Aether 2 HQM) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Aether 2 HQM from the list on the left. The launcher will handle everything else!

Aether 2 HQM Version 1.2

created by Zote on Minecraft Version 1.7.10
You must be logged in to comment. Click here to register a new account or log in.
In the quest of making the Ship's Engine, I try to craft the Floaters with the right materials but doesn't craft it and shows nothing in the box after you have crafted something.
RedPandas98 3 months ago
When I check my quest book, in "The Aether" section, it detects that there is an unclaimed quest. But when I checked to see it doesn't show any of the quest glowing purple. It happened ever since i finished the Ship's Helm quest.
RedPandas98 3 months ago
After completing the quest "The Slider", I cannot complete "The Path Home" because the quest does not detect the Orb of Arkenzus in any way. I loved modpack, can you fix it please?
Mr_Gilles 5 months ago
Same thing has happened to me so I'm unable to move onto the next quest.
Posted by RedPandas98 3 months ago
a very good modpack! simple, to the point, and works in peaceful mode.
DraconicDemon 1 year ago
In the quest book, killing the sentry guardian in the labyrinth still does not complete "the strong" quest. I have tried going into creative mode to fix it.
dolphin_of_peace 1 year ago
Is there any way to skip that quest
Posted by dolphin_of_peace 1 year ago
I figured it out use /hqm edit to auto complete that quest that is broken
Posted by dolphin_of_peace 1 year ago
In the quest book, killing the sentry guardian in the labyrinth still does not complete "the strong" quest. We've tried multiple times.
craigwatcher 1 year ago
not able to complete the quest "the strong" because it doesnt detect when you kill the sentry guardian
finmaster344 1 year ago
I believe the first quest is glitched, Ive looked all around and cant find the darn map. is the Elder meant to give you it or do you use the one inside your hosue? ive tried the map inside the house and it doesnt work.
2fst4u 1 year ago
Talk to the elder and they will tell you that the map is “under my desk”. Break the desk and there is a secret trap door underneath
Posted by Zote 1 year ago | Modpack Creator
I was in the labyrinth part of the aether and i killed all of the minibosses but the "The Strong" quest wouldn't complete do you know how i can fix this? (I tried killing anything else i could think of to fix it and it didn't work)
SwordMaster2976 1 year ago
I’m sorry, I’ll look into it.
Posted by Zote 1 year ago | Modpack Creator

Latest Update

Aether 2 HQM was updated to version 1.2