Technic Blog

ConcurrentModificationException in Java 1.8.0_20

This is a warning that a few days ago, a Java update versioned 1.8.0_20 was released, which currently makes it impossible to play modded Minecraft.  The release fixed a Java bug which was hiding a bug in Forge Modloader- users with this new version of java will now receive a ConcurrentModificationException when trying to load modpacks in Minecraft 1.6+.

Forge is currently working to correct this issue, but in the meantime, we advise that you do not update your Java version to 1.8.0_20.  We instead recommend that you use one of the following versions:

Java 1.7.0_67- we highly recommend that you downgrade to this version, because it is security complete: http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html

Java 1.8.0_11- if you need to stay on java 1.8, this is the latest version without the listed issue.  Again, there may be security updates in 1.8.0_20 not present in this version, so please use with care:  http://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html

Comments

You must be logged in to comment. Click here to register a new account or log in.
This is fixed, but only in the latest forge for 1.7.10. Everything from 1.6.1 or above to 1.7.2 or below is still broken. But there is any EXTREMELY easy fix. Download This: http://files.minecraftforge.net/LegacyJavaFixer/legacyjavafixer-1.0.jar Then put it in your forge mods folder. (NOTE: a lot of modpacks (including technic packs) already have this.
IRONTEMPLEMAN 5 years ago
Thank you so much for this, it finally worked! i have tried sooo many things but this works!
Posted by sanderkiller 5 years ago
Literally made an account just to upvote this.
Posted by UpTide 5 years ago
Yes finally thank you!
Posted by etarip101 4 years ago
Excelent! Thanks a bunch!
Posted by fileark 4 years ago
mine still wont work it says java SE stopped working
Posted by sgodsoe11 4 years ago
Well, you never did. I can't play any mods anymore! }:(
Posted by Utoobe_GAmin 4 years ago
I put it in my mods folder and it didn't work, please help me
Posted by Natalie Barr 4 years ago
do you need minecraft to play this
anush 5 years ago
NOOOOOOOO, IT'S NOT LIKE IT'S A MINECRAFT MODPACK
Posted by dudedude2211 5 years ago
Java Jdk-7u75 is good?
kira_oo 5 years ago
thank god this has been fixed now these modpacks ARE READY FOR FREDDYY
robotranic rex 5 years ago
yay!
matt101a 4 years ago
so i updated to java 8 update 71 and now i cannot launch the technic launcher. i can't downgrade my java without filling out a thing that seems like something that should not be filled out. is there a way that i can fix this?
mine still dont work it says java SE binary has stopped working
sgodsoe11 4 years ago
Well, you never did. I can't play any mods anymore! }:(
Utoobe_GAmin 4 years ago
why only so few upvotes to give need moar upvotes
Inaire777 3 years ago
When I open the technicpack it appears to me that I do not have version 1.0.5 and there is not that version
RealBlack14 3 years ago
oıjseıofkse 5 months ago