Install Star Wars: Conquest v7.0

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Star Wars: Conquest v7.0) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Star Wars: Conquest v7.0 from the list on the left. The launcher will handle everything else!

Star Wars: Conquest v7.0 Version 7.0.1

created by MinersLeague on Minecraft 1.7.10

Star Wars: Conquest v7.0 updated to version 7.0.1

QoL additions
TheMinersLeague posted a changelog update for Star Wars: Conquest v7.0 1 month ago

Comments

You must be logged in to comment. Click here to register a new account or log in.
Seems like the new version modpack 7.0.1 Has Messed Up The Game. What would happen is I load a world. Then it says the usual when a mod gets removed which seems like the flans mod. Then I create a backup of the world and load it in and it gets so laggy and then 30 seconds later it crashes. I load up the world again and 10 seconds later it crashes. That always happens then after when i go in the world its all black and crashes just a i join. So hours of work got lost. (but not really because i have a backup) So i now sit with an unusable world. Nobody might see this but i hope it gets fixed or if there is different versions i can switch to to keep playing my world. Thanks
Posted by 2_fun 1 week ago
ho is flansmod and what can we expect?
Posted by RangerLPHD 1 month ago

Latest Update

Star Wars: Conquest v7.0 was updated to version 7.0.1