Install The 1.7.10 Pack

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (The 1.7.10 Pack) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select The 1.7.10 Pack from the list on the left. The launcher will handle everything else!

The 1.7.10 Pack Version 0.9.8d

created by Hi it's me on Minecraft Version 1.7.10 using Technic Solder
Finally.
Hi it's me posted a status update for The 1.7.10 Pack 5 years ago

Comments

You must be logged in to comment. Click here to register a new account or log in.
hi would you mind posting a link or making an option to downgrade the pack back to 0.7.0 version?
Posted by imsupermario 5 years ago
Why would you want to do such a horrible thing?!
Posted by Hi it's me 5 years ago
yep,forget it i am restarting my server with the latest 0.7.1 version, this is my favorite pack!!well done
Posted by imsupermario 5 years ago
(:
Posted by Hi it's me 5 years ago
Well my launcher now refuses to upgrade and says "An error was raised while attempting to read pack info for modpack the-1710-pack, build 0.7.0: error in response Build does not exist." WHY WOULD YOU REMOVE OLDER VERSIONS? LEAVE THEM SO PEOPLE CAN STILL LAUNCH UNTILL A SERVER IS UPGRADED
Posted by HolyCow 5 years ago
Read my comment there: http://www.technicpack.net/modpack/the-1710-pack.453902/changelog/30569
Posted by Hi it's me 5 years ago
I really love this pack, i have some question's.. *What is the new in this update? *If i update, i will lost my world? *i will lost the other mods what i added ?? (i added some mods for make a thermoelectrical plant :v , just 3 extra mods) Finally GJ making this mod pack
Posted by dennyxd1 5 years ago
1: You can check out yourself through the "CHANGELOG" section. 2: No. 3: Not too sure but it's not that bad, just backup them. I actually don't think you'll lose them.
Posted by Hi it's me 5 years ago
i lose the other 3 mods, but i just put them again in the mod folder... ;) thanks you...
Posted by dennyxd1 5 years ago
yay! , thanks for the fix update!, btw any plan to add quarryplus into the modpack?, and a telepad would be very convenience :))
Posted by Ghen 5 years ago
You should suggest new mods there: http://bit.ly/The-1-7-10-Pack-Issues
Posted by Hi it's me 5 years ago
ah ok, thank you
Posted by Ghen 5 years ago
oops nevermind, i didn't realize you already put warp book here xD
Posted by Ghen 5 years ago
for some reason the pack still wont open
Posted by Dustier7 5 years ago
Please open a new issue there: http://bit.ly/The-1-7-10-Pack-Issues
Posted by Hi it's me 5 years ago

Latest Update

The 1.12.2 Pack is officially released! After several months of research, development and testing, we're exited to say the sequel is now available through http://bit.ly/The-1-12-2-Pack-Technic-Download. Players of The 1.7.10 Pack, welcome to the new home!