CanVox

Hi, it'd be great if you could update TheMindCrafters - Icehenge to 1.7.10 or include LexManos's LegacyJavaFixer mod into the pack, so that users with java 8 could play it.
Posted by CanVox on themindcrafters's profile 4 years ago

Comments

You must be logged in to comment. Click here to register a new account or log in.
Hi guys, Just a head-up the pack is broken and I am unable to download the client version, server side looks to be okay.
Posted by gnrdewet 3 years ago