Install The 1.7.10 Pack

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (The 1.7.10 Pack) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select The 1.7.10 Pack from the list on the left. The launcher will handle everything else!

The 1.7.10 Pack Version 0.9.8

created by Hi it's me on Minecraft Version 1.7.10 using Technic Solder
Pushed v0.8.4 to recommended!
Hi it's me posted a status update for The 1.7.10 Pack 2 years ago

Comments

You must be logged in to comment. Click here to register a new account or log in.
Ya Why dosent My Server Work When i add your Mod Pack Please help
Posted by xjoahx 2 years ago
Go there to get help: http://bit.ly/The-1-7-10-Pack-Issues
Posted by Hi it's me 2 years ago
wats up :P
Posted by generalelite18 2 years ago
What's not up?
Posted by Hi it's me 2 years ago
hi um this seems to happen a lot any pack with ic2 seems the world seems to corrupt ie no chests open and blocks when broke don't drop is there any known fix for this?
Posted by Alexanderworms 2 years ago
Go there to get help: http://bit.ly/The-1-7-10-Pack-Issues
Posted by Hi it's me 2 years ago
What's different from this update and the last?
Posted by xDragonxBornx 2 years ago
http://isigiel.github.io/changelogger/#/?url=http:%2F%2Fapi.technicpack.net%2Fmodpack%2Fthe-1710-pack&from=0.8.3&to=0.8.4
Posted by Hi it's me 2 years ago
I really like this pack, thank you. I play with along with my daughter on a little 0.8.4 server at home. I can't wait to see what you come up with for a MC 1.8 Mod Pack!
Posted by Calloused_Thumbs 2 years ago
Thank you very much! happy to see this helps for quality time. About 1.8, it depends more on the modders :)
Posted by Hi it's me 2 years ago
it says baubles can not be found but its in the mod file Halp PLZ?
Posted by EPICwolfguy30 2 years ago
Go there to get help: http://bit.ly/The-1-7-10-Pack-Issues
Posted by Hi it's me 2 years ago

Latest Update

The 1.7.10 Pack was updated to version 0.9.8