Install The 1.7.10 Pack

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (The 1.7.10 Pack) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select The 1.7.10 Pack from the list on the left. The launcher will handle everything else!

The 1.7.10 Pack Version 0.9.8d

created by Hi it's me on Minecraft 1.7.10 using Technic Solder
You must be logged in to comment. Click here to register a new account or log in.
So stoked for the update...I swear i'm ecstatic.
Voideon 5 years ago
It may come out just tomorrow, short in time than expected! :)
Posted by Hi it's me 5 years ago | Modpack Creator
Ok ;]
Posted by Voideon 5 years ago
It's out!
Posted by Hi it's me 5 years ago | Modpack Creator
Hi It's Me add me on skype: Saulsteele1, I believe we can make the server work.
Saul_PvP1 5 years ago
but can you do it on a cold rainy night in stoke
Posted by Voideon 5 years ago
please help me if i try playing this modpack it says error could not create java virtual machine error a fatal exception has occurred. progaram will exit. can someone fix this i do not want to download and instal something like java because i am scared for hacks and that i cant play minecraft anymore
eggi5 5 years ago
https://www.youtube.com/watch?v=KH62sm-orE4
Posted by Hi it's me 5 years ago | Modpack Creator
i dont get it srry :,(
Posted by eggi5 5 years ago
my dedicated server with 32gb of ram and dedicated ip is up and running please see my community for more information. www.gentlemensgaming.co.uk ... whitelist required
MrKRONIC 5 years ago
For anyone that isn't able to allocate enough Ram or it crashing. http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html < Download this and install it.
Voideon 5 years ago
Downloading Java 8 is recommended (8 > 7) even though it won't fix every issue on your computer.
Posted by Hi it's me 5 years ago | Modpack Creator
you're right... But I was helping someone get it fixed and the problem they had was everytime they tried to use a Java 8 jre it would tell them they were outdated. or there computer was, so I thought it would be about updating drivers or the computer itself, but when I found this one it worked.... But you're right. I'm on java 8 just transitioning from 7 and I can actually see a great difference :D
Posted by Voideon 5 years ago
Java 8 ? ew. The security issues on java 8 are UNBEARABLE. I can't use ANYTHING java related online because it won't have its "drivers signed" and you can't turn down the security on java 8. It's forced.
Posted by ethan80537 5 years ago
Hello Hi it's me, I me and my team are very interested in hosting the official server for your mod pack if you're interested add me on Skype so we can talk terms. Skype: saulsteele1
Saul_PvP1 5 years ago
Making an official server is hard, especially when you can't have plugins. :)
Posted by Hi it's me 5 years ago | Modpack Creator
*my team and I
Posted by Toasty Toast 5 years ago
Hey nice mudpack btw! One thing for me personally i do not like the over the top robotic mods that involve space or wiring/pipes. I love the magic/rpg/adventure aspect. Can i play through this modpack without having to deal with any of the mechanical mods? Or should i just pull out all those mods before i play?
Skyoto 5 years ago
modpack*
Posted by Skyoto 5 years ago
Yes, You definitely can...That's how I like my modpacks personally aswell, but this is perfect.
Posted by Voideon 5 years ago
Of course you can! You don't have to play with anything, we just provide you a stable option to use everything :)
Posted by Hi it's me 5 years ago | Modpack Creator
Whenever I hit install it gos through and gets to installing libraries and just stops at 44%,
dyegreenluke 5 years ago
Please see in the "HELP" Section where you should get complex help :)
Posted by Hi it's me 5 years ago | Modpack Creator
I really want to play but I can not get in? I have put the settings to java 1.7 java 64-bit and 2GB but it loads up with that hour glass thing. It says "initialising" and just closes itself! Please help!
Toasty Toast 5 years ago
Please see in the "HELP" Section where you should get real help. There, open a new issue and I'll help you. Be sure to include a log or something, more information will be there!
Posted by Hi it's me 5 years ago | Modpack Creator
Hi. I'm just here to suggest a mod to add (if you don't take requests than ignore this) but you should add MCA! (Minecraft Comes Alive) IT mainly adds better villagers that you can marry, have kids with, and more!
dyegreenluke 5 years ago
I was thinking the same thing. I think it would be awesome on the server. Plus the witchery update adds walls and larger villages too the existing ones and mca would be perfectly suited.
Posted by Voideon 5 years ago
I'm not sure what is going wrong. I go to play the mudpack and it closed the launcher as if its going to open the game and then the launcher opens again and the game doesn't start. I know someone suggested allocating more memory, so I put it to 6 gb, and I am using the latest java, 1.6.0_65 with 64 bit. Someone please help!
Sladak 5 years ago
Java 1.6? We're on Java 1.8! This is your problem (:
Posted by Hi it's me 5 years ago | Modpack Creator
Ah yes that would explain it. I will try and fix that thanks!
Posted by Sladak 5 years ago
So, I was getting a friend to go onto this modpack, and he's having the same problem exactly. same 1.6 and all. And we're trying to figure out how he updates it. we've re downloaded Java but nothing happened. So wondering what you think we should be doing
Posted by Voideon 5 years ago
Nevermind. We fixed it.
Posted by Voideon 5 years ago
Omg. Update tomorrow. CAN'T WAIT
Voideon 5 years ago
Sadly the Portal Gun doesn't exsist for MC 1.7.2 but I'm sure you would include that if you could. Could you add the Damage Indicator mod? I really like that mod more then this 'what am I looking at'. But great pack!
MrTarantel 5 years ago
I can't post these mod suggestion on this other platform, because I don't want to create an account there.
Posted by MrTarantel 5 years ago
Well, WAILA tells you also the health of the mod, and it's enough for 98% of the people. If you want more than that, I'd recommend you to install it manually, sorry! [:
Posted by Hi it's me 5 years ago | Modpack Creator
when i press play its verifying minecraft assetts and then closes down the launcher and opens it right after so the game dont really load at all. any way to fix this?
Sittin'Sidewayz 5 years ago
Java 7/8 & 64bit.
Posted by Hi it's me 5 years ago | Modpack Creator
Go into Launcher Options, Java, and make sure you set at least 2 GB of RAM available. You might need to install Java 64 bit if the option for 2 GB is not there.
Posted by imperiledthree 5 years ago
any good servers?
xxbemanxx 5 years ago
http://bit.ly/1AHqiGe
Posted by Hi it's me 5 years ago | Modpack Creator
Best MODPACK EVER 8/8 M8
forster82 5 years ago
Thanks m8, no h8! :D
Posted by Hi it's me 5 years ago | Modpack Creator
Add ME 1st
The_Roman_Empyr 5 years ago
Huh?
Posted by Hi it's me 5 years ago | Modpack Creator
just wanted to say awesome modpack! keep up the good work.
jamesbandeen 5 years ago
:)
Posted by Hi it's me 5 years ago | Modpack Creator
Ugh, Not sure if this is the place to post. But a new Update for the Witchery Mod has come out and it adds vampires and all this cool stuff and I was wondering how soon you would be updating it. And the version is actually for 1.7.10 (just updated).
Voideon 5 years ago
He said the next pack update would be on March 16th, so I imagine witchery will be getting the update then.
Posted by Puremin0rez 5 years ago
^
Posted by Hi it's me 5 years ago | Modpack Creator
Ok thanks. I didn't see that. :)
Posted by Voideon 5 years ago
I hit 'play' on the launcher and it started to start up, but then it went back to the launcher. I am on java 7. Any help?
Stonewall33 5 years ago
64 bit?
Posted by Hi it's me 5 years ago | Modpack Creator
yeah. nevermind, i need version 75 not 76 for some reason
Posted by Stonewall33 5 years ago

Latest Update

The 1.12.2 Pack is officially released! After several months of research, development and testing, we're exited to say the sequel is now available through http://bit.ly/The-1-12-2-Pack-Technic-Download. Players of The 1.7.10 Pack, welcome to the new home!