Install The 1.7.10 Pack

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (The 1.7.10 Pack) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select The 1.7.10 Pack from the list on the left. The launcher will handle everything else!

The 1.7.10 Pack Version 0.9.8c

created by Hi it's me on Minecraft Version 1.7.10 using Technic Solder

The 1.7.10 Pack updated to version 0.7.6b

After years of waiting..it finally comes. Now on DVD and Bluray...
A new update! Now for the changelog:
- Updated Forge to build 1352.
- Updated 37 mods to their latest versions, all the mods on the pack are up-to-date. This includes an update from Mekanism that fixes a pretty serious bug that crashed and freezed worlds..scary. Thanks to Spellkaze (on GitHub) we were able to report it.
- Minor configuration changes.
- Changed some things on the server files, you'll see.
Enjoy!
Hi it's me posted a changelog update for The 1.7.10 Pack 4 years ago

Comments

You must be logged in to comment. Click here to register a new account or log in.
download ( client ) is persistently failing. "Error unzipping a file for the following pack: The 1.1.10 Pack Attempting to extract file the-1710-pack-0.7.6b.zip, but it did not exist."
Posted by tmc4242 4 years ago
Typo. ..following pack: The 1.7.10 Pack...
Posted by tmc4242 4 years ago
Should be fixed :)
Posted by Hi it's me 4 years ago
Does that mean i have to redownload the server files?
Posted by MatCraftDK 4 years ago
Yup
Posted by Hi it's me 4 years ago
The update is working like a charm with me, also, I heard that this version of mekanism have some bugs in the servers, but until there is any server report, the things should be fine.
Posted by Spellkaze 4 years ago
There's an issue with the integration between EnderIO & Mekanism, we'll have to use a dev build of EnderIO to fix this. More info on GitHub.
Posted by Hi it's me 4 years ago
the update wont work for me
Posted by tbird364 4 years ago
Won't work eh? In what way? Anyway go to the "HELP" Section to get help, here is not the place.
Posted by Hi it's me 4 years ago

Latest Update

If you suffered from crashing after updating to v0.9.8c, please reinstall the modpack now as this will revert the LumySkinPatch mod to its older version. That should fix your issue!