Install The 1.7.10 Pack

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (The 1.7.10 Pack) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select The 1.7.10 Pack from the list on the left. The launcher will handle everything else!

The 1.7.10 Pack Version 0.9.8c

created by Hi it's me on Minecraft Version 1.7.10 using Technic Solder

The 1.7.10 Pack updated to version 0.7.5

~10 days without an update and I get "is this pack abandoned". Huh :P
Anyway, here is our lovely changelog:
- Added Default World Generation (Just as the name of the mod, BoP is the default now).
- Updated Forge to latest version, 1307.
- Updated *37* mods to this point, all the mods in the pack are up to date.
- Minor configuration changes.
- Just one tiny bug fix to a specific HQM quest.
- Added a server icon to the server files!
Don't forget that for any support that you need simply go to: http://bit.ly/The-1-7-10-Pack-Issues
Enjoy! ;D
Hi it's me posted a changelog update for The 1.7.10 Pack 4 years ago

Comments

You must be logged in to comment. Click here to register a new account or log in.
How do i delete Haxys from the server list?
Posted by TommDX 1 year ago
i can't run it ==
Posted by suntdnb 4 years ago
Use Java 7/8 and a 64 bit version of it.
Posted by Hi it's me 4 years ago
This is my favorite pack to play. Keep up the great work!
Posted by ZeWi 4 years ago
Thanks!
Posted by Hi it's me 4 years ago
Ever since I updated to 0.7.5 minecraft has not been allocating RAM correctly Before I updated when i pressed f3 the allocated RAM was 4096 and it never changed, now changes on the fly from between 2000 and 3000 and its killing my FPS.
Posted by bisousbisous64 4 years ago
In The 1.7.10 Pack the RAM is allocating automatically. If your FPS is not the best you should download Optifine, but the RAM is not what killing your FPS.
Posted by Hi it's me 4 years ago
Actually, RAM might be killing the FPS, if you have resource packs, 4gb isn't enough, and I spent a really long time realizing that this modpack forced java args completely ignoring any arguments I set in the technic launcher. I had to manually change the version.json (the one inside the modpack.jar!!!) to be able to allocate more ram. After allocating 8gb fps spike of death disappeared because I was no longer reaching the 4gb limit. You should add somewhere on here instructions on how to change the java args because really, automatic should be a suggestion, not an enforced limit. Obviously I think this will fix the "ZOMG NO RAM?!??!" comments but I feel like showing where you can change this instruction is needed for people that need more ram. (I also think technic should show what the modpack java args are instead of always overriding the version.json thing, but that's not for you, that's for the technic people :D)
Posted by Andrew121007 4 years ago
i cant run it
Posted by Mussa03 4 years ago
Well, that's unfortunate! See on the "HELP" Section where you should get help.
Posted by Hi it's me 4 years ago
Do I just drop the new server files in over the old ones? Or do I need to delete the old?
Posted by Canuck117 4 years ago
Delete the old
Posted by Hi it's me 4 years ago
Thanks for investing so much into this pack. It's an awesome combination, and by far my personal favorite pack I've ever played. Just wanted to let you know that your effort is appreciated!
Posted by dragnnflye15 4 years ago
Thank you very much [:
Posted by Hi it's me 4 years ago
Will this break worlds from 0.7.4?
Posted by spocot 4 years ago
Nope. Updates never break worlds (unless I tell them to).
Posted by Hi it's me 4 years ago

Latest Update

If you suffered from crashing after updating to v0.9.8c, please reinstall the modpack now as this will revert the LumySkinPatch mod to its older version. That should fix your issue!