Install Lapito's Galacticraft Modpack

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Lapito's Galacticraft Modpack) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Lapito's Galacticraft Modpack from the list on the left. The launcher will handle everything else!

Lapito's Galacticraft Modpack Version 8.7.5

created by Nbgreen on Minecraft Version 1.12.2
You must be logged in to comment. Click here to register a new account or log in.
It crashes on 3/7 and says the problem is tinkerers construct, how do I fix this?
jacobsf65 2 months ago
https://paste.dimdev.org/wexomenoli.mccrash
iamgoodmen 2 months ago
Whenever I try to open galacticraft from the launcher it closes around 3/7 on the second bar and around sounds on the third. I have the error report too if it's needed.
Craftboi69 3 months ago
crashes every time for me
rowpoke 4 months ago
When myself and other two friends downloaded the mod, the game ended up crashing at the loading screen for all of us, is there any fix for this?
ebertj227 5 months ago
When I Random Teleported I teleported to x:-1480, z:2482, y:66. I crashed. When I try to spawn back in I crash again and again. I have tried 5 times. I am stuck because I can't type a command in fast enough before I crash. Can anyone help? Maybe go to that point and see if you crash? Or maybe teleport me out of there.
Trufire 5 months ago
Hi, just thought I'd let you know the download is broken for me. Maybe check your file hosting
Jolihan 6 months ago
https://paste.dimdev.org/utisufebif.mccrash
Acesofwar 6 months ago
what happened to buildcraft?
nolexe 7 months ago
Please keep comments to a pack related matters
vexedjman11 7 months ago
So after the new update (8.6.2) came out I haven't been able to use Lapitos Galacticraft on my aternos server since it only supports version 8.6.1 right now. Is there any way that I can use version 8.6.1 on the technic launcher so we can use our aternos server?
Typerkiller 7 months ago
To launch the server through a batch file, what executable does it need to run? or am I doing this the wrong way entirely...
BlueJ360 8 months ago
why is the minimap mod gone?
thefirstaussie 8 months ago
why "Server download" link here is not compatible with client? wanted to test my own little server, but incompatible mods ....... :-(
icomaniac 8 months ago
It wont launch it just crashes for me 0-o
LegitKilla 8 months ago
actual version working only with java(64bit) 3,5GB RAM for run and 4GB+ RAM for using texture resourcepacks :-) but for galacticraft is recomended 6GB+
Posted by icomaniac 8 months ago
so recently been watching some videos on YT about galacticraft, and i wanted to try it out unfortunately i have a mac but its 3G ram so its fine but it says after i download it that some mods are interfering with the modpack so i cant play it just wondering if someone could get back to me and tell me why?, no rush know your busy just whenever
Noot_Dude123 10 months ago
The mods use a lot of RAM to run. There's no workaround - you need at least 3GB of RAM. I personally like running with 8 to make life easy.
Posted by thebigschnoz 10 months ago
Please give us access to server files. It is near impossible to host a private server without em.
Flynnius 1 year ago
This modpack runs really smoothly with 4G allocated on my computer, but runs like absolute shit on my wife's computer. We have identical computers except she has a Radeon HD 7950 whereas I have a GTX 1060. Regular Minecraft runs just fine on her computer, any help?
axman10 1 year ago
I want server pack
KILLERMANTV_KIL 1 year ago
OS is 64 Java HotSpot(TM) 64-Bit Server VM warning: Ignoring option MaxPermSize; support was removed in 8.0 A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.base/java.lang.reflect.Method.invoke(Unknown Source) at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:62) at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:31) Caused by: java.lang.ClassCastException: java.base/jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to java.base/java.net.URLClassLoader at net.minecraft.launchwrapper.Launch.(Launch.java:34) at net.minecraft.launchwrapper.Launch.main(Launch.java:28) ... 6 more Press any key to continue . . . I get this error message when I try to open a modpacks LaunchServer.bat which was created automaticly with atlauncher.
eimantasxd23 1 year ago

Latest Update

Lapito's Galacticraft Modpack was updated to version 8.7.5