Install Craft & Slash RPG

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Craft & Slash RPG) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Craft & Slash RPG from the list on the left. The launcher will handle everything else!

Craft & Slash RPG Version 2.0.1

created by TheEpicModPack on Minecraft Version 1.7.10
You must be logged in to comment. Click here to register a new account or log in.
Any chance of a storage mod being put in? Storage drawers, jabba barrels, something?
Himeki 3 years ago
Iron Chests will be in the next update
Posted by TheEpicModPack 3 years ago | Modpack Creator
download is broken
Asrafel3 3 years ago
Fixed it!
Posted by TheEpicModPack 3 years ago | Modpack Creator
Download is broken :(
DBtheGreatest 3 years ago
Should work now!
Posted by TheEpicModPack 3 years ago | Modpack Creator
Download's broken again.
zeldafan36143 3 years ago
Just fixed!
Posted by TheEpicModPack 3 years ago | Modpack Creator
The modpack wont download for me
adjr03 3 years ago
Give it a try now, just fixed the download!
Posted by TheEpicModPack 3 years ago | Modpack Creator
Optifine or fastcraft would help so much with this pack.
MrCheeseTaters 3 years ago
This pack has fastcraft and betterfps, and chunkpurge already. You could add fpsplus+ for another boost if you want, though that can't be included in the pack due to it needing specific java arguments to be set in the launcher, which I can't control through the modpack. Optifine is incompatible with fastcraft, which is why it is not included. Fastcraft gives a significantly larger fps/latency boost over optifine, as the main cause of lag in the pack is not graphic lag, but loading lag, which fastcraft takes care of. That said, this pack should run fine on most PCs as long as you allocate 2GB or more of RAM and keep the graphic settings at the default. It runs smooth on my macbook and other laptops.
Posted by TheEpicModPack 3 years ago | Modpack Creator
Something strange is happening when I join into my own server now. For a while I'm getting this error: "internal exception java.io.ioexception an existing connection was forcibly closed by the remote host" I've tried fixing it in many ways now but it's not working. Any ideas?
JustChris 3 years ago
Is this happening when you do something specific? I know some chocolate quest actions cause that, but those are mainly related to creating custom NPCs for dungeons and other things that don't happen during regular play.
Posted by TheEpicModPack 3 years ago | Modpack Creator
Not really. I was in my own home doing some inventory management when it happens, going to see if I can fix it today since it happened last night.
Posted by JustChris 3 years ago
IS there a server for this pack?
Sparten2168 3 years ago
There's no official one, though there is a server package so that anyone in the community can make one.
Posted by TheEpicModPack 3 years ago | Modpack Creator
Cant download. if i go to the dropbox it says: Error (429) This account's links are generating too much traffic and have been temporarily disabled! #feelsbadman
Minecraft_JBB 3 years ago
Should work now, thanks for letting me know
Posted by TheEpicModPack 3 years ago | Modpack Creator
Well on my PC it doesn't work :/
Posted by Minecraft_JBB 3 years ago
Nevermind just restarted technic launcher and now it works!
Posted by Minecraft_JBB 3 years ago
Getting the same error when I try to download it. I'm guessing fixing the download broke the download.... Haha!
FriskiestChart6 3 years ago
Naw, it fixed it for a bit. The download is gonna break on a daily basis with the amount of traffic we get. Fixing it again right now.
Posted by TheEpicModPack 3 years ago | Modpack Creator
Got this error about five minutes ago. "error downloading a file for the for the following pack: Craft & Slash RPG - Failed to download https://www.dropbox.com/s/07hoklx0zohf0mz/modpack3.zip?dl=1 - Please consult the modpack author. -OK-"
Antisocialkittie 3 years ago
Download is fixed!
Posted by TheEpicModPack 3 years ago | Modpack Creator
I think a download is down for dropbox :error downloading file for the following pack: Craft & slash Rpg failed to download https://www.dropbox.com/s/07hoklx0zohf0mz/Modpack3.zip?dl=1 :Please consult the modpack author.
silverbond_5 3 years ago
Should work now!
Posted by TheEpicModPack 3 years ago | Modpack Creator
Which version of Thaumcraft is in this modpack? I'm looking up a guide and don't know which version to use.
FlatchelentCheese 3 years ago
Thaumcraft 4
Posted by TheEpicModPack 3 years ago | Modpack Creator
server down ! pls repared this to download
xx-hacker 3 years ago
Download is updated, let me know if you have any issues!
Posted by TheEpicModPack 3 years ago | Modpack Creator
how can i play on the server or what is the servr ip
IchBinSimon 3 years ago
There is no official server
Posted by TheEpicModPack 3 years ago | Modpack Creator
does this have a multiplayer? a server or sth?
Pr0nFire 3 years ago
No official server, though there is a server package so the community can make one if anyone wants.
Posted by TheEpicModPack 3 years ago | Modpack Creator
Been trying to get it to work, the game crashes after about 3-5 seconds of walking in game, all of the textures seem to not have loaded as well. I have an i5 6600k processor and a GTX 950 GPU, I shouldn't be lagging, I know it's recommended to change RAM allocation to 2g, but it only allows 1 at the max. Not sure what else to try.
udead196 3 years ago
you need a bit of an older java i run same set up and i crash to might be update i dont know
Posted by SinProductions 3 years ago
There's definitely an issue with your java or something if it's only allowing 1GB max. Make sure you have 64 bit java if you have a 64 bit OS, otherwise it won't allow you to allocate more RAM. Aside from that, I'm not sure, that sounds like something outside of the modpack. I am using the newest build of Java 8 to run the pack.
Posted by TheEpicModPack 3 years ago | Modpack Creator
Thanks for your help, it was because I was running a 32 bit version of Java for some reason, took me a bit of looking to get the right executable as the one used for the modpacks but now it works fine for me.
Posted by udead196 3 years ago
Awesome, glad it helped!
Posted by TheEpicModPack 3 years ago | Modpack Creator
wile it is in the finale stage of loading in loading reasourses it always crashes for me is it my computer or is it the files?
awesomeconcon 3 years ago
Sounds like something on your end. If you post a crash report I can take a look.
Posted by TheEpicModPack 3 years ago | Modpack Creator
whenever I launch the batch file as administrator it says "Unable to access jarfile bin/pw/prok/KCauldron/1.7.10-1614.201/KCauldron-1.7.10-1614.201.jar Press any key to continue" And when I run it regulary nothing happens
KuroReaper 3 years ago
Make sure your java isn't out of date (1.8 or newer). Also, make sure nothing has been moved at all (just make a blank folder on your desktop and extract the whole zip to that folder, it should work right after unzipping). If it still isn't working let me know, I'll take a look to make sure it works properly on my end.
Posted by TheEpicModPack 3 years ago | Modpack Creator
don't ask add Archimedes ships mod
tovir 3 years ago

Latest Update

Sorry for the lack of updates guys! In a few months I will be finished college, and will have time for plenty of updates! Keep giving me feedback!