Install Craft & Slash RPG

Step 1

Installing a modpack using the Technic Launcher is easy. If you don't already have the launcher downloaded, visit our download page to get the latest version.

Step 2

Type in the modpack name (Craft & Slash RPG) or paste the following url into the search box.

Step 3

Finally, click Install at the bottom right of the launcher after you select Craft & Slash RPG from the list on the left. The launcher will handle everything else!

Craft & Slash RPG Version 2.0.1

created by TheEpicModPack on Minecraft 1.7.10
You must be logged in to comment. Click here to register a new account or log in.
Hello so I love this modpack, first of all! Really challenging and unforgiving! I am, however experiencing a crash when I travel to a certain area of the overworld.... I have been able to save my save by turning draw distance to 2 and running faaaar away with my Ring of Dashing. It is fully updated so not ruins crash, I think? Any ideas?
TheBagGuy 7 years ago
I'd need a crash report to be able to see what's causing it.
Posted by TheEpicModPack 7 years ago | Modpack Creator
Here you are:
Posted by TheBagGuy 7 years ago
So im trying to make a server but when i click the start file the cmd pops out then says "press any key to continue" then the box disappears what do i dooooo please help!!!!!!!!!!
xXBlueDolphinXx 7 years ago
Hey xXBlueDolphinXx , I don't really know how to fix your problem but you are free to join our server ! :D
Posted by TheSinEater 7 years ago
This is usually a problem with java. Make sure you have java 8 jdk installed (not jre, which is the default java download). You may need to uninstall javal altogether and then install the java 8 JDK to make sure your server isn't trying to launch with another version. You can get the JDK here (make sure it is 64 bit):
Posted by TheEpicModPack 7 years ago | Modpack Creator
whenever I click "play" it loads for a bit, but never opens minecraft, and kicks me back into the technic launcher. Possible to fix?
TheMissingLink 7 years ago
I'll need a crash report in order to help you. Check your crash reports folder in your modpack directory for the most recent file, and post it to pastebin. Alternatively, play with the console open (via technic launcher options) and copy what it says in there when you crash.
Posted by TheEpicModPack 7 years ago | Modpack Creator
I know I already made a comment, but I have to say even though I'm just a normal modpack player, the sudden influx of People making public servers makes me so very happy. Thank you to those making them, and more importantly, thank you to the modpack creator for making it all possible. This is just amazing :D
Midnyte18 7 years ago
and we will keep hosting the server for ppl like you that want to have some fun on the modpack! :D
Posted by TheSinEater 7 years ago
Haha, glad you're enjoying the pack!
Posted by TheEpicModPack 7 years ago | Modpack Creator
Theepicmodpack can you give me and thesineater a way to contact you via skype or something? we've got a server up and would like it to be the official server. ~Michael Westen
greghead5 7 years ago
I don't use skype, but we can talk on here. What sort of maximum capacity do you have? You'll get a huge influx of players if I put it in the download (we have a ton more players for this pack than the plays/runs stat shows, it's broken).
Posted by TheEpicModPack 7 years ago | Modpack Creator
our server currently has 50 slots and can be upped if needed
Posted by greghead5 7 years ago
Hi Theepicmodpack! i can allocate a total of 32GB ram to the server , and its also hosted on a dedicated server , i just picked a random number to start off. atm the server had 15GB ram , and can hold 50 players ( could do more but just kept it at 50) wath do you think would be best to set player count on? we got ourselfs a spawn and are now working on the perms..... some players left bcs i forgot /back /home /sethome but thats fixed now ':) theres not much left to do , only a guild plugin and lanclaim , then just some ranks and stuff maby? we already got a logo / website /buycraft theme :D i hope you will support us with this! we think its better for players to just join a multiplayer server instead of a single player server bcs its easyer to run for some pc's! Greetings TheSinEater Aka Staticflame!
Posted by TheSinEater 7 years ago
Sounds like you have a good enough setup. Post the IP and I can add it to the default server list during the next update,
Posted by TheEpicModPack 7 years ago | Modpack Creator
Couly you add a lagg reducing MOD? we are currently having alot of TPS issues on the server ! tried installing this myself : but i couldent get it to work. server shouldent lagg with 15GB Ram , and Cpu: Intel Xeon E3-1230v3 Opslag: 120GB SSD RAID 1 the server ip is :
Posted by TheSinEater 7 years ago
That mod does not seem to be compatible with the modpack unfortunately (it is only in alpha so it likely doesn't have a lot of compatibility testing). As far as lag goes, you should not be having lag problems with a system like that, assuming you have allocated more RAM properly in the .bat file. Keep in mind, internet upload speed plays the biggest role in server latency. Your upload mbps will determine how fast the server runs with more players. Also, users will experience varying lag depending on their own internet, so if some players are lagging and not others, it is likely their own internet or location causing ping issues.
Posted by TheEpicModPack 7 years ago | Modpack Creator
It's also worth noting that I am running a personal server at the moment, and with only 5GB allocated to it and a 10 mbps upload speed I have not had any lag issues, so it might be something such as your java version (make sure you have JDK installed, not JRE) or improperly allocated RAM. Firewalls can cause problems also sometimes.
Posted by TheEpicModPack 7 years ago | Modpack Creator
Also, definitely don;t connect to the internet wirelessly.
Posted by TheEpicModPack 7 years ago | Modpack Creator
Okay , and we have another Item that we banned from the Modpack Farlanders its called : Mystic wand when i used it it made the server crash , so i banned it :D
Posted by TheSinEater 7 years ago
Is there a reason that Enchantment tables don't work to craft? I have the required elements and it doesn't work. The recipe listing doesn't show it as an output either. Is this a bug a design feature or a stupid user error?
BlazingCoconut 7 years ago
Crafting an enchanting table should make an advanced enchanting table (from enchanting plus mod). Let me know if this doesn't work for you
Posted by TheEpicModPack 7 years ago | Modpack Creator
Hi guys got it fixed setting up a 8 player server ( can expand ofc ) if all slots are full i will make it bigger : ip : hope you guys like it :D! Cracked ppl allowed :D!
TheSinEater 7 years ago
24/7 online bdw :D! dedicated server
Posted by TheSinEater 7 years ago
would you like to work together since i have a dedicated server for this as well?
Posted by greghead5 7 years ago
Public official server is in development atm only holds 4 people , will upgrade slots when i see a decent player base heres the IP:
greghead5 7 years ago
With the latest update any time you touch a thaumcraft item, like the writing table, it disappears. Relog and the item is there again, and appears, but if you try to use it it disappears.
hydrazine2501 7 years ago
I can't replicate this on my end to look into it unfortunately. I'd suggest re-installing the pack (and server files if you are using a server) and see if that helps, as that is very unusual.
Posted by TheEpicModPack 7 years ago | Modpack Creator
Also, make sure java and your graphics card drivers are up to date.
Posted by TheEpicModPack 7 years ago | Modpack Creator
Turns out it was a server install issue. We got it working.
Posted by hydrazine2501 7 years ago
Anyone have a server that is open to the public? I'm terrible with making my own (plus none of my friends want to play with me anyway ;-; )
Midnyte18 7 years ago
My gf and I are running a private server and sometimes attack animations of enemies, or even the whole mob is only viewable to one of us. This was particularly difficult when our house had mobs teleporting in and attacking. Dark Druids I belive.
Professor Loophole 7 years ago
I can't give me or my friends op permissions, thus none of us ca teleport or use any commands, NEI is also not appearing
Puffinsv1 7 years ago
Press O in your inventory to enable NEI. OP permissions should work by just using the /op command in console for the server. Any permissions outside that are handled by whatever plugin you are using for permissions.
Posted by TheEpicModPack 7 years ago | Modpack Creator
thank you sorry about that, but when I try to op in the console it tells me that it is an unknown command, and when I type /help it also says it is an unknown command
Posted by Puffinsv1 7 years ago
You don't use / when typing a command in the console, you would just type "help" or "op "
Posted by TheEpicModPack 7 years ago | Modpack Creator
Can you fix Chocolate Quest? One of my community members walked right into one of its dungeons which keeps forcing my server to close down. As I look at the command line, it has to do with Chocolate Quest, its dungeons.
JustChris 7 years ago
The problem dungeon was removed in the last update. Make sure you are using the latest server package. Deleting the file for that chunk and using the new server package should fix it.
Posted by TheEpicModPack 7 years ago | Modpack Creator
So is there anyone with a server that's looking for trustful players? I really want to try this pack with other people! I also got a buddy that could join as well.
AlexG 7 years ago
I, me to please (im without a buddy)
Posted by Calib 7 years ago
Come join us dude, we want a group, you too calib
Posted by Puffinsv1 7 years ago
I can't duel weld anything cause the camper mod remove's the button to get to the menu
Calib 7 years ago
As it says in the starter guide, you just have to press "I" and then click the "BG" button. I would set it to also work the original way, but I can't change the camping mod shortcut unfortunately, so we have to do it the new way.
Posted by TheEpicModPack 7 years ago | Modpack Creator
I found that the BG button wasn't showing for me, but pressing O brought up quite a few menus, including the BG one.
Posted by Kaeldo 7 years ago
Ah, yeah I may have to update the settings if that is off by default.
Posted by TheEpicModPack 7 years ago | Modpack Creator
2 things I have to say 1: The Locked Chests ruin the Millennial Mod 2. Make a server that people can play on
OGDubstepDemon 7 years ago
1. The locked chests are part of the entire purpose of millenaire (you have to play the mod to get them open). 2. I can't, my internet is not good enough.
Posted by TheEpicModPack 7 years ago | Modpack Creator
Love the mod pack except for the Spice Of Life mod. Highly suggest removing it, kinda annoying having to delete it every update.
Austindj3 7 years ago
No plans to remove it, as it adds a lot of purpose to other mods that would be dead weight otherwise (pam's harvestcraft etc.). You are definitely free to remove it though!
Posted by TheEpicModPack 7 years ago | Modpack Creator
O O OH.. Could you add Hardcore Ender expansion.. maybe :3
simonbee100 7 years ago
I tried it out, but removed it in the end. Honestly, I just found that it wasn't a very well done mod. If it expanded the end in a way that looked nicer/was more navigable I would add it, but adding a lot of floating spheres that mostly don't do anything to the end didn't really impress me much tbh.
Posted by TheEpicModPack 7 years ago | Modpack Creator
Fixed the ruins crash! New update is out (no new content this time, just bug fixes)
TheEpicModPack 7 years ago
Currently working on fixing the jungle temple crash. I don't think it will stop current crashes (deleting the offending chunk file will, though) but it will prevent the crash from happening in the future.
TheEpicModPack 7 years ago

Latest Update

Sorry for the lack of updates guys! In a few months I will be finished college, and will have time for plenty of updates! Keep giving me feedback!